aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-11-16 14:14:49 +0100
committerKoen Kooi <koen@openembedded.org>2008-11-16 14:14:49 +0100
commit8e0b54694967bd2c5742d50b72101c886983230a (patch)
treeee232eea6296ec8f97bc90fab2773318e2fb17cf
parentce5b19f9784561fb506bc564082e7a3d888a0c90 (diff)
downloadopenembedded-8e0b54694967bd2c5742d50b72101c886983230a.tar.gz
dsplink: remove obsolete files
-rw-r--r--packages/dsplink/codec-engine_2.10.bb154
-rw-r--r--packages/dsplink/files/CURRENTCFG.MK99
-rw-r--r--packages/dsplink/files/c64xx_5.xx_linux.mk223
-rw-r--r--packages/dsplink/files/cmemk-fix-class-device-api.diff89
-rw-r--r--packages/dsplink/files/openembedded.mk196
-rw-r--r--packages/dsplink/files/prcs-fix-include.patch50
6 files changed, 0 insertions, 811 deletions
diff --git a/packages/dsplink/codec-engine_2.10.bb b/packages/dsplink/codec-engine_2.10.bb
deleted file mode 100644
index abfe2f24e6..0000000000
--- a/packages/dsplink/codec-engine_2.10.bb
+++ /dev/null
@@ -1,154 +0,0 @@
-DESCRIPTION = "Codec Engine for TI ARM/DSP processors"
-
-DEPENDS = "virtual/kernel perl-native"
-RDEPENDS = "update-modules"
-
-inherit module
-
-# tconf from xdctools dislikes '.' in pwd :/
-PR = "r0"
-PV = "210"
-
-# Get CE tarball from TI website, place in sources and calculate
-# md5sum
-# Look for tarball at https://www-a.ti.com/downloads/sds_support/targetcontent/CE/index.html
-
-SRC_URI = "http://install.tarball.in.source.dir/codec_engine_2_10_01.tar.gz \
- file://xdcpaths.mak \
- "
-
-S = "${WORKDIR}/codec_engine_2_10_01"
-
-require ti-paths.inc
-
-PARALLEL_MAKE = ""
-
-do_configure() {
- cp ${WORKDIR}/xdcpaths.mak ${S}/examples/
- sed -i -e s:SEDME_TITOOLS_BASEPATH:${TITOOLSDIR}:g \
- -e s:SEDME_BIOSUNPACKDIR:${TITOOLSDIR}/${TIBIOSDIR}:g \
- -e 's:SEDME_S:${S}:g' \
- -e s:SEDME_XDCTOOLSUNPACKDIR:${TITOOLSDIR}/${TIXDCTOOLSDIR}:g \
- -e s:/db/toolsrc/library/tools/vendors/mvl/arm/mvl4.0-new/montavista/pro/devkit/arm/v5t_le:${CROSS_DIR}:g \
- -e s:bin/arm_v5t_le-gcc:bin/${TARGET_PREFIX}gcc:g \
- -e s:/db/toolsrc/library/tools/vendors/ti/c6x/6.0.16/Linux:${TITOOLSDIR}/${TICGTOOLSDIR}:g \
- ${S}/examples/xdcpaths.mak
-
- sed -i -e s:/db/toolsrc/library/tools/vendors/mvl/arm/mvl4.0-new/montavista/pro/devkit/arm/v5t_le:${CROSS_DIR}:g \
- -e s:/db/toolsrc/library/tools/vendors/ti/c6x/6.0.16/Linux:${TITOOLSDIR}/${TICGTOOLSDIR}:g \
- ${S}/examples/user.bld
-
- for cfg in ${S}/examples/ti/sdo/ce/examples/apps/image_copy/package/cfg/*/*cfg ; do
- sed -i -e s:arm_v5t_le-:${TAGET_PREFIX}:g $cfg
- done
-
- install -d ${S}/examples/ti/sdo/ce/examples/apps/speech/linuxonly/app/
- echo -n "${CFLAGS} -I${TITOOLSDIR}/${TIXDCTOOLSDIR}/packages -I${S}/packages -I${S}/cetools/packages" > ${S}/examples/ti/sdo/ce/examples/apps/speech/linuxonly/app/compiler.opt
-}
-
-do_compile() {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- cd ${S}/cetools/packages/ti/sdo/linuxutils/cmem
- sed -i \
- -e s:/db/toolsrc/library/vendors2005/mvl/arm/mvl4.0.1-root-new/montavista/pro/devkit/arm/v5t_le/bin/arm_v5t_le-:${TARGET_PREFIX}:g \
- -e s:/db/toolsrc/library/vendors2005/opensource/buildroot/10122007/build_arm/staging_dir/usr/bin/arm-linux-:${TARGET_PREFIX}:g \
- -e s:/db/toolsrc/library/vendors2005/mvl/arm/DaVinci-Linux-Rel_mvl401c/Linux:${STAGING_KERNEL_DIR}:g \
- -e s:/opt/mv_pro_4.0/montavista/pro/devkit/arm/v5t_le/target/opt/dvevm:${D}:g \
- Rules.make
-
- oe_runmake clean
- oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR} \
- KERNEL_SRC=${STAGING_KERNEL_DIR} \
- KERNEL_VERSION=${KERNEL_VERSION} \
- CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
- AR="${KERNEL_AR}" \
- release
- oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR} \
- KERNEL_SRC=${STAGING_KERNEL_DIR} \
- KERNEL_VERSION=${KERNEL_VERSION} \
- CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
- AR="${KERNEL_AR}" \
- debug
- oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR} \
- KERNEL_SRC=${STAGING_KERNEL_DIR} \
- KERNEL_VERSION=${KERNEL_VERSION} \
- CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
- AR="${KERNEL_AR}"
-
-# oe_runmake -C ${S}/examples/ti/sdo/ce/examples/apps
-
-}
-
-export DSPLIBS = "${S}/packages/ti/sdo/ce/utils/trace/lib/*.a* \
- ${S}/packages/ti/sdo/ce/bioslog/lib/*.a* \
- ${S}/packages/ti/sdo/ce/video/lib/*.a* \
- ${S}/packages/ti/sdo/ce/audio/lib/*.a* \
- ${S}/packages/ti/sdo/ce/speech/lib/*.a* \
- ${S}/packages/ti/sdo/ce/lib/*.a* \
- ${S}/packages/ti/sdo/ce/alg/lib/*.a* \
- ${S}/cetools/packages/ti/sdo/fc/dman3/*.a* \
- ${S}/cetools/packages/ti/sdo/fc/acpy3/*.a* \
- ${S}/packages/ti/sdo/ce/osal/linux/lib/osal_linux_470.a* \
- ${S}/packages/ti/sdo/ce/utils/xdm/lib/*.a* \
- ${S}/cetools/packages/ti/sdo/utils/trace/lib/*.a* \
- "
-
-do_install() {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- cd ${S}/cetools/packages/ti/sdo/linuxutils/cmem
- oe_runmake install
- install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
- mv ${D}/cmemk.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
- install -d ${D}/${base_sbindir}
- cd ${D} ; mv apitest apitestd multi_process multi_processd translate translated ${D}/${base_sbindir}
-
-
- install -d ${D}/${libdir}
- for i in ${DSPLIBS}; do
- install -m 0755 $i ${D}/${libdir}/ || true
- done
- install -m 0755 ${S}/cetools/packages/ti/sdo/linuxutils/cmem/lib/*.a ${D}/${libdir}
-}
-
-do_stage() {
- install -d ${STAGING_LIBDIR}
- for i in ${DSPLIBS} ; do
- install -m 0755 $i ${STAGING_LIBDIR}/
- ln -sf ${STAGING_LIBDIR}/$(basename $i | awk -F. '{print $1}').a470MV ${STAGING_LIBDIR}/$(basename $i | awk -F. '{print $1}').a || true
- done
-
- install -m 0755 ${S}/cetools/packages/ti/sdo/linuxutils/cmem/lib/*.a ${STAGING_LIBDIR}/
-
- install -d ${STAGING_INCDIR}/codec-engine}
-
- for header in $(find ${S}/cetools/packages/ -name "*.h") ; do
- install -d ${STAGING_INCDIR}/codec-engine/$(dirname $header | sed s:${S}::g)
- cp -pPr $header ${STAGING_INCDIR}/codec-engine/$(echo $header | sed s:${S}::g)
- done
-
- for header in $(find ${S}/packages/ -name "*.h") ; do
- install -d ${STAGING_INCDIR}/codec-engine/$(dirname $header | sed s:${S}::g)
- cp -pPr $header ${STAGING_INCDIR}/codec-engine/$(echo $header | sed s:${S}::g)
- done
-
-}
-
-pkg_postinst_${PN}-module () {
- if [ -n "$D" ]; then
- exit 1
- fi
- depmod -a
- update-modules || true
-}
-
-pkg_postrm_${PN}-module () {
- update-modules || true
-}
-
-PACKAGES =+ "dsplink-cmemk-module"
-FILES_dsplink-cmemk-module = "${sysconfdir} /lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/*ko"
-INHIBIT_PACKAGE_STRIP = "1"
-
-FILES_${PN} = "${base_sbindir}"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/packages/dsplink/files/CURRENTCFG.MK b/packages/dsplink/files/CURRENTCFG.MK
deleted file mode 100644
index 9e23bafe12..0000000000
--- a/packages/dsplink/files/CURRENTCFG.MK
+++ /dev/null
@@ -1,99 +0,0 @@
-# =========================================================
-# DSP/BIOS LINK Configuration file.
-#
-# CAUTION! This is a generated file.
-# All changes will be lost.
-#
-# This file was generated on MAY 14, 2008 11:53:09
-# =========================================================
-
-
-# =========================================================
-# When this file was created.
-# =========================================================
-export CFGDATE := MAY 14, 2008 11:53:09
-
-
-# =========================================================
-# DSP/BIOS LINK GPP side root directory.
-# =========================================================
-export GPPROOT := SED_ME_SOURCEDIR/gpp
-export DSPROOT := SED_ME_SOURCEDIR/dsp
-
-
-# =========================================================
-# GPP and DSP OS for which DSP/BIOS LINK is being built
-# =========================================================
-export GPPOS := Linux
-export DSPOS := DspBios
-
-
-# =========================================================
-# Specific distribution of GPP and DSP OS (if any)
-# =========================================================
-export GPPDISTRIBUTION := SED_ME_GPPDISTRO
-export GPPOSVERSION := SED_ME_KERNELVERSION
-export GPPOSVARIANT :=
-export DSPDISTRIBUTION := SED_ME_DSPDISTRO
-
-
-# =========================================================
-# Target GPP and DSP platforms for DSP/BIOS LINK
-# =========================================================
-export GPPPLATFORM := SED_ME_PLATFORM
-export DSPPLATFORM := SED_ME_PLATFORM
-
-
-# =========================================================
-# Target GPP and DSP devices
-# =========================================================
-export GPPDEVICE := SED_ME_PLATFORM
-export DSPDEVICE := SED_ME_DSP
-
-
-# =========================================================
-# Compile time scalability options for DSP/BIOS LINK
-# =========================================================
-export USE_PROC := 1
-export USE_POOL := 1
-export USE_NOTIFY := 1
-export USE_MPCS := 1
-export USE_RINGIO := 1
-export USE_MPLIST := 1
-export USE_MSGQ := 1
-export USE_CHNL := 1
-
-
-# =========================================================
-# Compile time physical link scalability options for device
-# =========================================================
-export USE_CHNL_ZCPY_LINK := 1
-export USE_CHNL_PCPY_LINK := 0
-export USE_MSGQ_ZCPY_LINK := 1
-export USE_MSGQ_PCPY_LINK := 0
-
-
-# =========================================================
-# Enable/ Disable trace
-# =========================================================
-export TRACE := 0
-
-
-# =========================================================
-# Enable/ Disable profiling
-# =========================================================
-export PROFILE := 0
-
-
-# =========================================================
-# Enable/ Disable probe
-# =========================================================
-export PROBE := 0
-
-
-# =========================================================
-# Platform Variant
-# =========================================================
-export VARIANT := SED_ME_SOC
-
-
diff --git a/packages/dsplink/files/c64xx_5.xx_linux.mk b/packages/dsplink/files/c64xx_5.xx_linux.mk
deleted file mode 100644
index 0a75c147ae..0000000000
--- a/packages/dsplink/files/c64xx_5.xx_linux.mk
+++ /dev/null
@@ -1,223 +0,0 @@
-# ============================================================================
-# @file c64xx_5.xx_linux.mk
-#
-# @path $(DSPLINK)/make/DspBios/
-#
-# @desc This makefile defines OS specific macros used by MAKE system for
-# the DSP/BIOS version 5.xx for C64XX on Linux.
-#
-# @ver 1.50
-# ============================================================================
-# Copyright (c) Texas Instruments Incorporated 2002-2007
-#
-# Use of this software is controlled by the terms and conditions found in the
-# license agreement under which this software has been supplied or provided.
-# ============================================================================
-
-
-ifndef C64XX_5_XX_LINUX_MK
-
-define C64XX_5_XX_LINUX_MK
-endef
-
-
-# ============================================================================
-# Let the make system know that a specific distribution for the GPP OS
-# is being used.
-# ============================================================================
-USE_DISTRIBUTION := 1
-
-
-# ============================================================================
-# Set the values of necessary variables to be used for the OS.
-# ============================================================================
-
-# ----------------------------------------------------------------------------
-# Base directory for the DSP OS
-# ----------------------------------------------------------------------------
-BASE_INSTALL := SEDME_TITOOLS_BASEPATH
-BASE_SABIOS := $(BASE_INSTALL)/SEDME_BIOSUNPACKDIR
-BASE_BUILDOS := $(BASE_SABIOS)/packages/ti/bios
-
-# ----------------------------------------------------------------------------
-# Base directory for the XDC tools
-# ----------------------------------------------------------------------------
-XDCTOOLS_DIR := $(BASE_SABIOS)/xdctools
-
-# ----------------------------------------------------------------------------
-# Base for code generation tools - compiler, linker, archiver etc.
-# ----------------------------------------------------------------------------
-BASE_CGTOOLS := $(BASE_INSTALL)/SEDME_CGTOOLSDIR
-BASE_CGTOOLSBIN := $(BASE_CGTOOLS)/bin
-
-# ----------------------------------------------------------------------------
-# Base for TCONF, platform files and dependent components
-# ----------------------------------------------------------------------------
-BASE_TCONF := $(XDCTOOLS_DIR)
-BASE_PLATFORMS := $(BASE_SABIOS)/packages
-BASE_CSL := $(BASE_INSTALL)/c6000/csl
-BASE_PSL := $(BASE_SABIOS)/packages/ti/psl
-BASE_RTDX := $(BASE_SABIOS)/packages/ti/rtdx
-
-
-# ----------------------------------------------------------------------------
-# Base directory for include files
-# ----------------------------------------------------------------------------
-BASE_OSINC := $(BASE_BUILDOS)/include
-BASE_CGTOOLSINC := $(BASE_CGTOOLS)/include
-BASE_RTDXINC := $(BASE_RTDX)/include/c6000
-BASE_PSLINC := $(BASE_PSL)/include
-BASE_CSLINC := $(BASE_CSL)/include
-
-OSINC_GENERIC := $(BASE_OSINC)
-OSINC_PLATFORM := $(BASE_CGTOOLSINC) $(BASE_CSLINC) $(BASE_RTDXINC) $(BASE_PSLINC)
-
-
-ifeq ($(PLATFORM), morpheus_dev)
-OSINC_PLATFORM += $(BASE_INSTALL)/boards/evmdm642/include
-endif # ifeq ($(PLATFORM), morpheus_dev)
-
-ifneq ("$(VARIANT)", "")
-OSINC_VARIANT := $(BASE_OSINC)
-endif
-
-
-# ----------------------------------------------------------------------------
-# Base directory for libraries
-# ----------------------------------------------------------------------------
-BASE_OSLIB := $(BASE_BUILDOS)/lib
-BASE_CGTOOLSLIB := $(BASE_CGTOOLS)/lib
-BASE_RTDXLIB := $(BASE_RTDX)/lib/c6000
-BASE_PSLLIB := $(BASE_PSL)/lib
-BASE_CSLLIB := $(BASE_CSL)/lib
-
-OSLIB_GENERIC := $(BASE_OSLIB)
-OSLIB_PLATFORM := $(BASE_CGTOOLSLIB) $(BASE_RTDXLIB) \
- $(BASE_PSLLIB) $(BASE_CSLLIB)
-
-ifeq ($(PLATFORM), morpheus_dev)
-OSLIB_PLATFORM += $(BASE_INSTALL)/boards/evmdm642/lib
-endif # ifeq ($(PLATFORM), morpheus_dev)
-
-ifeq ($(PLATFORM), DM642_PCI)
-OSLIB_PLATFORM += $(BASE_INSTALL)/boards/evmdm642/lib
-endif # ifeq ($(PLATFORM), DM642_PCI)
-
-ifneq ("$(VARIANT)", "")
-OSLIB_VARIANT := $(BASE_OSLIB)
-endif
-
-
-# ============================================================================
-# COMPILER
-# ============================================================================
-
-# ----------------------------------------------------------------------------
-# Name of the compiler
-# ----------------------------------------------------------------------------
-COMPILER := $(BASE_CGTOOLSBIN)/cl6x
-
-# ----------------------------------------------------------------------------
-# Command line switches used by the compiler
-#
-# CC_SW_DEF Command line defines
-# CC_SW_INC Search path for header files
-# CC_SW_OBJ Object file directory
-# CC_SW_DEB Include debug information
-# CC_SW_REL Release build
-# ----------------------------------------------------------------------------
-CC_SW_DEF := -d
-CC_SW_INC := -I
-CC_SW_OBJ := -fr
-CC_SW_DEB := -g -d"_DEBUG"
-CC_SW_REL := -o3
-
-# ----------------------------------------------------------------------------
-# Standard flags for the compiler
-# ----------------------------------------------------------------------------
-STD_CC_FLAGS := SEDME_DSPFLAGS
-
-# ----------------------------------------------------------------------------
-# Standard flags for the compiler when building an executable
-# ----------------------------------------------------------------------------
-EXE_CC_FLAGS :=
-
-# ----------------------------------------------------------------------------
-# Flags for the compiler when building an archive
-# ----------------------------------------------------------------------------
-ARC_CC_FLAGS :=
-
-# ----------------------------------------------------------------------------
-# Standard definitions for the compiler
-# ----------------------------------------------------------------------------
-STD_CC_DEFNS :=
-
-
-# ============================================================================
-# ARCHIVER
-# ============================================================================
-ARCHIVER := $(BASE_CGTOOLSBIN)/ar6x
-
-# ----------------------------------------------------------------------------
-# Standard flags for the archiver
-# ----------------------------------------------------------------------------
-STD_AR_FLAGS := -r
-
-# ----------------------------------------------------------------------------
-# Archiver flags for extracting object files
-# ----------------------------------------------------------------------------
-EXT_AR_FLAGS := xq
-
-
-# ============================================================================
-# LINKER
-# ============================================================================
-LINKER := $(BASE_CGTOOLSBIN)/cl6x -z
-
-# ----------------------------------------------------------------------------
-# Command line switches used by the linker
-#
-# LD_SW_INC Search path for libraries
-# LD_SW_LIB Include library name
-# LD_SW_OUT Output file name
-# LD_SW_MAP Map file name
-# LD_SW_RELOC Generate relocateable output
-# ----------------------------------------------------------------------------
-LD_SW_INC := -i
-LD_SW_LIB := -l
-LD_SW_OUT := -o
-LD_SW_MAP := -m
-LD_SW_RELOC := -r
-
-# ----------------------------------------------------------------------------
-# Standard flags for the linker
-# ----------------------------------------------------------------------------
-STD_LD_FLAGS := -c -x
-
-# ----------------------------------------------------------------------------
-# Flags for the linker when building an executable
-# ----------------------------------------------------------------------------
-EXE_LD_FLAGS :=
-
-ifeq ($(PLATFORM), morpheus_dev)
-EXE_LD_FLAGS += $(LD_SW_LIB)"cslDM642.lib"
-EXE_LD_FLAGS += $(LD_SW_LIB)"morpheus.lib"
-endif # ifeq ($(PLATFORM), morpheus_dev)
-
-ifeq ($(PLATFORM), DM642_PCI)
-EXE_LD_FLAGS += $(LD_SW_LIB)"cslDM642.lib"
-endif # ifeq ($(PLATFORM), DM642_PCI)
-
-# ============================================================================
-# TCONF
-# ============================================================================
-TCONF := $(BASE_TCONF)/tconf
-
-
-# ----------------------------------------------------------------------------
-# Standard flags for TCONF
-# ----------------------------------------------------------------------------
-STD_TCF_FLAGS :=
-
-
-endif # ifndef C64XX_5_XX_LINUX_MK
diff --git a/packages/dsplink/files/cmemk-fix-class-device-api.diff b/packages/dsplink/files/cmemk-fix-class-device-api.diff
deleted file mode 100644
index c42e6ae927..0000000000
--- a/packages/dsplink/files/cmemk-fix-class-device-api.diff
+++ /dev/null
@@ -1,89 +0,0 @@
---- codec_engine_2_21_00_06/cetools/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.c 2008-09-26 02:26:04.000000000 +0200
-+++ codec_engine_2_21_00_06/cetools/packages/ti/sdo/linuxutils/cmem/src/module/cmemk.c 2008-10-30 11:57:54.000000000 +0100
-@@ -42,11 +26,20 @@
- * USE_CLASS_SIMPLE - #define if Linux version contains class_simple,
- * otherwise class is used (Linux supports one or the other, not both)
- */
--#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,18)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,26)
-
--#warning LINUX_VERSION_CODE >= 2.6.18
-+#warning LINUX_VERSION_CODE >= 2.6.26
-+
-+#define USE_CACHE_VOID_ARG
-+#undef USE_CLASS_DEVICE
-+#undef USE_CLASS_SIMPLE
-+
-+#elif LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,18)
-+
-+#warning 2.6.26 > LINUX_VERSION_CODE >= 2.6.18
-
- #define USE_CACHE_VOID_ARG
-+#define USE_CLASS_DEVICE
- #undef USE_CLASS_SIMPLE
-
- #else /* LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,18) */
-@@ -54,6 +47,7 @@
- #warning LINUX_VERSION_CODE < 2.6.18
-
- #define USE_CLASS_SIMPLE
-+#undef USE_CLASS_DEVICE
- #undef USE_CACHE_VOID_ARG
-
- #endif /* LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,18) */
-@@ -1697,12 +1691,12 @@
- #ifdef USE_CLASS_SIMPLE
- class_simple_device_add(cmem_class, MKDEV(cmem_major, 0), NULL, "cmem");
- #else
--/*
-- Use the following for newer GIT releases ( > 2.6.25?)
-- device_create(cmem_class, NULL, MKDEV(cmem_major, 0), "cmem");
--*/
-+#ifdef USE_CLASS_DEVICE
- class_device_create(cmem_class, NULL, MKDEV(cmem_major, 0), NULL, "cmem");
--#endif
-+#else
-+ device_create(cmem_class, NULL, MKDEV(cmem_major, 0), "cmem");
-+#endif // USE_CLASS_DEVICE
-+#endif // USE_CLASS_SIMPLE
- #endif // USE_UDEV
-
- pstart[0] = phys_start;
-@@ -1862,13 +1856,13 @@
- class_simple_device_remove(MKDEV(cmem_major, 0));
- class_simple_destroy(cmem_class);
- #else
--/*
-- Use the following for newer GIT releases ( > 2.6.25?)
-- device_destroy(cmem_class, MKDEV(cmem_major, 0));
--*/
-+#ifdef USE_CLASS_DEVICE
- class_device_destroy(cmem_class, MKDEV(cmem_major, 0));
-+#else
-+ device_destroy(cmem_class, MKDEV(cmem_major, 0));
-+#endif // USE_CLASS_DEVICE
- class_destroy(cmem_class);
--#endif
-+#endif // USE_CLASS_SIMPLE
-
- #endif // USE_UDEV
-
-@@ -1938,13 +1932,13 @@
- class_simple_device_remove(MKDEV(cmem_major, 0));
- class_simple_destroy(cmem_class);
- #else
--/*
-- Use the following for newer GIT releases ( > 2.6.25?)
-- device_destroy(cmem_class, MKDEV(cmem_major, 0));
--*/
-+#ifdef USE_CLASS_DEVICE
- class_device_destroy(cmem_class, MKDEV(cmem_major, 0));
-+#else
-+ device_destroy(cmem_class, MKDEV(cmem_major, 0));
-+#endif // USE_CLASS_DEVICE
- class_destroy(cmem_class);
--#endif
-+#endif // USE_CLASS_SIMPLE
-
- #endif // USE_UDEV
-
diff --git a/packages/dsplink/files/openembedded.mk b/packages/dsplink/files/openembedded.mk
deleted file mode 100644
index aaf241ad14..0000000000
--- a/packages/dsplink/files/openembedded.mk
+++ /dev/null
@@ -1,196 +0,0 @@
-# ============================================================================
-# @file davinci_mvlpro5.0.mk
-#
-# @path $(DSPLINK)/make/Linux/
-#
-# @desc This makefile defines OS specific macros used by MAKE system for
-# the Montavista Pro 5.0 Linux distribution.
-#
-# @ver 1.50
-# ============================================================================
-# Copyright (c) Texas Instruments Incorporated 2002-2007
-#
-# Use of this software is controlled by the terms and conditions found in the
-# license agreement under which this software has been supplied or provided.
-# ============================================================================
-
-
-ifndef DAVINCI_MVLPRO5_0_MK
-
-define DAVINCI_MVLPRO5_0_MK
-endef
-
-
-# ============================================================================
-# Let the make system know that a specific distribution for the GPP OS
-# is being used.
-# ============================================================================
-USE_DISTRIBUTION := 1
-
-
-# ============================================================================
-# Set the values of necessary variables to be used for the OS.
-# ============================================================================
-
-# ----------------------------------------------------------------------------
-# Base directory for the GPP OS
-# ----------------------------------------------------------------------------
-BASE_BUILDOS := SED_ME_KERNELDIR
-
-# ----------------------------------------------------------------------------
-# Base for code generation tools - compiler, linker, archiver etc.
-# ----------------------------------------------------------------------------
-BASE_CGTOOLS := /opt/montavista/pro/devkit/arm/v5t_le/bin
-
-# ----------------------------------------------------------------------------
-# Base directory for include files provided by GPP OS
-# ----------------------------------------------------------------------------
-BASE_OSINC := $(BASE_BUILDOS)/include
-
-OSINC_GENERIC := $(BASE_OSINC)
-OSINC_PLATFORM := SED_ME_CROSS/4.2.0/include
-OSINC_TARGET := SED_ME_STAGINGDIR/usr/include
-
-ifneq ("$(VARIANT)", "")
-OSINC_VARIANT := $(BASE_OSINC)
-endif
-
-
-# ----------------------------------------------------------------------------
-# Base directory for libraries provided by GPP OS
-# ----------------------------------------------------------------------------
-BASE_OSLIB := SED_ME_STAGINGDIR/lib
-
-OSLIB_GENERIC := $(BASE_OSLIB)
-OSLIB_PLATFORM := $(BASE_OSLIB)
-
-
-ifneq ("$(VARIANT)", "")
-OSLIB_VARIANT := $(BASE_OSLIB)
-endif
-
-
-# ============================================================================
-# COMPILER
-# ============================================================================
-
-# ----------------------------------------------------------------------------
-# Name of the compiler
-# ----------------------------------------------------------------------------
-COMPILER := SED_ME_TARGET_PREFIXgcc
-LD := SED_ME_TARGET_PREFIXld
-
-CROSS_COMPILE := SED_ME_TARGET_PREFIX
-export CROSS_COMPILE
-
-# ----------------------------------------------------------------------------
-# Command line switches used by the compiler
-#
-# CC_SW_DEF Command line defines
-# CC_SW_INC Search path for header files
-# CC_SW_OBJ Create object file
-# CC_SW_DEB Include debug information
-# ----------------------------------------------------------------------------
-CC_SW_DEF := -D
-CC_SW_INC := -I
-CC_SW_OBJ := -o
-CC_SW_DEB := -g
-
-# ----------------------------------------------------------------------------
-# Standard flags for the compiler
-# ----------------------------------------------------------------------------
-STD_KRNL_FLAGS := SEDME_KERNEL_ARMFLAGS
-STD_USER_FLAGS := -mlittle-endian SEDME_USER_ARMFLAGS -msoft-float \
- -Uarm -Wdeclaration-after-statement -marm -Wall \
- -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing \
- -fno-common -fno-omit-frame-pointer -mapcs -c \
- -mabi=aapcs-linux
-
-# ----------------------------------------------------------------------------
-# Standard flags for the compiler when building an executable
-# ----------------------------------------------------------------------------
-EXE_CC_FLAGS :=
-
-# ----------------------------------------------------------------------------
-# Flags for the compiler when building a driver
-# ----------------------------------------------------------------------------
-DRV_CC_FLAGS := -nostdinc
-
-# ----------------------------------------------------------------------------
-# Flags for the compiler when building a library
-# ----------------------------------------------------------------------------
-LIB_CC_FLAGS :=
-
-# ----------------------------------------------------------------------------
-# Standard definitions for the compiler
-# ----------------------------------------------------------------------------
-STD_CC_DEFNS := -D_REENTRANT
-
-
-# ============================================================================
-# ARCHIVER1 - This denotes the linker.
-# ============================================================================
-ARCHIVER1 := SED_ME_TARGET_PREFIXld
-
-# ----------------------------------------------------------------------------
-# Standard flags for the archiver
-# ----------------------------------------------------------------------------
-STD_AR_FLAGS1 := -EL -r
-
-
-# ============================================================================
-# ARCHIVER2 - This denotes the archiver.
-# ============================================================================
-ARCHIVER2 := SED_ME_TARGET_PREFIXar
-
-# ----------------------------------------------------------------------------
-# Standard flags for the archiver
-# ----------------------------------------------------------------------------
-STD_AR_FLAGS2 := -r
-
-
-# ============================================================================
-# LINKER - The compiler is used for linking purpose as well.
-# ============================================================================
-LINKER := SED_ME_TARGET_PREFIXgcc
-
-# ----------------------------------------------------------------------------
-# Command line switches used by the linker
-#
-# LD_SW_LIB Search path for libraries
-# LD_SW_OUT Output filename
-# LD_SW_RELOC Generate relocateable output
-# ----------------------------------------------------------------------------
-LD_SW_LIB := -L
-LD_SW_OUT := -o
-LD_SW_RELOC := -r
-
-# ----------------------------------------------------------------------------
-# Standard flags for the linker
-# ----------------------------------------------------------------------------
-STD_LD_FLAGS :=
-
-# ----------------------------------------------------------------------------
-# Specific flags for the linker if linking and module generating utility are
-# different
-# ----------------------------------------------------------------------------
-SPECIFIC_LD_FLAGS := -lpthread
-
-# ----------------------------------------------------------------------------
-# Flags for the linker when building an executable
-# ----------------------------------------------------------------------------
-EXE_LD_FLAGS := -lc
-
-# ----------------------------------------------------------------------------
-# Flags for the linker when building a driver
-# ----------------------------------------------------------------------------
-DRV_LD_FLAGS :=
-
-
-# ============================================================================
-# Post processing utilities for Linux 2.6
-# ============================================================================
-CMD_MODPOST := $(BASE_BUILDOS)/scripts/mod/modpost -i $(BASE_BUILDOS)/Module.symvers $(BASE_BUILDOS)/vmlinux
-
-
-endif # ifndef DAVINCI_MVLPRO5_0_MK
diff --git a/packages/dsplink/files/prcs-fix-include.patch b/packages/dsplink/files/prcs-fix-include.patch
deleted file mode 100644
index 421bd706f7..0000000000
--- a/packages/dsplink/files/prcs-fix-include.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- /tmp/prcs.c 2008-05-15 20:35:49.946802023 +0200
-+++ dsplink_1_50/dsplink/gpp/src/osal/Linux/prcs.c 2008-05-15 20:36:01.386858569 +0200
-@@ -17,6 +17,7 @@
-
- /* ----------------------------------- OS Specific Headers */
- #include <linux/autoconf.h>
-+#include <linux/sched.h>
- #include <linux/spinlock.h>
- #include <linux/module.h>
- #include <linux/mm.h>
-
---- dvevm_1_00_00_32.orig/dsplink_1_30_07ce/packages/dsplink_dm420/gpp/src/osal/Linux/2.6/isr.c
-+++ dsplink_1_50/dsplink/gpp/src/osal/Linux/2.6.18/isr.c
-@@ -130,7 +130,7 @@ struct IsrObject_tag {
- */
- STATIC
- irqreturn_t
--ISR_Callback (int irq, void * arg, struct pt_regs * flags) ;
-+ISR_Callback (int irq, void * arg) ;
-
-
- /* ============================================================================
-@@ -664,7 +664,7 @@ ISR_Debug ()
- */
- STATIC
- irqreturn_t
--ISR_Callback (int irq, void * arg, struct pt_regs * flags)
-+ISR_Callback (int irq, void * arg)
- {
- DSP_STATUS status = DSP_SOK ;
- IsrObject * isrObj = (IsrObject *) (arg) ;
-
---- /tmp/mem.c 2008-06-22 16:05:16.000000000 +0200
-+++ dsplink_1_50/dsplink/gpp/src/osal/Linux/2.6.18/mem.c 2008-06-22 16:05:43.000000000 +0200
-@@ -16,6 +16,7 @@
-
-
- /* ----------------------------------- OS Specific Headers */
-+
- #include <linux/autoconf.h>
- #include <linux/spinlock.h>
- #if (defined(DM642_PCI) || defined (DM64LC_PCI))
-@@ -31,6 +32,7 @@
- #endif /* if (defined(DM642_PCI) || defined (DM64LC_PCI)) */
- #include <linux/vmalloc.h>
- #include <asm/io.h>
-+#include <linux/sched.h>
-
- /* ----------------------------------- DSP/BIOS Link */
- #include <dsplink.h>