aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2008-11-16 13:58:54 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-11-16 13:58:54 +0100
commitce5b19f9784561fb506bc564082e7a3d888a0c90 (patch)
tree6859f52afd7fc3399fa1c21b8d3e297d980cd2f0
parentfe55a9ac61c0b94e2565fe6a8713c90f37ec86fc (diff)
parent70cb225447f65d260b7b4e95e3db9dcc20ddac15 (diff)
downloadopenembedded-ce5b19f9784561fb506bc564082e7a3d888a0c90.tar.gz
Merge branch 'holger/openmoko-merges' into org.openembedded.dev
-rw-r--r--packages/openmoko-projects/illume-theme-asu_svn.bb44
1 files changed, 29 insertions, 15 deletions
diff --git a/packages/openmoko-projects/illume-theme-asu_svn.bb b/packages/openmoko-projects/illume-theme-asu_svn.bb
index 5ddb61d0eb..e232dbb554 100644
--- a/packages/openmoko-projects/illume-theme-asu_svn.bb
+++ b/packages/openmoko-projects/illume-theme-asu_svn.bb
@@ -1,27 +1,41 @@
DESCRIPTION = "Illume - Mobile UI module for Enlightenment"
HOMEPAGE = "http://illume.projects.openmoko.org/"
LICENSE = "MIT/BSD"
+DEPENDS = "edje-native eet-native"
+RPROVIDES_${PN} = "illume-theme"
+RCONFLICTS = "illume-config"
PV = "0.0+svnr${SRCREV}"
-PR = "r6"
-
-SRC_URI = "svn://svn.projects.openmoko.org/svnroot/;module=illume;proto=http"
-S = "${WORKDIR}/illume"
+PR = "r9"
-do_install() {
- install -d ${D}${sysconfdir}/enlightenment
- install -d ${D}${datadir}/enlightenment/data/themes/
- install -d ${D}${datadir}/enlightenment/data/init/
+SRC_URI = "svn://svn.openmoko.org/trunk/src/target/themes/;module=illume-theme-asu;proto=http"
- # Make illume the default profile
- echo 'E_PROFILE="-profile illume"' > ${D}${sysconfdir}/enlightenment/default_profile
+S = "${WORKDIR}/illume-theme-asu"
- install -m 0644 ${S}/misc-data/illume.edj ${D}${datadir}/enlightenment/data/themes/
- install -m 0644 ${S}/misc-data/illume_init.edj ${D}${datadir}/enlightenment/data/init/
+do_compile() {
+ cd misc-data/asu && ./build.sh && cd ../..
+ cd misc-data/asu_init && ./build.sh && cd ../..
+ cd config
+ eet -e e.cfg config e.src 1
+ eet -e module.battery.cfg config module.battery.src 1
+ eet -e module.illume.cfg config module.illume.src 1
}
-RPROVIDES_${PN} = "illume-theme"
-CONFFILES_${PN} = "${sysconfdir}/enlightenment/default_profile"
-FILES_${PN} = "${sysconfdir}/enlightenment ${datadir}/enlightenment"
+do_install() {
+ install -d ${D}${sysconfdir}/enlightenment
+ install -d ${D}${datadir}/enlightenment/data/themes
+ install -d ${D}${datadir}/enlightenment/data/init
+ install -d ${D}${datadir}/enlightenment/data/config/asu
+ # Make asu the default profile
+ echo 'E_PROFILE="-profile asu"' > ${D}${sysconfdir}/enlightenment/default_profile
+ install -m 0644 ${S}/misc-data/asu/asu.edj ${D}${datadir}/enlightenment/data/themes/asu.edj
+ install -m 0644 ${S}/misc-data/asu_init/asu_init.edj ${D}${datadir}/enlightenment/data/init/asu_init.edj
+ install -m 0644 ${S}/config/*.cfg ${D}${datadir}/enlightenment/data/config/asu
+}
PACKAGE_ARCH_${PN} = "all"
+PACKAGES = "\
+ ${PN} \
+"
+FILES_${PN} = "${sysconfdir}/enlightenment ${datadir}/enlightenment"
+CONFFILES_${PN} = "${sysconfdir}/enlightenment/default_profile"