aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-11-17 20:43:26 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-11-17 23:15:17 +0100
commite5ec376d033256003416ec4be125af99e4cc75a4 (patch)
tree00830c3ebdda255389cfefbfaf1a4151e1aac36a
parent867e1804a6824e55b977cb42adcef85abfe59435 (diff)
downloadopenembedded-e5ec376d033256003416ec4be125af99e4cc75a4.tar.gz
sip-native: add version 4.7.8
-rw-r--r--packages/sip/sip-native_4.7.8.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/sip/sip-native_4.7.8.bb b/packages/sip/sip-native_4.7.8.bb
new file mode 100644
index 0000000000..eace44359d
--- /dev/null
+++ b/packages/sip/sip-native_4.7.8.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "SIP is a C++/Python Wrapper Generator"
+SECTION = "devel"
+HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip"
+AUTHOR = "Phil Thompson"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "ml0"
+
+SRC_URI = "http://www.riverbankcomputing.co.uk/static/Downloads/sip4/sip-${PV}.tar.gz"
+S = "${WORKDIR}/sip-${PV}/sipgen"
+
+inherit qt4x11 native
+
+export BUILD_SYS
+export HOST_SYS
+export STAGING_LIBDIR
+export STAGING_INCDIR
+
+EXTRA_QMAKEVARS_POST += "DESTDIR=${S} CONFIG=console"
+
+do_configure_prepend() {
+ cat sipgen.sbf | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, > sipgen.pro
+}
+
+do_stage() {
+ install -m 0755 sip ${STAGING_BINDIR_NATIVE}/sip
+ cd ${WORKDIR}/sip-${PV} && python configure.py
+ install -d ${STAGING_PYDIR}/site-packages
+ install -m 0755 sip*.py ${STAGING_PYDIR}/site-packages
+}