aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-11-01 12:27:24 -0700
committerTom Rini <tom_rini@mentor.com>2010-11-01 12:27:24 -0700
commit0de2221d3b4412cc018dfa3b25cf42f64dba49ea (patch)
tree168d42165762084fb6aa5e7ea2ce723caeb3eaf9
parent28f78abeed4e1e98b1395d87300f63ce0d4129ae (diff)
downloadopenembedded-0de2221d3b4412cc018dfa3b25cf42f64dba49ea.tar.gz
stage-manager: Fix removal of installed packages
Currently, the status line for installed pstaging packages will ready 'Status: install user installed' but we check for 'install ok installed' so the check fails and we don't remove. Fix the check to look for user rather than ok. Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rwxr-xr-xrecipes/stage-manager/files/stage-manager-ipkg2
-rw-r--r--recipes/stage-manager/stagemanager-native_0.0.1.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes/stage-manager/files/stage-manager-ipkg b/recipes/stage-manager/files/stage-manager-ipkg
index 53c172e77a..105ea5458a 100755
--- a/recipes/stage-manager/files/stage-manager-ipkg
+++ b/recipes/stage-manager/files/stage-manager-ipkg
@@ -431,7 +431,7 @@ ipkg_status_matching() {
ipkg_status_installed_sd() {
local sd="$1"
local pkg="$2"
- ipkg_status_sd $sd $pkg Status | grep -q "Status: install ok installed"
+ ipkg_status_sd $sd $pkg Status | grep -q "Status: install user installed"
}
ipkg_status_installed_all() {
diff --git a/recipes/stage-manager/stagemanager-native_0.0.1.bb b/recipes/stage-manager/stagemanager-native_0.0.1.bb
index b54c38df02..957774911c 100644
--- a/recipes/stage-manager/stagemanager-native_0.0.1.bb
+++ b/recipes/stage-manager/stagemanager-native_0.0.1.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Helper script for packaged-staging.bbclass"
-PR = "r14"
+PR = "r15"
SRC_URI = "file://stage-manager \
file://stage-manager-ipkg \