aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2010-10-30 21:42:31 +0300
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2010-11-03 16:51:17 +0100
commit47bc7b62872aa5aedbcfb21539c0d087411f6eb8 (patch)
tree0144318a8eac4413910d533b3e95d911a867b2c6
parentdb07755b857885d294256dcafbb0322bb9de056d (diff)
downloadopenembedded-47bc7b62872aa5aedbcfb21539c0d087411f6eb8.tar.gz
mplayer: Added support for mipsel processors for version 1.0rc2.
* Added mipsel-support.patch, which adds the correct hooks in configure for compiling mplayer for a mipsel processor. * Modified mplayer-0.0+1.0rc2, adding the above patch to SRC_URI. Signed-off-by: Alex Ferguson <thoughtmonster@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
-rw-r--r--recipes/mplayer/files/mipsel-support.patch46
-rw-r--r--recipes/mplayer/mplayer_0.0+1.0rc2.bb1
2 files changed, 47 insertions, 0 deletions
diff --git a/recipes/mplayer/files/mipsel-support.patch b/recipes/mplayer/files/mipsel-support.patch
new file mode 100644
index 0000000000..5958adb787
--- /dev/null
+++ b/recipes/mplayer/files/mipsel-support.patch
@@ -0,0 +1,46 @@
+diff -ru MPlayer-1.0rc2.orig/configure MPlayer-1.0rc2/configure
+--- MPlayer-1.0rc2.orig/configure 2007-10-07 22:49:33.000000000 +0300
++++ MPlayer-1.0rc2/configure 2010-10-19 19:28:37.126493496 +0300
+@@ -1233,7 +1233,7 @@
+ # host's CPU/instruction set
+ host_arch=`uname -p 2>&1`
+ case "$host_arch" in
+- i386|sparc|ppc|alpha|arm|sh3|mips|vax)
++ i386|sparc|ppc|alpha|arm|sh3|mips|mipsel|vax)
+ ;;
+ powerpc) # Darwin returns 'powerpc'
+ host_arch=ppc
+@@ -1266,6 +1266,7 @@
+ s390) host_arch=s390 ;;
+ s390x) host_arch=s390x ;;
+ mips*) host_arch=mips ;;
++ mipsel*) host_arch=mipsel ;;
+ vax) host_arch=vax ;;
+ *) host_arch=UNKNOWN ;;
+ esac
+@@ -1631,7 +1632,7 @@
+ fi
+
+
+-_arch_all='X86 X86_32 X86_64 IA64 SPARC ARM ARMV4L SH3 POWERPC PPC ALPHA SGI_MIPS PA_RISC S390 S390X VAX BFIN GENERIC'
++_arch_all='X86 X86_32 X86_64 IA64 SPARC ARM ARMV4L SH3 POWERPC PPC ALPHA SGI_MIPS MIPSEL PA_RISC S390 S390X VAX BFIN GENERIC'
+ case "$host_arch" in
+ i[3-9]86|x86|x86pc|k5|k6|k6-2|k6-3|pentium*|athlon*|i586-i686)
+ _arch='X86 X86_32'
+@@ -2206,6 +2207,16 @@
+
+ ;;
+
++ mipsel)
++ _arch='MIPSEL'
++ _target_arch='ARCH_MIPSEL = yes'
++ iproc='mipsel'
++ proc=''
++ _march='-march=mips32'
++ _mcpu=''
++ _optimizing=''
++ ;;
++
+ hppa)
+ _arch='PA_RISC'
+ _target_arch='ARCH_PA_RISC = yes'
diff --git a/recipes/mplayer/mplayer_0.0+1.0rc2.bb b/recipes/mplayer/mplayer_0.0+1.0rc2.bb
index 4c4d590e7d..3ab953528b 100644
--- a/recipes/mplayer/mplayer_0.0+1.0rc2.bb
+++ b/recipes/mplayer/mplayer_0.0+1.0rc2.bb
@@ -29,6 +29,7 @@ SRC_URI = "http://www1.mplayerhq.hu/MPlayer/releases/MPlayer-1.0rc2.tar.bz2 \
file://pxa_configure.patch \
file://pxa-video_out.patch \
file://motion-comp-pld.patch \
+ file://mipsel-support.patch \
file://ivtv-fix.patch "
# This is required for the collie machine only as all stacks in that