aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Balister <philip@opensdr.com>2010-11-03 11:55:22 -0400
committerPhilip Balister <philip@opensdr.com>2010-11-03 12:49:10 -0400
commit500e8f790ae71b4ac0b87a3c2840b9a7a9376a27 (patch)
tree274d026b1941011d7b30216ef79be22472da42c2
parent5764ede4ad59960d2a00fe9fc762233bef6a9d1e (diff)
downloadopenembedded-500e8f790ae71b4ac0b87a3c2840b9a7a9376a27.tar.gz
uhd-firmware : Add recipe to install USRP firmware into images.
-rw-r--r--recipes/uhd/uhd-firmware_0.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/uhd/uhd-firmware_0.1.bb b/recipes/uhd/uhd-firmware_0.1.bb
new file mode 100644
index 0000000000..dd48954e3f
--- /dev/null
+++ b/recipes/uhd/uhd-firmware_0.1.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Universal Hardware Driver Firmware"
+HOMEPAGE = "http://www.ettus.com"
+LICENSE = "GPLv3"
+
+SRC_URI = "http://www.ettus.com/downloads/uhd_images/UHD-images-20100901.003255.b5461fc%20--%20most%20recent/UHD-images-20100901.003255.b5461fc-Linux.tar.gz"
+
+# Yes, matching the directory name to package version is annoying
+S = ${WORKDIR}/UHD-images-20100901.003255.b5461fc-Linux
+
+do_install() {
+ install -d ${D}${datadir}/uhd/images
+ install -m 0644 ${S}/share/uhd/images/* ${D}${datadir}/uhd/images
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} = ${datadir}/uhd/images
+