aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-27 13:52:05 -0700
committerChris Larson <chris_larson@mentor.com>2010-10-27 13:52:05 -0700
commit8759bb71e5d511694ce7166d72a76244e2561363 (patch)
treebcccd18e54b60f52efa0c93521e3d4a21866d5d3
parentd79f536f2b3dc6a7cce86529f1c8753859e8f06e (diff)
downloadopenembedded-8759bb71e5d511694ce7166d72a76244e2561363.tar.gz
which: add recipe, versions 2.17 and 2.20
2.17 is the most recent version which was still GPLv2+, and 2.20 is the latest which is now GPLv3+. Signed-off-by: Chris Larson <chris_larson@mentor.com>
-rw-r--r--MAINTAINERS3
-rw-r--r--recipes/which/which.inc15
-rw-r--r--recipes/which/which_2.17.bb7
-rw-r--r--recipes/which/which_2.20.bb7
4 files changed, 31 insertions, 1 deletions
diff --git a/MAINTAINERS b/MAINTAINERS
index e7ec4eee38..0fd01c1f01 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -37,7 +37,8 @@ Machines: simpad
Person: Christopher Larson
Mail: clarson@kergoth.com
Recipes: autoconf, automake, libtool, gnu-config
-Recipes: autotools*.bbclass, gzip, lzip, ed, genromfs
+Recipes: gzip, lzip, ed, genromfs, which
+Classes: autotools.bbclass
Person: Cliff Brake
Mail: cbrake@bec-systems.com
diff --git a/recipes/which/which.inc b/recipes/which/which.inc
new file mode 100644
index 0000000000..ad7eed751b
--- /dev/null
+++ b/recipes/which/which.inc
@@ -0,0 +1,15 @@
+inherit autotools
+
+DESCRIPTION = "shows the full path of (shell) commands"
+HOMEPAGE = "http://www.xs4all.nl/~carlo17/which/"
+INC_PR = "0"
+
+SRC_URI = "http://www.xs4all.nl/~carlo17/which/which-${PV}.tar.gz"
+
+EXTRA_OECONF += "--disable-iberty"
+
+do_configure () {
+ oe_runconf
+}
+
+BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes/which/which_2.17.bb b/recipes/which/which_2.17.bb
new file mode 100644
index 0000000000..6c47601d39
--- /dev/null
+++ b/recipes/which/which_2.17.bb
@@ -0,0 +1,7 @@
+require which.inc
+
+LICENSE = "GPLv2+"
+PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "c9d33b7c8ce5acc69105e13d56ef0dad"
+SRC_URI[sha256sum] = "176fe9c451487eda787dd58d9469d48c95509f49dbb34a574004a936905dd6da"
diff --git a/recipes/which/which_2.20.bb b/recipes/which/which_2.20.bb
new file mode 100644
index 0000000000..8dc42d7652
--- /dev/null
+++ b/recipes/which/which_2.20.bb
@@ -0,0 +1,7 @@
+require which.inc
+
+LICENSE = "GPLv3+"
+PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "95be0501a466e515422cde4af46b2744"
+SRC_URI[sha256sum] = "d417b65c650d88ad26a208293c1c6e3eb60d4b6d847f01ff8f66aca63e2857f8"