aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Menzel <paulepanter@users.sourceforge.net>2010-11-03 09:52:36 +0100
committerKoen Kooi <koen@openembedded.org>2010-11-03 11:34:17 +0100
commit93dca1c604d420ed4db44a71a375182933658886 (patch)
treefa4323df843d57d6cfebcf747b5a9c4c6236b835
parent61a4d1805c6c73091dd2264c0f84ee3264cc05a6 (diff)
downloadopenembedded-93dca1c604d420ed4db44a71a375182933658886.tar.gz
openembedded-93dca1c604d420ed4db44a71a375182933658886.tar.bz2
openembedded-93dca1c604d420ed4db44a71a375182933658886.zip
vlc_1.1.4.1: add `lua5.1` to `DEPENDS`
After VLC 1.0.6, being the latest version in OE until addition of 1.1.4.1 in commit 30e362 [2], some interfaces were implemented in Lua in VLC 1.1.0 [1]. Interfaces: * Renamed the legacy rc, telnet and http interfaces to oldrc, oldtelnet and oldhttp. * rc, telnet and http are now implemented using the lua interface system. Task `configure` fails with the following error message. […] | checking for LUA... no | configure: WARNING: lua5.1 not found, trying lua >= 5.1 instead | checking for LUA... no | checking lua.h usability... no | checking lua.h presence... no | checking for lua.h... no | checking lauxlib.h usability... no | checking lauxlib.h presence... no | checking for lauxlib.h... no | checking lualib.h usability... no | checking lualib.h presence... no | checking for lualib.h... no | checking for luaL_newstate in -llua5.1 ... no | checking for luaL_newstate in -llua51 ... no | checking for luaL_newstate in -llua ... no | configure: error: Could not find lua. Lua is needed for some interfaces (rc, telnet, http) as well as many other custom scripts. Use --disable-lua to ignore this error. | ERROR: Function do_configure failed NOTE: package vlc-1.1.4.1-r0: task do_configure: Failed […] Adding `lua5.1` to `DEPENDS` is chosen in favor of disabling it. [1] http://git.videolan.org/?p=vlc.git;a=commitdiff;h=3c1df96cda8086f605f2eacaa5653c9e43ec45ac [2] http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=30e362c22a49521ebeef9bed1f0c58902b7dc50b Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net> Signed-off-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/vlc/vlc_1.1.4.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes/vlc/vlc_1.1.4.1.bb b/recipes/vlc/vlc_1.1.4.1.bb
index d4535a5f1f..ef764c1c69 100644
--- a/recipes/vlc/vlc_1.1.4.1.bb
+++ b/recipes/vlc/vlc_1.1.4.1.bb
@@ -10,7 +10,7 @@ SRC_URI[sha256sum] = "61c9ea30a17ea40c6ccbfd507026e5c83ad9e0691f221d3667c8e49696
# ffmpeg from git (library version => 52) is required
# libtool-native must be >= 2.2.4
-DEPENDS += "libdvdcss libdvdread"
+DEPENDS += "libdvdcss libdvdread lua"
EXTRA_OECONF += "\
--enable-dvdread \