aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-10-26 16:41:01 -0700
committerKhem Raj <raj.khem@gmail.com>2010-10-26 16:43:08 -0700
commit9feccf3a7374f6ac7ffe2ec42855585c6ccdf515 (patch)
treeeb6e12b192505e08b0334ee840a8322146d18774
parent1b857681e6042d01709efb7279a4945b8d015823 (diff)
downloadopenembedded-9feccf3a7374f6ac7ffe2ec42855585c6ccdf515.tar.gz
kstars-embedded_0.8.5.bb: Fix complilation with gcc 4.5
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/kstars/kstars-embedded-0.8.5/gcc45-compilation-fixes.patch34
-rw-r--r--recipes/kstars/kstars-embedded_0.8.5.bb6
2 files changed, 38 insertions, 2 deletions
diff --git a/recipes/kstars/kstars-embedded-0.8.5/gcc45-compilation-fixes.patch b/recipes/kstars/kstars-embedded-0.8.5/gcc45-compilation-fixes.patch
new file mode 100644
index 0000000000..4004edebc4
--- /dev/null
+++ b/recipes/kstars/kstars-embedded-0.8.5/gcc45-compilation-fixes.patch
@@ -0,0 +1,34 @@
+Index: kstars/kstars.cpp
+===================================================================
+--- kstars.orig/kstars.cpp
++++ kstars/kstars.cpp
+@@ -37,9 +37,9 @@
+ #include <qpe/mimetype.h>
+ #include <qpe/applnk.h>
+
+-#include <stdio.h>
+-#include <stdlib.h>
+-#include <stream.h>
++#include <cstdio>
++#include <cstdlib>
++#include <iostream>
+
+ #include "timedialog.h"
+ #include "locationdialog.h"
+Index: kstars/skymap.cpp
+===================================================================
+--- kstars.orig/skymap.cpp
++++ kstars/skymap.cpp
+@@ -36,9 +36,9 @@
+ #include <qpe/mimetype.h>
+ #include <qpe/applnk.h>
+
+-#include <math.h>
+-#include <stdlib.h>
+-#include <stream.h>
++#include <cmath>
++#include <cstdlib>
++#include <iostream>
+ #include <unistd.h>
+
+ #include "kstars.h"
diff --git a/recipes/kstars/kstars-embedded_0.8.5.bb b/recipes/kstars/kstars-embedded_0.8.5.bb
index 8dac901873..a792972c48 100644
--- a/recipes/kstars/kstars-embedded_0.8.5.bb
+++ b/recipes/kstars/kstars-embedded_0.8.5.bb
@@ -5,9 +5,11 @@ LICENSE = "GPL"
APPNAME = "kstars"
APPTYPE = "binary"
APPDESKTOP = "${WORKDIR}/apps/Applications"
-PR = "r1"
+PR = "r2"
-SRC_URI = "http://kstars.sourceforge.net/kstars-embedded-${PV}.tar.gz"
+SRC_URI = "http://kstars.sourceforge.net/kstars-embedded-${PV}.tar.gz \
+ file://gcc45-compilation-fixes.patch \
+ "
S = "${WORKDIR}/kstars"
inherit opie