summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-02-01 15:08:43 -0700
committerTom Rini <tom_rini@mentor.com>2011-02-01 15:08:43 -0700
commit01ef753e957bc95a7d0e4766e6bcb688cdbd8751 (patch)
treeba2d4be9bf8bdce061ef2663cb7c1419152f0c57
parent01996cb1129bc74f58807a4f442d37a1177bcbd5 (diff)
downloadopenembedded-01ef753e957bc95a7d0e4766e6bcb688cdbd8751.tar.gz
postgresql: Pass --disable-spinlocks on SH4, use INC_PR
Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/postgresql/postgresql.inc3
-rw-r--r--recipes/postgresql/postgresql_8.1.4.bb2
-rw-r--r--recipes/postgresql/postgresql_8.1.8.bb2
-rw-r--r--recipes/postgresql/postgresql_8.2.4.bb3
-rw-r--r--recipes/postgresql/postgresql_8.4.4.bb2
5 files changed, 9 insertions, 3 deletions
diff --git a/recipes/postgresql/postgresql.inc b/recipes/postgresql/postgresql.inc
index ca8698bc11..e8cf561d98 100644
--- a/recipes/postgresql/postgresql.inc
+++ b/recipes/postgresql/postgresql.inc
@@ -2,6 +2,7 @@ DESCRIPTION = "PostgreSQL is a powerful, open source relational database system.
HOMEPAGE = "http://www.postgresql.com"
LICENSE = "BSD"
DEPENDS = "zlib readline tzcode-native"
+INC_PR = "r5"
ARM_INSTRUCTION_SET = "arm"
@@ -16,6 +17,8 @@ export LDFLAGS_SL = "${LDFLAGS}"
inherit autotools pkgconfig
+EXTRA_OECONF_sh4 = "--disable-spinlocks"
+
do_compile_append() {
cp /usr/sbin/zic ${S}/src/timezone/
}
diff --git a/recipes/postgresql/postgresql_8.1.4.bb b/recipes/postgresql/postgresql_8.1.4.bb
index 1a83b4127f..8a1db3ac2f 100644
--- a/recipes/postgresql/postgresql_8.1.4.bb
+++ b/recipes/postgresql/postgresql_8.1.4.bb
@@ -1,6 +1,6 @@
require postgresql.inc
-PR = "r4"
+PR = "${INC_PR}.0"
SRC_URI[md5sum] = "a65bdc5d833169d28bf6fbaaa8d57fcf"
SRC_URI[sha256sum] = "ac7e7d311b07abd27b084041bcc943398df303bc86601f281891537bdf1a4e0b"
diff --git a/recipes/postgresql/postgresql_8.1.8.bb b/recipes/postgresql/postgresql_8.1.8.bb
index d54fe8cd57..ae9ac69993 100644
--- a/recipes/postgresql/postgresql_8.1.8.bb
+++ b/recipes/postgresql/postgresql_8.1.8.bb
@@ -1,6 +1,6 @@
require postgresql.inc
-PR = "r4"
+PR = "${INC_PR}.0"
SRC_URI[md5sum] = "b05e1d7f0cac9cc4e096aa21409dee55"
SRC_URI[sha256sum] = "91f75eb29c07271fcbfa2082c8300690efe4a72f2fbf35dace98108b0c6f7ba3"
diff --git a/recipes/postgresql/postgresql_8.2.4.bb b/recipes/postgresql/postgresql_8.2.4.bb
index b1a90e7d98..f4162ab916 100644
--- a/recipes/postgresql/postgresql_8.2.4.bb
+++ b/recipes/postgresql/postgresql_8.2.4.bb
@@ -1,6 +1,7 @@
require postgresql.inc
-PR = "r4"
+PR = "${INC_PR}.0"
+
DEFAULT_PREFERENCE = "-1"
SRC_URI += "file://no-ecpg-test.patch"
diff --git a/recipes/postgresql/postgresql_8.4.4.bb b/recipes/postgresql/postgresql_8.4.4.bb
index 0ec1769ebf..d9bf58e013 100644
--- a/recipes/postgresql/postgresql_8.4.4.bb
+++ b/recipes/postgresql/postgresql_8.4.4.bb
@@ -1,5 +1,7 @@
require postgresql.inc
+PR = "${INC_PR}.0"
+
DEFAULT_PREFERENCE = "-1"
SRC_URI = "ftp://ftp.postgresql.org/pub/source/v${PV}/${P}.tar.bz2 \