summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-02-02 18:13:13 -0700
committerTom Rini <tom_rini@mentor.com>2011-02-03 11:57:45 -0700
commit2ba88646629b96707ef8abbfa14374befd9371a2 (patch)
treea06da612074f6dfe847e17fadab6043211c01acf
parent93686d8afbf1888487224368d5bb19c12ef534dd (diff)
downloadopenembedded-2ba88646629b96707ef8abbfa14374befd9371a2.tar.gz
perl: Make this not be MACHINE-specific in pstaging+signatures
Based on d332f1881f362cef88f2b9f40186482ac612c2d0 and b02a4addca8a4727767e24953b98f30399e3592b in poky. Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/perl/perl_5.10.1.bb51
1 files changed, 23 insertions, 28 deletions
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index effb9b00e1..a53b157359 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPLv1+"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r21"
+PR = "r22"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"
@@ -157,22 +157,18 @@ do_configure() {
;;
esac
- if test "${MACHINE}" != "native"; then
- # These are strewn all over the source tree
- for foo in `grep -I -m1 \/usr\/include\/.*\\.h ${WORKDIR}/* -r | cut -f 1 -d ":"` ; do
- echo Fixing: $foo
- sed -e "s%/usr/include/%${STAGING_INCDIR}/%g" -i $foo
- done
- fi
+ # These are strewn all over the source tree
+ for foo in `grep -I -m1 \/usr\/include\/.*\\.h ${WORKDIR}/* -r | cut -f 1 -d ":"` ; do
+ echo Fixing: $foo
+ sed -e "s%/usr/include/%${STAGING_INCDIR}/%g" -i $foo
+ done
rm -f config
echo "ARCH = ${TARGET_ARCH}" > config
echo "OS = ${TARGET_OS}" >> config
}
do_compile() {
- if test "${MACHINE}" != "native"; then
- sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL
- fi
+ sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL
cd Cross
oe_runmake perl LD="${CCLD}"
}
@@ -195,24 +191,23 @@ do_install() {
ln -sf libperl.so.${PV} ${D}/${libdir}/libperl.so.5
# Fix up installed configuration
- if test "${MACHINE}" != "native"; then
- sed -i -e "s,${D},,g" \
- -e "s,-isystem${STAGING_INCDIR} ,,g" \
- -e "s,${STAGING_LIBDIR},${libdir},g" \
- -e "s,${STAGING_BINDIR},${bindir},g" \
- -e "s,${STAGING_INCDIR},${includedir},g" \
- -e "s,${TOOLCHAIN_PATH}${base_bindir}/,,g" \
- ${D}${bindir}/h2xs \
- ${D}${bindir}/h2ph \
- ${D}${datadir}/perl/${PV}/pod/*.pod \
- ${D}${datadir}/perl/${PV}/cacheout.pl \
- ${D}${datadir}/perl/${PV}/FileCache.pm \
- ${D}${libdir}/perl/${PV}/Config.pm \
- ${D}${libdir}/perl/${PV}/Config_heavy.pl \
- ${D}${libdir}/perl/${PV}/CORE/perl.h \
- ${D}${libdir}/perl/${PV}/CORE/pp.h
- fi
+ sed -i -e "s,${D},,g" \
+ -e "s,-isystem${STAGING_INCDIR} ,,g" \
+ -e "s,${STAGING_LIBDIR},${libdir},g" \
+ -e "s,${STAGING_BINDIR},${bindir},g" \
+ -e "s,${STAGING_INCDIR},${includedir},g" \
+ -e "s,${TOOLCHAIN_PATH}${base_bindir}/,,g" \
+ ${D}${bindir}/h2xs \
+ ${D}${bindir}/h2ph \
+ ${D}${datadir}/perl/${PV}/pod/*.pod \
+ ${D}${datadir}/perl/${PV}/cacheout.pl \
+ ${D}${datadir}/perl/${PV}/FileCache.pm \
+ ${D}${libdir}/perl/${PV}/Config.pm \
+ ${D}${libdir}/perl/${PV}/Config_heavy.pl \
+ ${D}${libdir}/perl/${PV}/CORE/perl.h \
+ ${D}${libdir}/perl/${PV}/CORE/pp.h
}
+
do_stage() {
install -d ${STAGING_LIBDIR_NATIVE}/perl/${PV} \
${STAGING_LIBDIR}/perl/${PV}/CORE \