summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2010-12-22 13:51:25 +0200
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2010-12-23 17:53:02 +0100
commit5667943cd09eb025ac382535e41269d874a6d560 (patch)
treeb96e226aa2db378603965d0396b552ed902e5094
parent2e02ec3cfae08fc62821a2034210f9bbb6f337d2 (diff)
downloadopenembedded-5667943cd09eb025ac382535e41269d874a6d560.tar.gz
midpath: Fix midpath-core and midpath-cldc, add patches.
midpath-core was slightly refactored, and now installs the configuration files needed which are picked up locally and can be overriden per-platform. A much more elegant solution, in my opinion. Two patches were added to midpath-core, one which changes the default UI colors to a more palatable gray pallete and one which disables the mouse cursor and enables key repeating for the SDL backend. midpath-cldc now builds files libmidpathfile and libmidpathnio (via --enable-cldc-vm) which are required, at least for a jamvm + midpath combo. No harm in installing them anyways. Configuration files moved around, and two more added, one default and one for the ben-nanonote. PR bumbed all around. Signed-off-by: Alex Ferguson <thoughtmonster@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
-rw-r--r--recipes/midpath/files/ben-nanonote/configuration.cfg128
-rw-r--r--recipes/midpath/files/configuration.cfg127
-rw-r--r--recipes/midpath/files/maemo5-compat/configuration.cfg (renamed from recipes/midpath/files/configuration_maemo.cfg)0
-rw-r--r--recipes/midpath/files/openmoko/configuration.cfg (renamed from recipes/midpath/files/configuration_openmoko.cfg)0
-rw-r--r--recipes/midpath/files/sdl-fixes.patch20
-rw-r--r--recipes/midpath/files/ui-colors.patch136
-rw-r--r--recipes/midpath/midpath-cldc_0.2+0.3rc2.bb9
-rw-r--r--recipes/midpath/midpath-core_0.2+0.3rc2.bb14
8 files changed, 429 insertions, 5 deletions
diff --git a/recipes/midpath/files/ben-nanonote/configuration.cfg b/recipes/midpath/files/ben-nanonote/configuration.cfg
new file mode 100644
index 0000000000..42f2796e4b
--- /dev/null
+++ b/recipes/midpath/files/ben-nanonote/configuration.cfg
@@ -0,0 +1,128 @@
+##========================================
+## Graphics parameters
+##========================================
+javax.microedition.lcdui.screenWidth:320
+javax.microedition.lcdui.screenHeight:224
+# Toolkit configuration (possible values: SDL, virtual)
+# The toolkit parameter should be set to "virtual" unless you know what you do.
+# (to change the UI backend, see the backend parameter of the virtual toolkit below)
+javax.microedition.lcdui.toolkit:virtual
+# Flag to enable/disable skin images (disabling images could improve performance)
+# (Possible values: yes, no)
+com.sun.midp.chameleon.skins.imageEnabled:no
+
+##======================================
+## Parameters for the Virtual UI Toolkit
+##======================================
+# Possible backend values: NULL, SDL, AWT, AWTGRABBER, SWT, X11, GTK, QT, FB
+org.thenesis.microbackend.ui.backend:SDL
+# SDL backend configuration.
+# Possible bitsPerPixels values: 8, 16, 32
+# Possible video mode values: SW, HW (i.e software, hardware)
+org.thenesis.microbackend.ui.sdl.bitsPerPixel:16
+org.thenesis.microbackend.ui.sdl.videoMode:HW
+# X11 backend configuration.
+# Display value examples: :0.0, 192.168.0.1:1.0
+org.thenesis.microbackend.ui.x11.Display::0.0
+# Linux Framebuffer (FB) backend configuration
+# (see /proc/bus/input/devices to know which special files are
+# associated with your mouse or touchscreen)
+org.thenesis.microbackend.ui.fb.framebufferDevice:/dev/fb0
+org.thenesis.microbackend.ui.fb.keyboardDevice:/dev/input/event1
+org.thenesis.microbackend.ui.fb.mouseDevice:/dev/input/event2
+org.thenesis.microbackend.ui.fb.touchscreenDevice:/dev/input/event2
+# Possible fontRenderer values: raw, BDF
+org.thenesis.midpath.ui.fontRenderer:raw
+org.thenesis.midpath.font.bdf.filename:VeraMono-12-8.bdf
+
+##==========================
+## Parameters for the sound
+##==========================
+# Sound configuration (possible values: SDL, virtual)
+# The "player" parameter should be set to "virtual" unless you know what you do.
+# The virtual engine requires this hardware configuration: 16 bits, stereo, little endian
+org.thenesis.midpath.sound.engine:virtual
+# Possible sound backend values: NULL, ALSA, ESD, PulseAudio
+org.thenesis.midpath.sound.backend:NULL
+org.thenesis.midpath.sound.device:default
+org.thenesis.midpath.sound.sampleRate:44100
+# Buffer size MUST be a power of two
+org.thenesis.midpath.sound.bufferSize:8192
+
+##======================================
+## IO parameters
+##======================================
+# IO (file, socket) backends (possible values: J2SE, CLDC)
+com.sun.midp.io.backend:CLDC
+# The RMS root path (if not defined, records are read/written in the current directory)
+com.sun.midp.rms.rootPath:/usr/share/midpath/records
+
+##======================================
+## Location (JSR179)
+##======================================
+# Location mode (possible values: GPS, KML, LMS, NMEA)
+org.thenesis.midpath.location.mode:GPS
+# Resource file URI (KML and NMEA mode only)
+# Examples:
+# -Load a KML file in the "res" package from the java classloader:
+# org.thenesis.midpath.location.resource.uri:/res/location.kml
+# -Load a NMEA file from the file system:
+# org.thenesis.midpath.location.resource.uri:file:////absolute/path/to/location.kml
+org.thenesis.midpath.location.resource.uri:
+# Resource poll interval in milliseconds (KML, LMS, NMEA mode only)
+org.thenesis.midpath.location.resource.pollInterval:5000
+
+##======================================
+## Messaging (JSR120, JSR205)
+##======================================
+# SMS backend (possible values: NULL)
+org.thenesis.midpath.messaging.backend:NULL
+
+##======================================
+## MIDlet Suite Manager (J2SE only)
+##======================================
+# The MIDlet repository path (if not defined, MIDlets are searched in the current directory)
+org.thenesis.midpath.main.repositoryPath:/usr/share/midpath/repository
+
+##======================================
+## Event parameters
+##======================================
+javax.microedition.lcdui.pointerSupported:false
+javax.microedition.lcdui.pointerMotionSupported:false
+
+##======================================
+## Key mapping
+## (AWT codes are used by convention - see java.awt.event.KeyEvent javadocs)
+##======================================
+# LEFT key. Default: VK_LEFT (37)
+org.thenesis.midpath.ui.keys.LEFT:37
+# UP key. Default: VK_UP (38)
+org.thenesis.midpath.ui.keys.UP:38
+# RIGHT key. Default: VK_RIGHT (39)
+org.thenesis.midpath.ui.keys.RIGHT:39
+# DOWN key. Default: VK_DOWN (40)
+org.thenesis.midpath.ui.keys.DOWN:40
+# GAME_A key. Default: VK_F4 (115)
+org.thenesis.midpath.ui.keys.GAME_A:115
+# GAME_B key. Default: VK_F5 (116)
+org.thenesis.midpath.ui.keys.GAME_B:116
+# GAME_C key. Default: VK_F6 (117)
+org.thenesis.midpath.ui.keys.GAME_C:117
+# GAME_D key. Default: VK_F7 (118)
+org.thenesis.midpath.ui.keys.GAME_D:118
+# FIRE key. Default: VK_ENTER (10)
+org.thenesis.midpath.ui.keys.FIRE:10
+# STAR key (*). Default: VK_ASTERISK (151)
+org.thenesis.midpath.ui.keys.STAR:151
+# POUND key (#). Default: VK_NUMBER_SIGN (520)
+org.thenesis.midpath.ui.keys.POUND:520
+# DELETE key. Default: VK_BACK_SPACE (8)
+org.thenesis.midpath.ui.keys.DELETE:8
+# END key. Default: VK_END (35)
+org.thenesis.midpath.ui.keys.END:35
+# POWER key. Default: VK_F8 (119)
+org.thenesis.midpath.ui.keys.POWER:119
+# SOFT_BUTTON1 key. Default: VK_F12/VOL_UP (122)
+org.thenesis.midpath.ui.keys.SOFT_BUTTON1:122
+# SOFT_BUTTON2 key. Default: VK_F21/VOL_DOWN (123)
+org.thenesis.midpath.ui.keys.SOFT_BUTTON2:123
diff --git a/recipes/midpath/files/configuration.cfg b/recipes/midpath/files/configuration.cfg
new file mode 100644
index 0000000000..33438c8121
--- /dev/null
+++ b/recipes/midpath/files/configuration.cfg
@@ -0,0 +1,127 @@
+##========================================
+## General graphics parameters
+##========================================
+org.thenesis.microbackend.ui.screenWidth:210
+org.thenesis.microbackend.ui.screenHeight:210
+# Toolkit configuration (possible values: SDL, Pure)
+# The toolkit parameter should be set to "Pure" unless you know what you do.
+# (to change the UI backend, see the backend parameter below)
+org.thenesis.microbackend.ui.toolkit:virtual
+# Flag to enable/disable skin images (disabling images could improve performance)
+# (Possible values: yes, no)
+com.sun.midp.chameleon.skins.imageEnabled:yes
+
+##======================================
+## MicroBackend parameters
+##======================================
+# Possible backend values: NULL, SDL, AWT, AWTGRABBER, SWT, X11, GTK, QT, FB
+org.thenesis.microbackend.ui.backend:AWT
+# SDL backend configuration.
+# Possible bitsPerPixels values: 8, 16, 32
+# Possible video mode values: SW, HW (i.e software, hardware)
+org.thenesis.microbackend.ui.sdl.bitsPerPixel:32
+org.thenesis.microbackend.ui.sdl.videoMode:SW
+# X11 backend configuration.
+# Display value examples: :0.0, 192.168.0.1:1.0
+org.thenesis.microbackend.ui.x11.Display::0.0
+# Linux Framebuffer (FB) backend configuration
+# (see /proc/bus/input/devices to know which special files are
+# associated with your mouse or touchscreen)
+org.thenesis.microbackend.ui.fb.framebufferDevice:/dev/fb0
+org.thenesis.microbackend.ui.fb.keyboardDevice:/dev/tty
+org.thenesis.microbackend.ui.fb.mouseDevice:/dev/input/event1
+org.thenesis.microbackend.ui.fb.touchscreenDevice:/dev/input/event2
+
+##==========================
+## Sound
+##==========================
+# Sound configuration (possible values: SDL, virtual)
+# The "player" parameter should be set to "virtual" unless you know what you do.
+# The virtual engine requires this hardware configuration: 16 bits, stereo, little endian
+org.thenesis.midpath.sound.engine:virtual
+# Possible sound backend values: NULL, ALSA, ESD, PulseAudio
+org.thenesis.midpath.sound.backend:NULL
+org.thenesis.midpath.sound.device:default
+org.thenesis.midpath.sound.sampleRate:44100
+# Buffer size MUST be a power of two
+org.thenesis.midpath.sound.bufferSize:8192
+
+##======================================
+## IO parameters
+##======================================
+# IO (file, socket) backends (possible values: J2SE, CLDC)
+com.sun.midp.io.backend:J2SE
+# The RMS root path (if not defined, records are read/written in the current directory)
+com.sun.midp.rms.rootPath:
+
+##======================================
+## Location (JSR179)
+##======================================
+# Location mode (possible values: GPS, KML, LMS, NMEA)
+org.thenesis.midpath.location.mode:GPS
+# Resource file URI (KML and NMEA mode only)
+# Examples:
+# -Load a KML file in the "res" package from the java classloader:
+# org.thenesis.midpath.location.resource.uri:/res/location.kml
+# -Load a NMEA file from the file system:
+# org.thenesis.midpath.location.resource.uri:file:////absolute/path/to/location.kml
+org.thenesis.midpath.location.resource.uri:
+# Resource poll interval in milliseconds (KML, LMS, NMEA mode only)
+org.thenesis.midpath.location.resource.pollInterval:5000
+
+##======================================
+## Messaging (JSR120, JSR205)
+##======================================
+# SMS backend (possible values: NULL)
+org.thenesis.midpath.messaging.backend:NULL
+
+##======================================
+## MIDlet Suite Manager (J2SE only)
+##======================================
+# The MIDlet repository path (if not defined, MIDlets are searched in the current directory)
+org.thenesis.midpath.main.repositoryPath:
+
+##======================================
+## Input parameters
+##======================================
+javax.microedition.lcdui.pointerSupported:true
+javax.microedition.lcdui.pointerMotionSupported:true
+# Enable/disable the virtual keyboard when editing text
+com.sun.midp.chameleon.input.virtualKeyboardAutoEnabled:false
+
+##======================================
+## Key mapping
+## (AWT codes are used by convention - see java.awt.event.KeyEvent javadocs)
+##======================================
+# LEFT key. Default: VK_LEFT (37)
+org.thenesis.midpath.ui.keys.LEFT:37
+# UP key. Default: VK_UP (38)
+org.thenesis.midpath.ui.keys.UP:38
+# RIGHT key. Default: VK_RIGHT (39)
+org.thenesis.midpath.ui.keys.RIGHT:39
+# DOWN key. Default: VK_DOWN (40)
+org.thenesis.midpath.ui.keys.DOWN:40
+# GAME_A key. Default: VK_F4 (115)
+org.thenesis.midpath.ui.keys.GAME_A:115
+# GAME_B key. Default: VK_F5 (116)
+org.thenesis.midpath.ui.keys.GAME_B:116
+# GAME_C key. Default: VK_F6 (117)
+org.thenesis.midpath.ui.keys.GAME_C:117
+# GAME_D key. Default: VK_F7 (118)
+org.thenesis.midpath.ui.keys.GAME_D:118
+# FIRE key. Default: VK_ENTER (10)
+org.thenesis.midpath.ui.keys.FIRE:10
+# STAR key (*). Default: VK_ASTERISK (151)
+org.thenesis.midpath.ui.keys.STAR:151
+# POUND key (#). Default: VK_NUMBER_SIGN (520)
+org.thenesis.midpath.ui.keys.POUND:520
+# DELETE key. Default: VK_BACK_SPACE (8)
+org.thenesis.midpath.ui.keys.DELETE:8
+# END key. Default: VK_END (35)
+org.thenesis.midpath.ui.keys.END:35
+# POWER key. Default: VK_F12 (123)
+org.thenesis.midpath.ui.keys.POWER:123
+# SOFT_BUTTON1 key. Default: VK_F1 (112)
+org.thenesis.midpath.ui.keys.SOFT_BUTTON1:112
+# SOFT_BUTTON2 key. Default: VK_F2 (113)
+org.thenesis.midpath.ui.keys.SOFT_BUTTON2:113
diff --git a/recipes/midpath/files/configuration_maemo.cfg b/recipes/midpath/files/maemo5-compat/configuration.cfg
index 441a9cdfc5..441a9cdfc5 100644
--- a/recipes/midpath/files/configuration_maemo.cfg
+++ b/recipes/midpath/files/maemo5-compat/configuration.cfg
diff --git a/recipes/midpath/files/configuration_openmoko.cfg b/recipes/midpath/files/openmoko/configuration.cfg
index bb413e4548..bb413e4548 100644
--- a/recipes/midpath/files/configuration_openmoko.cfg
+++ b/recipes/midpath/files/openmoko/configuration.cfg
diff --git a/recipes/midpath/files/sdl-fixes.patch b/recipes/midpath/files/sdl-fixes.patch
new file mode 100644
index 0000000000..f694d4276c
--- /dev/null
+++ b/recipes/midpath/files/sdl-fixes.patch
@@ -0,0 +1,20 @@
+diff -ru midpath-0.3rc2.orig/components/microbackend/org/thenesis/microbackend/ui/sdl/SDLBackend.java midpath-0.3rc2/components/microbackend/org/thenesis/microbackend/ui/sdl/SDLBackend.java
+--- midpath-0.3rc2.orig/components/microbackend/org/thenesis/microbackend/ui/sdl/SDLBackend.java 2008-09-02 03:03:19.000000000 +0300
++++ midpath-0.3rc2/components/microbackend/org/thenesis/microbackend/ui/sdl/SDLBackend.java 2010-12-21 18:58:05.890000957 +0200
+@@ -119,6 +119,7 @@
+
+ try {
+ SDLMain.init(SDLMain.SDL_INIT_VIDEO);
++ SDLVideo.showCursor(SDLVideo.SDL_DISABLE);
+ screenSurface = SDLVideo.setVideoMode(canvasWidth, canvasHeight, bitsPerPixel, flags);
+ rootARGBSurface = SDLVideo.createRGBSurface(SDLVideo.SDL_SWSURFACE, canvasWidth, canvasHeight, 32, 0x00ff0000L, 0x0000ff00L,
+ 0x000000ffL, 0xff000000L);
+@@ -155,6 +156,8 @@
+
+ try {
+ SDLEvent.enableUNICODE(1);
++ SDLEvent.enableKeyRepeat(SDLEvent.SDL_DEFAULT_REPEAT_DELAY,
++ SDLEvent.SDL_DEFAULT_REPEAT_INTERVAL);
+ while (Thread.currentThread() == thread) {
+ processEvent(SDLEvent.waitEvent(true));
+ }
diff --git a/recipes/midpath/files/ui-colors.patch b/recipes/midpath/files/ui-colors.patch
new file mode 100644
index 0000000000..6188fcdb99
--- /dev/null
+++ b/recipes/midpath/files/ui-colors.patch
@@ -0,0 +1,136 @@
+diff -ru midpath-0.3rc2.orig/components/core/src/com/sun/midp/chameleon/skins/resources/RomizedSkin.java midpath-0.3rc2/components/core/src/com/sun/midp/chameleon/skins/resources/RomizedSkin.java
+--- midpath-0.3rc2.orig/components/core/src/com/sun/midp/chameleon/skins/resources/RomizedSkin.java 2007-03-31 19:26:53.000000000 +0300
++++ midpath-0.3rc2/components/core/src/com/sun/midp/chameleon/skins/resources/RomizedSkin.java 2010-12-21 20:25:02.336667885 +0200
+@@ -58,15 +58,15 @@
+ // SCREEN_COLOR_FG
+ 0x000000,
+ // SCREEN_COLOR_BG_HL
+- 0xFFCC33,
++ 0x808080,
+ // SCREEN_COLOR_FG_HL
+ 0x000000,
+ // SCREEN_COLOR_BORDER
+ 0x000000,
+ // SCREEN_COLOR_BORDER_HL
+- 0xFFCC33,
++ 0x808080,
+ // SCREEN_COLOR_TRAVERSE_IND
+- 0xFFCC33,
++ 0x808080,
+ // SCREEN_BORDER_STYLE
+ Graphics.SOLID,
+ // SCREEN_FONT_LABEL
+@@ -128,19 +128,19 @@
+ // SOFTBTN_COLOR_FG_SHD
+ 0x000000,
+ // SOFTBTN_COLOR_BG
+- 0x264DB6,
++ 0x373636,
+ // SOFTBTN_COLOR_MU_FG
+ 0xFFFFFF,
+ // SOFTBTN_COLOR_MU_FG_SHD
+ 0x000000,
+ // SOFTBTN_COLOR_MU_BG
+- 0xFF9933,
++ 0x373636,
+ // SOFTBTN_COLOR_AU_FG
+ 0xFFFFFF,
+ // SOFTBTN_COLOR_AU_FG_SHD
+ 0x000000,
+ // SOFTBTN_COLOR_AU_BG
+- 0xF06409,
++ 0x373636,
+ // SOFTBTN_FONT
+ 1,
+ // SOFTBTN_TEXT_MENUCMD
+@@ -186,13 +186,13 @@
+ // PTI_MARGIN
+ 3,
+ // PTI_COLOR_BG
+- 0xA3E2F8,
++ 0xD9D9D9,
+ // PTI_COLOR_FG
+ 0x000000,
+ // PTI_COLOR_FG_HL
+ 0x000000,
+ // PTI_COLOR_BG_HL
+- 0xFFCC33,
++ 0xAFAFAF,
+ // PTI_COLOR_BDR
+ 0x336699,
+ // PTI_FONT
+@@ -216,7 +216,7 @@
+ // TITLE_COLOR_FG_SHD
+ 0x000000,
+ // TITLE_COLOR_BG
+- 0x1F3FB1,
++ 0x202020,
+ // TITLE_FONT
+ 1,
+ // TITLE_IMAGE_BG
+@@ -258,7 +258,7 @@
+ // ALERT_TIMEOUT
+ 2000,
+ // ALERT_COLOR_BG
+- 0xFFCC33,
++ 0xAFAFAF,
+ // ALERT_COLOR_TITLE
+ 0x000000,
+ // ALERT_COLOR_FG
+@@ -312,7 +312,7 @@
+ // CHOICE_COLOR_FG
+ 0x000000,
+ // CHOICE_COLOR_BG
+- 0xCCFFFF,
++ 0xD9D9D9,
+ // CHOICE_COLOR_BRDR
+ 0x003366,
+ // CHOICE_COLOR_BRDR_SHD
+@@ -390,7 +390,7 @@
+ // DATEFIELD_COLOR_FG
+ 0x000000,
+ // DATEFIELD_COLOR_BG
+- 0xC9E8FF,
++ 0xD9D9D9,
+ // DATEFIELD_COLOR_BRDR
+ 0x0D3964,
+ // DATEFIELD_COLOR_BRDR_LT
+@@ -446,7 +446,7 @@
+ // GAUGE_IMAGE_VALUES
+ 31,
+ // IMAGEITEM_COLOR_BG_LNK_FOC
+- 0xFFCC33,
++ 0xAFAFAF,
+ // IMAGEITEM_COLOR_BG_BTN
+ 0xff0000,
+ // IMAGEITEM_COLOR_BORDER_LT
+@@ -496,9 +496,9 @@
+ // MENU_ITEM_ANCHOR_X
+ 18,
+ // MENU_COLOR_BG
+- 0xFFEAA1,
++ 0xD9D9D9,
+ // MENU_COLOR_BG_SEL
+- 0xFFCC33,
++ 0xAFAFAF,
+ // MENU_COLOR_TITLE
+ 0x000000,
+ // MENU_COLOR_INDEX
+@@ -562,7 +562,7 @@
+ // STRINGITEM_COLOR_FG_LNK_FOC
+ 0x003399,
+ // STRINGITEM_COLOR_BG_LNK_FOC
+- 0xFFCC33,
++ 0xAFAFAF,
+ // STRINGITEM_COLOR_FG_BTN
+ 0x000000,
+ // STRINGITEM_COLOR_BG_BTN
+@@ -600,7 +600,7 @@
+ // TEXTFIELD_COLOR_BRDR
+ 0x000000,
+ // TEXTFIELD_COLOR_BRDR_SHD
+- 0x8db0d9,
++ 0x444444,
+ // TEXTFIELD_COLOR_FG_UE
+ 0x5d5d5d,
+ // TEXTFIELD_COLOR_BG_UE
diff --git a/recipes/midpath/midpath-cldc_0.2+0.3rc2.bb b/recipes/midpath/midpath-cldc_0.2+0.3rc2.bb
index a2307aea57..d87e82b5e4 100644
--- a/recipes/midpath/midpath-cldc_0.2+0.3rc2.bb
+++ b/recipes/midpath/midpath-cldc_0.2+0.3rc2.bb
@@ -1,6 +1,6 @@
require midpath-common.inc
-PR = "r1"
+PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/midpath/midpath-0.3rc2.tar.gz"
@@ -27,10 +27,14 @@ do_compile() {
--disable-opengl-api \
--disable-m3g-api \
--disable-demos \
+ --enable-cldc-vm \
--with-cldc-jar=dist/${JAR}
}
do_install() {
+ oe_libinstall -C dist -so libmidpathfile ${D}${libdir_jni}
+ oe_libinstall -C dist -so libmidpathnio ${D}${libdir_jni}
+
install -d ${D}${datadir}/midpath-cldc
install -m 0644 dist/${JAR} ${D}${datadir}/midpath-cldc
}
@@ -42,7 +46,8 @@ do_stage() {
PACKAGES = "${PN}"
-FILES_${PN} = "${datadir}/midpath-cldc/${JAR}"
+FILES_${PN} = "${datadir}/midpath-cldc/${JAR} ${libdir_jni}/*.so"
+FILES_${PN}-dbg = "${libdir_jni}/.debug"
SRC_URI[md5sum] = "d03cd88f51f82bbcfcfa5b65df0da5b0"
SRC_URI[sha256sum] = "e235ca7470e7cdfb90e3806fbcc1b2c450db286276136a2523c7ae26a804a100"
diff --git a/recipes/midpath/midpath-core_0.2+0.3rc2.bb b/recipes/midpath/midpath-core_0.2+0.3rc2.bb
index a23b26f977..6fe3447d9a 100644
--- a/recipes/midpath/midpath-core_0.2+0.3rc2.bb
+++ b/recipes/midpath/midpath-core_0.2+0.3rc2.bb
@@ -1,8 +1,11 @@
DESCRIPTION = "MIDPath is a Java library which provides a MIDP2 implementation"
-PR = "r4"
+PR = "r5"
-SRC_URI = "${SOURCEFORGE_MIRROR}/midpath/midpath-0.3rc2.tar.gz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/midpath/midpath-0.3rc2.tar.gz \
+ file://configuration.cfg \
+ file://ui-colors.patch \
+ file://sdl-fixes.patch"
S = "${WORKDIR}/midpath-0.3rc2"
@@ -24,6 +27,10 @@ RDEPENDS_${PN} += "libkxml2-java"
JAR = "midpath.jar"
+do_configure() {
+ mv ${WORKDIR}/configuration.cfg ${S}/configuration/com/sun/midp/configuration/
+}
+
do_compile() {
midpath_build \
--disable-cldc \
@@ -48,6 +55,7 @@ do_install() {
oe_libinstall -C dist -so libavetanabtcldc ${D}${libdir_jni}
install -d ${D}${datadir}/midpath
+ cp -R configuration ${D}${datadir}/midpath
install -m 0644 dist/${JAR} ${D}${datadir}/midpath
install -m 0644 dist/microbackend.jar ${D}${datadir}/midpath
install -m 0644 dist/avetanabt-cldc.jar ${D}${datadir}/midpath
@@ -76,11 +84,11 @@ FILES_${PN}-ogg = "${datadir}/midpath/jorbis-cldc.jar"
FILES_${PN} = "\
${datadir}/midpath/*.jar \
+ ${datadir}/midpath/configuration \
${datadir}/applications \
${datadir}/pixmaps \
${bindir} \
"
-
SRC_URI[md5sum] = "d03cd88f51f82bbcfcfa5b65df0da5b0"
SRC_URI[sha256sum] = "e235ca7470e7cdfb90e3806fbcc1b2c450db286276136a2523c7ae26a804a100"