summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorchase maupin <chasemaupin03@gmail.com>2010-12-22 04:30:05 +0000
committerDenys Dmytriyenko <denys@ti.com>2010-12-21 15:48:01 -0500
commitb3cf1d3ddb9f50a1f08a11116bd121ed2fdf8b03 (patch)
tree2a14eb59ef1c4caed52f9aa55387fcbf532a3081
parent846c9d27006b7a0c846c075ce4deb140689b3023 (diff)
downloadopenembedded-b3cf1d3ddb9f50a1f08a11116bd121ed2fdf8b03.tar.gz
ti-pru-sw-edma-library: stage needed header
* Stage the edma.h header which is needed by other example applications that link with this library. * Bump the PR Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes/ti/ti-pru-sw-edma-library_1.00.00.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/recipes/ti/ti-pru-sw-edma-library_1.00.00.bb b/recipes/ti/ti-pru-sw-edma-library_1.00.00.bb
index 128d79d32f..cb517dea03 100644
--- a/recipes/ti/ti-pru-sw-edma-library_1.00.00.bb
+++ b/recipes/ti/ti-pru-sw-edma-library_1.00.00.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "eDMA library for use by PRU sw example applications"
HOMEPAGE = "https://gforge.ti.com/gf/project/pru_sw/"
LICENSE = "BSD"
-PR = "r1+svnr${SRCPV}"
+PR = "r2+svnr${SRCPV}"
DEPENDS += "virtual/kernel ti-pru-sw-edma-driver"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -18,7 +18,8 @@ do_compile () {
}
do_install () {
- install -d ${D}/${libdir}
- install -m 0755 ${S}/../lib/libedmautils.a ${D}/${libdir}/
+ install -d ${D}${libdir}
+ install -d ${D}${includedir}
+ install -m 0755 ${S}/../lib/libedmautils.a ${D}${libdir}/
+ install -m 0644 ${S}/../include/edma.h ${D}${includedir}/
}
-