summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-12-28 01:16:56 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-12-28 01:17:38 +0100
commit1b3a22200a3ea913d1766144d35b60cf70cf64dc (patch)
tree82b45af5b097c383f12ed0a7ceb3e5955481a1be
parentc9a2eb91050169f443d6e809081e6541e444dea4 (diff)
downloadopenembedded-1b3a22200a3ea913d1766144d35b60cf70cf64dc.tar.gz
fsodeviced: disable support for libcanberra, which seldomly builds these days.
-rw-r--r--recipes/freesmartphone/fsodeviced_git.bb13
1 files changed, 7 insertions, 6 deletions
diff --git a/recipes/freesmartphone/fsodeviced_git.bb b/recipes/freesmartphone/fsodeviced_git.bb
index 33f58d3d01..240794bb3c 100644
--- a/recipes/freesmartphone/fsodeviced_git.bb
+++ b/recipes/freesmartphone/fsodeviced_git.bb
@@ -1,19 +1,16 @@
require cornucopia.inc
inherit fso-plugin
-DEPENDS += "alsa-lib libcanberra libfsoresource android-rpc i2c-tools"
-RDEPENDS_${PN} += "libcanberra-alsa"
-# Included in fsodeviced itself now
-# RRECOMMENDS_${PN} += "fso-alsa-data"
+DEPENDS += "alsa-lib libfsoresource android-rpc i2c-tools"
RPROVIDES_${PN} = "openmoko-alsa-scenarios virtual/alsa-scenarios"
SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
PV = "0.9.4+gitr${SRCPV}"
PE = "2"
-PR = "${INC_PR}.18"
+PR = "${INC_PR}.19"
EXTRA_OECONF = "\
--enable-kernel26-rfkill \
- --enable-player-canberra \
+ --disable-player-canberra \
--enable-htcdream-powercontrol \
"
@@ -24,6 +21,10 @@ INITSCRIPT_PARAMS = "defaults 27"
SRC_URI += "file://fsodeviced"
+do_configure_prepend() {
+ install ${STAGING_INCDIR}/linux/i2c-dev-user.h ${STAGING_INCDIR}/linux/i2c-dev.h
+}
+
CONFFILES_${PN} = "${sysconfdir}/freesmartphone/conf/openmoko_gta/fsodeviced.conf \
${sysconfdir}/freesmartphone/conf/palm_pre/fsodeviced.conf \
${sysconfdir}/freesmartphone/conf/htc_qualcomm_dream/fsodeviced.conf \