summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2011-01-13 14:46:14 -0500
committerChris Larson <chris_larson@mentor.com>2011-01-13 14:46:14 -0500
commitb2eefd38cf8867991027039e1fc649e338a92537 (patch)
tree9146fe9794b029da714a5ab7b4bce64d10fd52fc
parent823c6df67e743e90e8e7e2a5e5a79fe68b24e9e6 (diff)
downloadopenembedded-b2eefd38cf8867991027039e1fc649e338a92537.tar.gz
argp-standalone: fix patch
Signed-off-by: Chris Larson <chris_larson@mentor.com>
-rw-r--r--recipes/argp-standalone/argp-standalone/libtool.patch56
-rw-r--r--recipes/argp-standalone/argp-standalone_1.3.bb2
2 files changed, 27 insertions, 31 deletions
diff --git a/recipes/argp-standalone/argp-standalone/libtool.patch b/recipes/argp-standalone/argp-standalone/libtool.patch
index c3498aa749..3ed2f9dda2 100644
--- a/recipes/argp-standalone/argp-standalone/libtool.patch
+++ b/recipes/argp-standalone/argp-standalone/libtool.patch
@@ -1,56 +1,52 @@
----
- Makefile.am | 10 +++++-----
- configure.ac | 1 +
- testsuite/Makefile.am | 2 +-
- 3 files changed, 7 insertions(+), 6 deletions(-)
-
---- argp-standalone-1.3.orig/configure.ac
-+++ argp-standalone-1.3/configure.ac
-@@ -21,6 +21,7 @@ AC_PROG_CC
+diff -u argp-standalone-1.3/configure.ac argp-standalone-1.3.new/configure.ac
+--- argp-standalone-1.3/configure.ac 2004-03-19 16:39:08.000000000 -0500
++++ argp-standalone-1.3.new/configure.ac 2011-01-13 14:27:10.000000000 -0500
+@@ -21,6 +21,7 @@
AC_PROG_MAKE_SET
AC_PROG_RANLIB
AM_PROG_CC_STDC
+AC_PROG_LIBTOOL
-
+
if test "x$am_cv_prog_cc_stdc" = xno ; then
AC_ERROR([the C compiler doesn't handle ANSI-C])
---- argp-standalone-1.3.orig/Makefile.am
-+++ argp-standalone-1.3/Makefile.am
+diff -u argp-standalone-1.3/Makefile.am argp-standalone-1.3.new/Makefile.am
+--- argp-standalone-1.3/Makefile.am 2005-05-10 08:07:49.000000000 -0400
++++ argp-standalone-1.3.new/Makefile.am 2011-01-13 14:28:00.000000000 -0500
@@ -21,9 +21,9 @@
AUTOMAKE_OPTIONS = foreign
SUBDIRS = . testsuite
-
+
-LIBOBJS = @LIBOBJS@
+LTLIBOBJS = @LTLIBOBJS@
-
+
-lib_LIBRARIES = libargp.a
+lib_LTLIBRARIES = libargp.la
-
+
# argp-test needs random(), which is not available on windows.
EXTRA_PROGRAMS = argp-test
-@@ -33,11 +33,11 @@ include_HEADERS=argp.h
+@@ -33,11 +33,11 @@
EXTRA_DIST = mempcpy.c strchrnul.c strndup.c strcasecmp.c vsnprintf.c Versions
-
- # Leaves out argp-fs-xinl.c and argp-xinl.c
+
+ # Leaves out argp-fs-xinl.c and argp-xinl.c
-libargp_a_SOURCES = argp-ba.c argp-eexst.c argp-fmtstream.c \
+libargp_la_SOURCES = argp-ba.c argp-eexst.c argp-fmtstream.c \
- argp-help.c argp-parse.c argp-pv.c \
- argp-pvh.c
-
+ argp-help.c argp-parse.c argp-pv.c \
+ argp-pvh.c
+
-libargp_a_LIBADD = $(LIBOBJS)
-+libargp_la_LIBADD = $(LTLIBOBJS)
-
++libargp_la_LIBADD = $(LIBOBJS)
+
-argp_test_LDADD = libargp.a
+argp_test_LDADD = libargp.la
-
---- argp-standalone-1.3.orig/testsuite/Makefile.am
-+++ argp-standalone-1.3/testsuite/Makefile.am
-@@ -7,7 +7,7 @@ TS_SH = ex1-test permute-test
-
+
+--- argp-standalone-1.3/testsuite/Makefile.am 2004-10-18 17:00:26.000000000 -0400
++++ argp-standalone-1.3.new/testsuite/Makefile.am 2011-01-13 14:27:59.000000000 -0500
+@@ -7,7 +7,7 @@
+
TS_ALL = $(TS_PROGS) $(TS_SH)
-
+
-LDADD = ../libargp.a
+LDADD = $(top_builddir)/libargp.la
-
+
EXTRA_DIST = $(TS_SH) run-tests
CLEANFILES = test.out
diff --git a/recipes/argp-standalone/argp-standalone_1.3.bb b/recipes/argp-standalone/argp-standalone_1.3.bb
index ba8d35642d..95122e7cfe 100644
--- a/recipes/argp-standalone/argp-standalone_1.3.bb
+++ b/recipes/argp-standalone/argp-standalone_1.3.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "A standalone version of argp, which is part of the GNU C Library."
PRIORITY = "optional"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.auto.tuwien.ac.at/~mkoegler/eib/argp-standalone-${PV}.tar.gz \
file://libtool.patch"