summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2011-01-13 16:37:22 +0100
committerEric Bénard <eric@eukrea.com>2011-01-13 16:39:46 +0100
commitbe6797a1ffd68e219f3f8d4e3ac95e25ee2b5c6b (patch)
tree2b69781b880846d449e7bbbfe1bdb05c113b7f83
parent7f07380ce98d61cd09793de98be45107b144f8f4 (diff)
downloadopenembedded-be6797a1ffd68e219f3f8d4e3ac95e25ee2b5c6b.tar.gz
busybox 1.18.1 : fix patches
fetching patches from cgit is not a right idea as checksum are changing. Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--recipes/busybox/busybox-1.18.1/busybox-1.18.1-httpd.patch11
-rw-r--r--recipes/busybox/busybox_1.18.1.bb7
2 files changed, 14 insertions, 4 deletions
diff --git a/recipes/busybox/busybox-1.18.1/busybox-1.18.1-httpd.patch b/recipes/busybox/busybox-1.18.1/busybox-1.18.1-httpd.patch
new file mode 100644
index 0000000000..0b934e7f5a
--- /dev/null
+++ b/recipes/busybox/busybox-1.18.1/busybox-1.18.1-httpd.patch
@@ -0,0 +1,11 @@
+diff -urpN busybox-1.18.1/networking/httpd.c busybox-1.18.1-httpd/networking/httpd.c
+--- busybox-1.18.1/networking/httpd.c 2010-12-20 01:41:27.000000000 +0100
++++ busybox-1.18.1-httpd/networking/httpd.c 2011-01-11 17:59:06.638225175 +0100
+@@ -1522,6 +1522,7 @@ static NOINLINE void send_file_and_exit(
+ struct stat sb;
+ fstat(fd, &sb);
+ file_size = sb.st_size;
++ last_mod = sb.st_mtime;
+ } else {
+ IF_FEATURE_HTTPD_GZIP(content_gzip = 0;)
+ fd = open(url, O_RDONLY);
diff --git a/recipes/busybox/busybox_1.18.1.bb b/recipes/busybox/busybox_1.18.1.bb
index f337eef383..92ae604090 100644
--- a/recipes/busybox/busybox_1.18.1.bb
+++ b/recipes/busybox/busybox_1.18.1.bb
@@ -1,5 +1,5 @@
require busybox_1.1x.inc
-PR = "${INC_PR}.5"
+PR = "${INC_PR}.6"
SRC_URI += " \
file://busybox-1.18.1-hush.patch \
@@ -8,10 +8,9 @@ SRC_URI += " \
file://busybox-1.18.1-mkswap.patch \
file://busybox-1.18.1-warning.patch \
file://busybox-1.18.1-modprobe-small.patch \
- http://git.busybox.net/busybox/patch/id=8030a1484917d5b71d5ccd1a1d28a29da7a3d7f0;apply=yes;name=bb181-01 \
+ file://busybox-1.18.1-tftp.patch \
+ file://busybox-1.18.1-httpd.patch \
"
SRC_URI[md5sum] = "f15fe752d8b7012aa5e59f83b88ccb1c"
SRC_URI[sha256sum] = "33eb25ea7b20c727c3af769256b21408a1ac1f927ff9f89a1f1e3767c18c9967"
-SRC_URI[bb181-01.md5sum] = "fe58a0e758c2581fdd2554186089b03b"
-SRC_URI[bb181-01.sha256sum] = "f776d0b4ba525c62abe5e91f1432773eca92904cdecbdf48546a9271166cd896"