aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-06-16 11:16:23 -0700
committerTom Rini <tom_rini@mentor.com>2010-06-16 11:16:23 -0700
commit293fa519d1c883e5a65ac298c1011ab95fb96499 (patch)
tree718009881cdf8c40d0422ef62df2f572456a9920
parentfffb474ad6c4d1ce38561aec850be7bf707bb00a (diff)
downloadopenembedded-293fa519d1c883e5a65ac298c1011ab95fb96499.tar.gz
linux-libc-headers-native: Add, make it a dependency for most native recipes
On some host distributions the provided linux kernel headers are too old to compile utilities we need. Given that we need these utilities to run things on the target the best solution is to provide linux-libc-headers-native. Rather than get things into an inconsistent state, we make linux-libc-headers-native be a default dependency. Acked-by: Leon Woestenberg <leon@sidebranch.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--classes/base.bbclass6
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers.inc3
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.7.0.bb1
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.8.1.bb1
4 files changed, 10 insertions, 1 deletions
diff --git a/classes/base.bbclass b/classes/base.bbclass
index e0f9184f58..e26a45e756 100644
--- a/classes/base.bbclass
+++ b/classes/base.bbclass
@@ -75,6 +75,12 @@ def base_dep_prepend(d):
if (bb.data.getVar('HOST_SYS', d, 1) !=
bb.data.getVar('BUILD_SYS', d, 1)):
deps += " virtual/${TARGET_PREFIX}gcc virtual/libc "
+ elif bb.data.inherits_class('native', d) and \
+ bb.data.getVar('PN', d, True) not in \
+ ("linux-libc-headers-native", "quilt-native",
+ "unifdef-native", "shasum-native",
+ "stagemanager-native", "coreutils-native"):
+ deps += " linux-libc-headers-native"
return deps
DEPENDS_prepend="${@base_dep_prepend(d)} "
diff --git a/recipes/linux-libc-headers/linux-libc-headers.inc b/recipes/linux-libc-headers/linux-libc-headers.inc
index 0487e65fab..0b0d05a0d2 100644
--- a/recipes/linux-libc-headers/linux-libc-headers.inc
+++ b/recipes/linux-libc-headers/linux-libc-headers.inc
@@ -1,7 +1,8 @@
DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
SECTION = "devel"
LICENSE = "GPL"
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"
RDEPENDS_${PN}-dev = ""
RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPV})"
-
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.7.0.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.7.0.bb
index b66e768bb1..0a1159a8fb 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.7.0.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.7.0.bb
@@ -1,6 +1,7 @@
require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
+NATIVE_INSTALL_WORKS = "0"
PR = "r4"
# NOTE: no need to package these headers, since the c library includes them.
PACKAGES = ""
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.8.1.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.8.1.bb
index 4893cab100..6cbd8baf83 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.8.1.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.8.1.bb
@@ -1,5 +1,6 @@
require linux-libc-headers.inc
+NATIVE_INSTALL_WORKS = "0"
HOMEPAGE = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/"
# license note from the package:
# Linux-libc-headers are derived from linux kernel headers. For license of a