aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2005-06-08 13:38:31 +0000
committerRod Whitby <rod@whitby.id.au>2005-06-08 13:38:31 +0000
commit2f9f73aee4706f945edd8a7bde7d1e94d71c5434 (patch)
tree2c930a86a08d227c4eac055d459b74c7535d3e38
parent50b547798c2376e19684549f025d11b8388c1185 (diff)
downloadopenembedded-2f9f73aee4706f945edd8a7bde7d1e94d71c5434.tar.gz
Merge bk://nslu2-linux@nslu2-linux.bkbits.net/openembedded
into home.(none):/home/bitkeeper/openembedded 2005/06/08 23:07:41+09:30 (none)!rwhitby Added ftpd-topfield BKrev: 42a6f4d7BSu_Qv-x_upv_q9Hb-mQVA
-rw-r--r--packages/dnsmasq/dnsmasq.inc28
-rw-r--r--packages/ftpd-topfield/files/init0
-rw-r--r--packages/ftpd-topfield/ftpd-topfield_cvs.bb0
3 files changed, 28 insertions, 0 deletions
diff --git a/packages/dnsmasq/dnsmasq.inc b/packages/dnsmasq/dnsmasq.inc
index e69de29bb2..389f67cbb2 100644
--- a/packages/dnsmasq/dnsmasq.inc
+++ b/packages/dnsmasq/dnsmasq.inc
@@ -0,0 +1,28 @@
+SECTION = "console/network"
+DESCRIPTION = "Dnsmasq is a lightweight, easy to configure DNS forwarder and DHCP server."
+HOMEPAGE = "http://www.thekelleys.org.uk/dnsmasq/doc.html"
+LICENSE = "GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+
+SRC_URI = "http://www.thekelleys.org.uk/dnsmasq/dnsmasq-${PV}.tar.gz \
+ file://init \
+ file://dnsmasq.conf"
+
+S = "${WORKDIR}/dnsmasq-${PV}"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "dnsmasq"
+INITSCRIPT_PARAMS = "defaults"
+
+do_install () {
+ oe_runmake "PREFIX=${D}${prefix}" \
+ "BINDIR=${D}${bindir}" \
+ "MANDIR=${D}${mandir}" \
+ install
+ install -d ${D}${sysconfdir}/ ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/dnsmasq.conf ${D}${sysconfdir}/
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/dnsmasq
+}
+
+CONFFILES_${PN} = "${sysconfdir}/dnsmasq.conf"
diff --git a/packages/ftpd-topfield/files/init b/packages/ftpd-topfield/files/init
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ftpd-topfield/files/init
diff --git a/packages/ftpd-topfield/ftpd-topfield_cvs.bb b/packages/ftpd-topfield/ftpd-topfield_cvs.bb
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ftpd-topfield/ftpd-topfield_cvs.bb