aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-11-04 14:25:17 -0400
committerChris Larson <chris_larson@mentor.com>2010-11-04 14:25:53 -0400
commit7c05f4e4c4d0cb1914660f1d261961e185a4e1f5 (patch)
tree9a5de519c33eb59828e0d74d86b10fe101859696
parenta3d8c448c2bb3ea2c9a92bdb442fb4b39144bae0 (diff)
downloadopenembedded-7c05f4e4c4d0cb1914660f1d261961e185a4e1f5.tar.gz
termcap, termcapfile: add GNU termcap 1.3.1
Signed-off-by: Chris Larson <chris_larson@mentor.com>
-rw-r--r--recipes/termcap/termcap_1.3.1.bb35
-rw-r--r--recipes/termcapfile/termcapfile_11.0.1.bb (renamed from recipes/termcap/termcap_11.0.1.bb)5
2 files changed, 36 insertions, 4 deletions
diff --git a/recipes/termcap/termcap_1.3.1.bb b/recipes/termcap/termcap_1.3.1.bb
new file mode 100644
index 0000000000..6f78bbf40c
--- /dev/null
+++ b/recipes/termcap/termcap_1.3.1.bb
@@ -0,0 +1,35 @@
+inherit autotools
+
+DESCRIPTION = "GNU termcap is a library of C functions that enables programs \
+to send control strings to terminals in a terminal type-independent manner"
+HOMEPAGE = "http://freshmeat.net/projects/termcap/"
+LICENSE = "GPLv2"
+DEPENDS = ""
+PE = "1"
+PR = "0"
+
+SRC_URI = "${GNU_MIRROR}/termcap/termcap-${PV}.tar.gz"
+SRC_URI[md5sum] = "ffe6f86e63a3a29fa53ac645faaabdfa"
+SRC_URI[sha256sum] = "91a0e22e5387ca4467b5bcb18edf1c51b930262fd466d5fda396dd9d26719100"
+
+EXTRA_OECONF += "\
+ --enable-install-termcap \
+ --with-termcap=${sysconfdir}/termcap \
+"
+
+EXTRA_OEMAKE += "\
+ 'AR=${AR}' \
+ 'CFLAGS=${CFLAGS}' \
+"
+
+do_install () {
+ install -d ${D}${sysconfdir}
+ oe_runmake install \
+ 'libdir=${D}${libdir}' \
+ 'includedir=${D}${includedir}' \
+ 'infodir=${D}${infodir}' \
+ 'termcapfile=${D}${sysconfdir}/termcap' \
+ 'oldincludedir='
+}
+
+BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes/termcap/termcap_11.0.1.bb b/recipes/termcapfile/termcapfile_11.0.1.bb
index a14630dacd..6e8517b7fd 100644
--- a/recipes/termcap/termcap_11.0.1.bb
+++ b/recipes/termcapfile/termcapfile_11.0.1.bb
@@ -2,6 +2,7 @@ DESCRIPTION = "Terminal Capabilities File"
SECTION = "base"
HOMEPAGE = "http://www.catb.org/~esr/terminfo/"
LICENSE = "PD"
+PR = "r1"
SRC_URI = "http://www.catb.org/~esr/terminfo/termtypes.tc.gz"
S = "${WORKDIR}"
@@ -11,9 +12,5 @@ do_install() {
install -m 0644 termtypes.tc ${D}${sysconfdir}/termcap
}
-PACKAGES = "${PN}-dbg termcap"
-FILES_termcap = "${sysconfdir}"
-
-
SRC_URI[md5sum] = "37318885db65314f1bcc2b22751123d3"
SRC_URI[sha256sum] = "c4fa04257fea6e968d4caa28cc18dbbf9eea4769a463296eaca21ceea757a728"