aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-04-10 14:48:06 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-04-10 14:48:06 +0000
commitf12f92a5baf13c1859c2756e31fba2994cd9f059 (patch)
tree89a4a3e24ccaad7201158974219d05c68d7e0c56
parentc6021f5bae3468ba3f844efc5776ff7086f05a83 (diff)
downloadopenembedded-f12f92a5baf13c1859c2756e31fba2994cd9f059.tar.gz
python 2.5.2 python-xml does _not_ RDEPENDS on python-netclient (what was i thinking?)
-rwxr-xr-xcontrib/python/generate-manifest-2.5.py2
-rw-r--r--packages/python/python-2.5-manifest.inc8
-rw-r--r--packages/python/python_2.5.2.bb3
3 files changed, 7 insertions, 6 deletions
diff --git a/contrib/python/generate-manifest-2.5.py b/contrib/python/generate-manifest-2.5.py
index 69788f66af..8f1ee88937 100755
--- a/contrib/python/generate-manifest-2.5.py
+++ b/contrib/python/generate-manifest-2.5.py
@@ -318,7 +318,7 @@ if __name__ == "__main__":
m.addPackage( 0, "python-unittest", "Python Unit Testing Framework", "python-core python-stringold python-lang",
"unittest.*" )
- m.addPackage( 0, "python-xml", "Python basic XML support.", "python-core python-re python-netclient",
+ m.addPackage( 1, "python-xml", "Python basic XML support.", "python-core python-re",
"lib-dynload/pyexpat.so xml xmllib.*" ) # package
m.addPackage( 0, "python-xmlrpc", "Python XMLRPC Support", "python-core python-xml python-netserver python-lang",
diff --git a/packages/python/python-2.5-manifest.inc b/packages/python/python-2.5-manifest.inc
index c098494d17..a18b371696 100644
--- a/packages/python/python-2.5-manifest.inc
+++ b/packages/python/python-2.5-manifest.inc
@@ -1,5 +1,5 @@
-########################################################################################################################
-### AUTO-GENERATED by './generate-manifest-2.5.py' [(C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>] on Fri Mar 21 18:43:05 2008
+[?1034h########################################################################################################################
+### AUTO-GENERATED by '../../contrib/python/generate-manifest-2.5.py' [(C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>] on Thu Apr 10 16:47:00 2008
###
### Visit THE Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy
###
@@ -208,8 +208,8 @@ RDEPENDS_python-mailbox="python-core python-mime"
FILES_python-mailbox="${libdir}/python2.5/mailbox.* "
DESCRIPTION_python-xml="Python basic XML support."
-PR_python-xml="ml0"
-RDEPENDS_python-xml="python-core python-re python-netclient"
+PR_python-xml="ml1"
+RDEPENDS_python-xml="python-core python-re"
FILES_python-xml="${libdir}/python2.5/lib-dynload/pyexpat.so ${libdir}/python2.5/xml ${libdir}/python2.5/xmllib.* "
DESCRIPTION_python-mime="Python MIME Handling APIs"
diff --git a/packages/python/python_2.5.2.bb b/packages/python/python_2.5.2.bb
index af907f23c9..325e541b97 100644
--- a/packages/python/python_2.5.2.bb
+++ b/packages/python/python_2.5.2.bb
@@ -5,7 +5,8 @@ SECTION = "devel/python"
PRIORITY = "optional"
DEPENDS = "python-native readline zlib gdbm openssl sqlite3 tcl tk"
DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
-PR = "ml1"
+# bump this on every change in contrib/python/generate-manifest-2.5.py
+PR = "ml2"
PYTHON_MAJMIN = "2.5"