aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-05-27 16:13:07 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-05-27 17:13:51 +0200
commit03578a4aa342add60202d2e97f527e17da22b67d (patch)
treec4ca3c83a39509a229e74651d974f09b9faf6024
parent480be229f1a7092b96830dd71a38b96cbda7cbad (diff)
downloadopenembedded-03578a4aa342add60202d2e97f527e17da22b67d.tar.gz
linux-openmoko-2.6.3[79]: fix nand with badblocks
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/linux/linux-2.6.37/shr.patch21
-rw-r--r--recipes/linux/linux-2.6.39/shr.patch13
-rw-r--r--recipes/linux/linux-openmoko_2.6.37.bb2
-rw-r--r--recipes/linux/linux-openmoko_2.6.39.bb2
4 files changed, 30 insertions, 8 deletions
diff --git a/recipes/linux/linux-2.6.37/shr.patch b/recipes/linux/linux-2.6.37/shr.patch
index 43b81d506a..09c89c8978 100644
--- a/recipes/linux/linux-2.6.37/shr.patch
+++ b/recipes/linux/linux-2.6.37/shr.patch
@@ -3,6 +3,7 @@ rebased on top of openmoko kernel repository
https://gitorious.org/shr/linux/commits/shr-2.6.37-nodrm
+bd961d3 nand/s3c2410: add mising badblocksbits value
f12719d nand: Fix S3C NAND clok stop
acf3f89 input: lis302dl: fix the resume path
4682e58 (AG: there's some more rationale for changing this here
@@ -2166,7 +2167,7 @@ index 0000000..5bcc818
+MODULE_AUTHOR("Andy Green <andy@openmoko.com>");
+MODULE_DESCRIPTION("Neo1973 resume_reason");
diff --git a/drivers/mtd/nand/s3c2410.c b/drivers/mtd/nand/s3c2410.c
-index cb5d2c0..4666b5e 100644
+index cb5d2c0..9ca6a0e 100644
--- a/drivers/mtd/nand/s3c2410.c
+++ b/drivers/mtd/nand/s3c2410.c
@@ -55,7 +55,7 @@ static int hardware_ecc = 0;
@@ -2274,7 +2275,15 @@ index cb5d2c0..4666b5e 100644
clk_put(info->clk);
}
-@@ -947,7 +976,7 @@ static int s3c24xx_nand_probe(struct platform_device *pdev)
+@@ -773,6 +802,7 @@ static void s3c2410_nand_init_chip(struct s3c2410_nand_info *info,
+ chip->priv = nmtd;
+ chip->options = set->options;
+ chip->controller = &info->controller;
++ chip->badblockbits = 8;
+
+ switch (info->cpu_type) {
+ case TYPE_S3C2410:
+@@ -947,7 +977,7 @@ static int s3c24xx_nand_probe(struct platform_device *pdev)
goto exit_error;
}
@@ -2283,7 +2292,7 @@ index cb5d2c0..4666b5e 100644
/* allocate and map the resource */
-@@ -1026,9 +1055,9 @@ static int s3c24xx_nand_probe(struct platform_device *pdev)
+@@ -1026,9 +1056,9 @@ static int s3c24xx_nand_probe(struct platform_device *pdev)
goto exit_error;
}
@@ -2295,7 +2304,7 @@ index cb5d2c0..4666b5e 100644
}
pr_debug("initialised ok\n");
-@@ -1059,8 +1088,7 @@ static int s3c24xx_nand_suspend(struct platform_device *dev, pm_message_t pm)
+@@ -1059,8 +1089,7 @@ static int s3c24xx_nand_suspend(struct platform_device *dev, pm_message_t pm)
writel(info->save_sel | info->sel_bit, info->sel_reg);
@@ -2305,7 +2314,7 @@ index cb5d2c0..4666b5e 100644
}
return 0;
-@@ -1072,7 +1100,7 @@ static int s3c24xx_nand_resume(struct platform_device *dev)
+@@ -1072,7 +1101,7 @@ static int s3c24xx_nand_resume(struct platform_device *dev)
unsigned long sel;
if (info) {
@@ -2314,7 +2323,7 @@ index cb5d2c0..4666b5e 100644
s3c2410_nand_inithw(info);
/* Restore the state of the nFCE line. */
-@@ -1082,8 +1110,7 @@ static int s3c24xx_nand_resume(struct platform_device *dev)
+@@ -1082,8 +1111,7 @@ static int s3c24xx_nand_resume(struct platform_device *dev)
sel |= info->save_sel & info->sel_bit;
writel(sel, info->sel_reg);
diff --git a/recipes/linux/linux-2.6.39/shr.patch b/recipes/linux/linux-2.6.39/shr.patch
index 0c0a9f7550..330cbf7eb9 100644
--- a/recipes/linux/linux-2.6.39/shr.patch
+++ b/recipes/linux/linux-2.6.39/shr.patch
@@ -3,6 +3,7 @@ rebased on top of openmoko kernel repository
https://gitorious.org/shr/linux/commits/shr-2.6.39-nodrm
+efd94d3 nand/s3c2410: add mising badblocksbits value
56885e2 glamo-mci: revert changes for Per's patchset
6ab40bf Revert "mmc: add none blocking mmc request function"
7937634 Revert "mmc: mmc_test: add debugfs file to list all tests"
@@ -1920,6 +1921,18 @@ index 02c4b69..f298658 100644
mmc_host_enable(mmc);
mmc_remove_host(mmc);
mmc_host_disable(mmc);
+diff --git a/drivers/mtd/nand/s3c2410.c b/drivers/mtd/nand/s3c2410.c
+index cb5d2c0..66b75c6 100644
+--- a/drivers/mtd/nand/s3c2410.c
++++ b/drivers/mtd/nand/s3c2410.c
+@@ -773,6 +773,7 @@ static void s3c2410_nand_init_chip(struct s3c2410_nand_info *info,
+ chip->priv = nmtd;
+ chip->options = set->options;
+ chip->controller = &info->controller;
++ chip->badblockbits = 8;
+
+ switch (info->cpu_type) {
+ case TYPE_S3C2410:
diff --git a/include/linux/mmc/core.h b/include/linux/mmc/core.h
index 5bbfb71..07f27af 100644
--- a/include/linux/mmc/core.h
diff --git a/recipes/linux/linux-openmoko_2.6.37.bb b/recipes/linux/linux-openmoko_2.6.37.bb
index 69e1d6a9d6..24ba7df25b 100644
--- a/recipes/linux/linux-openmoko_2.6.37.bb
+++ b/recipes/linux/linux-openmoko_2.6.37.bb
@@ -1,3 +1,3 @@
require linux_${PV}.bb
require linux-openmoko.inc
-OM-PR = "3"
+OM-PR = "4"
diff --git a/recipes/linux/linux-openmoko_2.6.39.bb b/recipes/linux/linux-openmoko_2.6.39.bb
index 2824f6c6fd..69e1d6a9d6 100644
--- a/recipes/linux/linux-openmoko_2.6.39.bb
+++ b/recipes/linux/linux-openmoko_2.6.39.bb
@@ -1,3 +1,3 @@
require linux_${PV}.bb
require linux-openmoko.inc
-OM-PR = "2"
+OM-PR = "3"