aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-05-21 13:02:47 +0200
committerSimon Busch <morphis@gravedo.de>2011-05-25 09:55:56 +0200
commit5aac444b5a6a1ad5f8785f4bf1ad27026c7c5b49 (patch)
tree3ed61643f7a59d90f5be1153ea7155eb37e8c379
parentf327c8ebbfad6941576ade5d8f17e69ff9a51cc5 (diff)
downloadopenembedded-5aac444b5a6a1ad5f8785f4bf1ad27026c7c5b49.tar.gz
aurora: use qte.sh script at bootup to get the correct touchscreen configuration
After the boot the /etc/profile.d directory will only be evaluated when the user logs in so the QWS_MOUSE_PROTO environment variable is not set when the aurora daemon is started automatically by the init system. To workaround this we include the /etc/profile.d/qte.sh provided by qt4-embedded which is needed to execute aurora. Signed-off-by: Simon Busch <morphis@gravedo.de>
-rw-r--r--recipes/freesmartphone/aurora/aurora-daemon4
-rw-r--r--recipes/freesmartphone/aurora_git.bb2
2 files changed, 5 insertions, 1 deletions
diff --git a/recipes/freesmartphone/aurora/aurora-daemon b/recipes/freesmartphone/aurora/aurora-daemon
index 3bb8fae7dd..3c57fc3949 100644
--- a/recipes/freesmartphone/aurora/aurora-daemon
+++ b/recipes/freesmartphone/aurora/aurora-daemon
@@ -11,6 +11,10 @@ NAME=aurora
[ -f /etc/default/rcS ] && . /etc/default/rcS
+# to get the correct configuration of the touchscreen as /etc/profile is maybe not
+# evaluated at this time.
+[ -f /etc/profile.d/qte.sh ] && . /etc/profile.d/qte.sh
+
case "$1" in
start)
echo -n "Starting aurora-daemon: "
diff --git a/recipes/freesmartphone/aurora_git.bb b/recipes/freesmartphone/aurora_git.bb
index f1839c856e..46a3ed6d52 100644
--- a/recipes/freesmartphone/aurora_git.bb
+++ b/recipes/freesmartphone/aurora_git.bb
@@ -6,7 +6,7 @@ SECTION = "fso"
LICENSE = "GPLv2"
SRCREV = "6db9e04728bd0434e6b79939ee18be43017afeef"
PV = "0.1.0+gitr${SRCPV}"
-PR = "r1"
+PR = "r2"
SRC_URI = "\
${FREESMARTPHONE_GIT}/aurora.git;protocol=git;branch=master \