aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-01-29 14:49:29 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2011-01-29 19:02:22 +0100
commit52913dbb5bc298d55ff32612ad8308107b59058d (patch)
treea93729c8a899d6756c0e788ce5ee9fad1f249538
parent45dfa3d3668f343a627427a69bd8de59f399f9c5 (diff)
downloadopenembedded-52913dbb5bc298d55ff32612ad8308107b59058d.tar.gz
eina: introduce 1.0.0
* eina_svn is now D_P -1 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/efl1/eina-native_svn.bb6
-rw-r--r--recipes/efl1/eina.inc14
-rw-r--r--recipes/efl1/eina_1.0.0.bb10
-rw-r--r--recipes/efl1/eina_svn.bb21
4 files changed, 32 insertions, 19 deletions
diff --git a/recipes/efl1/eina-native_svn.bb b/recipes/efl1/eina-native_svn.bb
deleted file mode 100644
index 8cc34bb178..0000000000
--- a/recipes/efl1/eina-native_svn.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-require eina_svn.bb
-inherit native
-DEPENDS = ""
-# we no longer inherit pkgconfig, so we need to state this explicitly
-# (see explanation in efl.bbclass and autotools.bbclass)
-DEPENDS += "pkgconfig-native"
diff --git a/recipes/efl1/eina.inc b/recipes/efl1/eina.inc
new file mode 100644
index 0000000000..621cc9e59c
--- /dev/null
+++ b/recipes/efl1/eina.inc
@@ -0,0 +1,14 @@
+DESCRIPTION = "Eina is the Enlightenment data library"
+LICENSE = "LGPL"
+
+BBCLASSEXTEND = "native"
+INC_PR = "r0"
+
+inherit efl
+
+# Some upgrade path tweaking
+AUTO_LIBNAME_PKGS = ""
+
+RREPLACES_${PN} = "libeina-ver-pre-svn-00-0 libeina-ver-pre-svn-01-0"
+
+FILES_${PN} += "${libdir}/eina"
diff --git a/recipes/efl1/eina_1.0.0.bb b/recipes/efl1/eina_1.0.0.bb
new file mode 100644
index 0000000000..bbd4f12efc
--- /dev/null
+++ b/recipes/efl1/eina_1.0.0.bb
@@ -0,0 +1,10 @@
+require eina.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI = "\
+ ${E_MIRROR}/${SRCNAME}-${PV}.tar.gz \
+"
+
+SRC_URI[md5sum] = "207b64a6549642392c4a0760df78df59"
+SRC_URI[sha256sum] = "75e0795e0cb27e6278441b09e5299ee4e8fbacaf2a1d7a4a2b86a82f059b520b"
diff --git a/recipes/efl1/eina_svn.bb b/recipes/efl1/eina_svn.bb
index b4e9615627..23b45c52db 100644
--- a/recipes/efl1/eina_svn.bb
+++ b/recipes/efl1/eina_svn.bb
@@ -1,16 +1,11 @@
-DESCRIPTION = "Eina is the Enlightenment data library"
-LICENSE = "LGPL"
-PV = "0.0.2.060+svnr${SRCPV}"
-PR = "r1"
+require eina.inc
+
SRCREV = "${EFL_SRCREV}"
+PV = "1.0.999+svnr${SRCPV}"
+PR = "${INC_PR}.0"
+DEFAULT_PREFERENCE = "-1"
-inherit efl
-SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+SRC_URI = "\
+ ${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep \
+"
S = "${WORKDIR}/${SRCNAME}"
-
-# Some upgrade path tweaking
-AUTO_LIBNAME_PKGS = ""
-
-RREPLACES_${PN} = "libeina-ver-pre-svn-00-0 libeina-ver-pre-svn-01-0"
-
-FILES_${PN} += "${libdir}/eina"