summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-08-05 17:48:32 +0200
committerKoen Kooi <koen@openembedded.org>2010-08-05 20:11:13 +0200
commit07fb388f27c46e4ed7085461fd5a3952467876db (patch)
tree8cbc3116e648d67d765b0ccbf618a88256c29db6
parent71c6f94e7d8329ec44436c9f951522ff79940321 (diff)
downloadopenembedded-07fb388f27c46e4ed7085461fd5a3952467876db.tar.gz
eds-dbus: work around crosscompile badness
-rw-r--r--recipes/eds/eds-dbus_git.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/eds/eds-dbus_git.bb b/recipes/eds/eds-dbus_git.bb
index ee1addbf63..16b3276cfe 100644
--- a/recipes/eds/eds-dbus_git.bb
+++ b/recipes/eds/eds-dbus_git.bb
@@ -5,7 +5,7 @@ DEPENDS = "libical intltool-native libglade glib-2.0 gtk+ gconf dbus db gnome-co
SRCREV = "91812cd2f797fb8ec8befbb2685037584ce144ee"
PV = "1.4.0"
-PR = "r3"
+PR = "r4"
PE = "1"
PR_append = "+gitr${SRCREV}"
@@ -26,6 +26,11 @@ do_configure_prepend () {
cp ${WORKDIR}/gtk-doc.make ${S}
}
+do_configure_append() {
+ for i in $(find ${S} -name "Makefile") ; do
+ sed -i -e s:-I${includedir}::g $i
+ done
+}
EXTRA_OECONF = "--without-openldap --with-dbus --without-weather --without-bug-buddy --without-soup --without-libdb --with-libdb=${STAGING_DIR_HOST}${layout_prefix} --disable-smime --disable-nss --disable-nntp --disable-gtk-doc --enable-calendar --disable-hula --disable-dot-locking --disable-gnome-keyring"
PACKAGES =+ "libcamel-collateral libcamel libcamel-dev libebook libebook-dev libecal libecal-dev libedata-book libedata-book-dev libedata-cal libedata-cal-dev libedataserver libedataserver-dev"