summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-09-01 16:08:26 +0000
committerKhem Raj <raj.khem@gmail.com>2010-09-01 20:57:08 -0700
commit1d48a1c15d20e40e3479d7b09dc3ef1325a9f7ea (patch)
tree984c63024f196c2494952ab28f48407a2a66efc6
parent0f08f4a52c7db1514941c3925933d990767e8e85 (diff)
downloadopenembedded-1d48a1c15d20e40e3479d7b09dc3ef1325a9f7ea.tar.gz
gpsd: unbreak gpsd_2.38.bb and gpsd_2.39.bb
The older recipe(s) are needed for programs which have not updated to gpsd's newer api. e.g. prismstumbler. Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/gpsd/gpsd.inc5
-rw-r--r--recipes/gpsd/gpsd_2.90.bb5
-rw-r--r--recipes/gpsd/gpsd_2.91.bb5
-rw-r--r--recipes/gpsd/gpsd_2.94.bb5
-rw-r--r--recipes/gpsd/gpsd_2.95.bb5
5 files changed, 22 insertions, 3 deletions
diff --git a/recipes/gpsd/gpsd.inc b/recipes/gpsd/gpsd.inc
index 63d6433fd8..23335f00f4 100644
--- a/recipes/gpsd/gpsd.inc
+++ b/recipes/gpsd/gpsd.inc
@@ -4,7 +4,7 @@ PRIORITY = "optional"
LICENSE = "GPL"
DEPENDS = "dbus-glib ncurses python"
PROVIDES = "virtual/gpsd"
-INC_PR = "r9"
+INC_PR = "r10"
EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/X11 \
--x-libraries=${STAGING_LIBDIR} \
@@ -49,14 +49,13 @@ do_install_append() {
install -m 0644 ${WORKDIR}/60-gpsd.rules ${D}/${sysconfdir}/udev/rules.d
install -d ${D}${base_libdir}/udev/
install -m 0755 ${S}/gpsd.hotplug ${D}${base_libdir}/udev/
- install -m 0755 ${S}/gpsd.hotplug.wrapper ${D}${base_libdir}/udev/
}
pkg_postinst_${PN}-conf() {
update-alternatives --install ${sysconfdir}/default/gpsd gpsd-defaults ${sysconfdir}/default/gpsd.default 10
}
-pkg_postrm_${PN}-conf() {
+pkg_postrm_${PN}-conf() {
update-alternatives --remove gpsd-defaults ${sysconfdir}/default/gpsd.default
}
diff --git a/recipes/gpsd/gpsd_2.90.bb b/recipes/gpsd/gpsd_2.90.bb
index 25c739b7a8..69cd9bacc6 100644
--- a/recipes/gpsd/gpsd_2.90.bb
+++ b/recipes/gpsd/gpsd_2.90.bb
@@ -7,3 +7,8 @@ SRC_URI[gpsd.sha256sum] = "8c81461266fc95aae6519ec996d7e4f4801fb5a02dbcc7a5d1c13
PR = "${INC_PR}.0"
PARALLEL_MAKE = ""
+
+do_install_append() {
+ install -d ${D}${base_libdir}/udev/
+ install -m 0755 ${S}/gpsd.hotplug.wrapper ${D}${base_libdir}/udev/
+}
diff --git a/recipes/gpsd/gpsd_2.91.bb b/recipes/gpsd/gpsd_2.91.bb
index 7c575cb2b2..2c964ca027 100644
--- a/recipes/gpsd/gpsd_2.91.bb
+++ b/recipes/gpsd/gpsd_2.91.bb
@@ -8,3 +8,8 @@ SRC_URI[gpsd.sha256sum] = "02ee0f0a86a3c74fe807ea0a3fce908cb94dd7ff3afcef0b1fb66
PR = "${INC_PR}.0"
PARALLEL_MAKE = ""
+
+do_install_append() {
+ install -d ${D}${base_libdir}/udev/
+ install -m 0755 ${S}/gpsd.hotplug.wrapper ${D}${base_libdir}/udev/
+}
diff --git a/recipes/gpsd/gpsd_2.94.bb b/recipes/gpsd/gpsd_2.94.bb
index 66bd559a49..2b5e9d30a0 100644
--- a/recipes/gpsd/gpsd_2.94.bb
+++ b/recipes/gpsd/gpsd_2.94.bb
@@ -10,3 +10,8 @@ SRC_URI[gpsd.sha256sum] = "1520b87d106d198aa42137db4b230615dbd0d06b04e6fcc84e010
PR = "${INC_PR}.1"
PARALLEL_MAKE = ""
+
+do_install_append() {
+ install -d ${D}${base_libdir}/udev/
+ install -m 0755 ${S}/gpsd.hotplug.wrapper ${D}${base_libdir}/udev/
+}
diff --git a/recipes/gpsd/gpsd_2.95.bb b/recipes/gpsd/gpsd_2.95.bb
index 27aa851246..ddc4e917aa 100644
--- a/recipes/gpsd/gpsd_2.95.bb
+++ b/recipes/gpsd/gpsd_2.95.bb
@@ -12,3 +12,8 @@ SRC_URI[gpsd.sha256sum] = "832343a53921a8371efa540ba57c91dadedda445e571c1beb97c0
PR = "${INC_PR}.0"
PARALLEL_MAKE = ""
+
+do_install_append() {
+ install -d ${D}${base_libdir}/udev/
+ install -m 0755 ${S}/gpsd.hotplug.wrapper ${D}${base_libdir}/udev/
+}