summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman <raster@rasterman.com>2009-04-17 15:44:58 +1000
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2009-04-17 15:48:45 +1000
commit212e36417ae27e1be11147168b6f5cdfd1c5eda9 (patch)
tree00892cc3bca94534140f1e44ab98b4e58587410c
parentd92391844e4454ba9ea3af5b4273721496511ebb (diff)
downloadopenembedded-212e36417ae27e1be11147168b6f5cdfd1c5eda9.tar.gz
angstrom, exquisite, psplash, opkg, angsrtom-images, sysvinit: abstract splash
this abstracts psplash to be generic. now as long as something provides a splashfuncs file that sysvinit (and other scripts) can source, and all the approproate init hooks to start the splash etc. you can use psplash, exquisitie, usplash or anything that tickles your fancy. this moves splash toa ${SPLASH} variable to include in your image (or override). the default in angstrom is psplash - unless you override it. opkg also runs a configure script that cna take forever - and so this speically sends off some splash commands (if there) to let you know the systme is alive and working (but just busy). this is one commit as if this breaks things you either want to fix the minor break or totally revert the whole patch. i hope it didn't break anything.
-rw-r--r--conf/distro/angstrom-2008.1.conf2
-rw-r--r--recipes/angstrom/angstrom-gpe-task-base.bb2
-rw-r--r--recipes/e17/exquisite/exquisite-init10
-rw-r--r--recipes/e17/exquisite/splashfuncs29
-rw-r--r--recipes/e17/exquisite_svn.bb14
-rw-r--r--recipes/images/beagleboard-demo-image.bb1
-rw-r--r--recipes/images/bootmanager-image.bb2
-rw-r--r--recipes/images/gateway-image.bb1
-rw-r--r--recipes/images/illume-image.bb7
-rw-r--r--recipes/images/minimal-gpe-image.bb1
-rw-r--r--recipes/images/minimal-image.bb1
-rw-r--r--recipes/images/sdr-image.bb1
-rw-r--r--recipes/images/sugar-image.bb1
-rw-r--r--recipes/images/udumpty-image.bb1
-rw-r--r--recipes/images/x11-gpe-image.bb1
-rw-r--r--recipes/images/x11-gpe-java-image.bb1
-rw-r--r--recipes/images/x11-image.bb1
-rw-r--r--recipes/images/x11-office-image.bb1
-rw-r--r--recipes/images/x11-pimlico-image.bb1
-rw-r--r--recipes/initrdscripts/files/00-psplash.sh4
-rw-r--r--recipes/initrdscripts/files/99-psplash.sh4
-rw-r--r--recipes/initrdscripts/initramfs-module-psplash_1.0.bb2
-rwxr-xr-xrecipes/opie-init/opie-init/opie4
-rw-r--r--recipes/opie-init/opie-init_1.2.2.bb2
-rw-r--r--recipes/opkg/files/configure18
-rw-r--r--recipes/opkg/opkg-nogpg_svn.bb2
-rw-r--r--recipes/opkg/opkg_svn.bb26
-rw-r--r--recipes/psplash/files/psplash-init2
-rw-r--r--recipes/psplash/files/splashfuncs29
-rw-r--r--recipes/psplash/files/zzapsplash-init4
-rw-r--r--recipes/psplash/psplash-angstrom_svn.bb1
-rw-r--r--recipes/psplash/psplash.inc11
-rw-r--r--recipes/psplash/psplash_svn.bb3
-rwxr-xr-xrecipes/sysvinit/sysvinit/angstrom/rc13
-rw-r--r--recipes/sysvinit/sysvinit_2.86.bb2
-rw-r--r--recipes/tasks/task-base.bb2
36 files changed, 152 insertions, 55 deletions
diff --git a/conf/distro/angstrom-2008.1.conf b/conf/distro/angstrom-2008.1.conf
index 37cb8f068a..a26a98729a 100644
--- a/conf/distro/angstrom-2008.1.conf
+++ b/conf/distro/angstrom-2008.1.conf
@@ -237,7 +237,7 @@ DISTRO_EXTRA_RRECOMMENDS += " \
avahi-daemon \
avahi-autoipd \
openssh-sftp-server \
- ${@base_contains("MACHINE_FEATURES", "screen", "psplash-angstrom", "",d)} \
${DEBUG_APPS} \
"
+SPLASH ?= ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-angstrom", "",d)}'
diff --git a/recipes/angstrom/angstrom-gpe-task-base.bb b/recipes/angstrom/angstrom-gpe-task-base.bb
index f2c897dfb7..4540fddee6 100644
--- a/recipes/angstrom/angstrom-gpe-task-base.bb
+++ b/recipes/angstrom/angstrom-gpe-task-base.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Task packages for the Angstrom distribution"
-PR = "r37"
+PR = "r38"
inherit task
diff --git a/recipes/e17/exquisite/exquisite-init b/recipes/e17/exquisite/exquisite-init
index 1750184842..2de6774ffb 100644
--- a/recipes/e17/exquisite/exquisite-init
+++ b/recipes/e17/exquisite/exquisite-init
@@ -28,13 +28,13 @@ case `machine_id` in
esac
args=$args" $FPS $THEME"
-export EXDIR=/mnt/.exquisite
+export EXDIR=/mnt/.splash
export EXQUISITE_IPC=$EXDIR/exquisite
mount tmpfs -t tmpfs $EXDIR -o,size=40k
exquisite -fb -fs $args &
-exquisite-write -wait 40
+exquisite-write -wait 120
exquisite-write "PULSATE"
-
-# kill off exquisite in 300 seconds if its not gone yet
-(sleep 300; exquisite-write "QUIT")&
+setterm -blank 0
+setterm -powersave off
+setterm -powerdown 0
diff --git a/recipes/e17/exquisite/splashfuncs b/recipes/e17/exquisite/splashfuncs
new file mode 100644
index 0000000000..ada2a96dd4
--- /dev/null
+++ b/recipes/e17/exquisite/splashfuncs
@@ -0,0 +1,29 @@
+status() {
+ if type splash-write >/dev/null 2>&1; then
+ (TMPDIR="/mnt/.splash" EXQUISITE_IPC="$TMPDIR/exquisite" splash-write "$1" || true) &
+ fi
+}
+
+status_position() {
+ status "PROGRESS $1"
+}
+
+status_title() {
+ status "TITLE $1"
+}
+
+status_text() {
+ if test -n "$1"; then
+ status "MSG $1"
+ else
+ status "CLEAR"
+ fi
+}
+
+status_pulse() {
+ status "PULSATE"
+}
+
+status_tick() {
+ status "TICK"
+}
diff --git a/recipes/e17/exquisite_svn.bb b/recipes/e17/exquisite_svn.bb
index e303600d58..ac4c6b57d4 100644
--- a/recipes/e17/exquisite_svn.bb
+++ b/recipes/e17/exquisite_svn.bb
@@ -2,9 +2,10 @@ DESCRIPTION = "A psplash replacement for display"
LICENSE = "MIT BSD"
DEPENDS = "eet evas ecore embryo edje"
PV = "0.0.1+svnr${SRCREV}"
-PR = "r3"
+PR = "r8"
RDEPENDS = "initscripts"
RRECOMMENDS_${PN} = "exquisite-themes"
+RCONFLICTS_${PN} = "psplash virtual/psplash"
SRCNAME = "exquisite"
@@ -13,13 +14,18 @@ inherit e
EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
SRC_URI += "file://exquisite-init"
+SRC_URI += "file://splashfuncs"
inherit update-rc.d
do_install_prepend() {
- install -d ${D}/mnt/.exquisite/
- install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}/mnt/.splash/
+ install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/exquisite-init ${D}${sysconfdir}/init.d/exquisite
+ install -d ${D}${sysconfdir}/default
+ install -m 0755 ${WORKDIR}/splashfuncs ${D}${sysconfdir}/default/splashfuncs
+ install -d ${D}${bindir}
+ ln -s exquisite-write ${D}${bindir}/splash-write
}
@@ -30,4 +36,4 @@ do_install_append() {
INITSCRIPT_NAME = "exquisite"
INITSCRIPT_PARAMS = "start 01 S . stop 20 0 1 6 ."
-FILES_${PN} += "/mnt/.exquisite/"
+FILES_${PN} += "/mnt/.splash/"
diff --git a/recipes/images/beagleboard-demo-image.bb b/recipes/images/beagleboard-demo-image.bb
index 4007daec25..7d0e408b73 100644
--- a/recipes/images/beagleboard-demo-image.bb
+++ b/recipes/images/beagleboard-demo-image.bb
@@ -18,6 +18,7 @@ IMAGE_INSTALL = "\
${XSERVER} \
${ANGSTROM_EXTRA_INSTALL} \
task-beagleboard-demo \
+ ${SPLASH} \
"
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
diff --git a/recipes/images/bootmanager-image.bb b/recipes/images/bootmanager-image.bb
index d829590188..1f8c3273f6 100644
--- a/recipes/images/bootmanager-image.bb
+++ b/recipes/images/bootmanager-image.bb
@@ -1,7 +1,7 @@
#Angstrom bootmanager image
DEPENDS = "task-angstrom"
-IMAGE_INSTALL = "angstrom-base-depends angstrom-bootmanager"
+IMAGE_INSTALL = "angstrom-base-depends angstrom-bootmanager ${SPLASH}"
export IMAGE_BASENAME = "bootmanager-image"
diff --git a/recipes/images/gateway-image.bb b/recipes/images/gateway-image.bb
index ee9d1d97fc..8df21bcbeb 100644
--- a/recipes/images/gateway-image.bb
+++ b/recipes/images/gateway-image.bb
@@ -11,6 +11,7 @@ IMAGE_INSTALL = "task-boot \
dnsmasq \
# vsftpd \
angstrom-version \
+ ${SPLASH} \
"
export IMAGE_BASENAME = "gateway-image"
diff --git a/recipes/images/illume-image.bb b/recipes/images/illume-image.bb
index 9c2b1befed..3ab006ae9c 100644
--- a/recipes/images/illume-image.bb
+++ b/recipes/images/illume-image.bb
@@ -4,6 +4,9 @@
IMAGE_LINGUAS = "en-us de-de fr-fr pt-br ca-es zh-cn zh-tw bg-bg cs-cz da-dk nl-nl fi-fi hu-hu it-it ja-jp ko-kr nb-no pl-pl ru-ru sk-sk sl-si es-ar sv-se"
+# use exquisite splash
+SPLASH = "exquisite exquisite-themes exquisite-theme-illume"
+
# getting the base system up
BASE_INSTALL = "\
angstrom-libc-fixup-hack \
@@ -17,9 +20,6 @@ BASE_INSTALL = "\
pointercal \
tslib-conf \
# prelink \
-# exquisite \
-# exquisite-themes \
-# exquisite-theme-illume \
# rsync \
# screen \
# fbset \
@@ -154,6 +154,7 @@ IMAGE_INSTALL = "\
# ${ZHONE_INSTALL} \
${APPS_INSTALL} \
${DEV_INSTALL} \
+ ${SPLASH} \
"
inherit image
diff --git a/recipes/images/minimal-gpe-image.bb b/recipes/images/minimal-gpe-image.bb
index 5dd08f6e23..d71f9dee19 100644
--- a/recipes/images/minimal-gpe-image.bb
+++ b/recipes/images/minimal-gpe-image.bb
@@ -17,6 +17,7 @@ IMAGE_INSTALL = "\
gpe-terminal \
angstrom-feed-configs \
opkg-nogpg opkg-collateral \
+ ${SPLASH} \
"
#zap root password for release images
diff --git a/recipes/images/minimal-image.bb b/recipes/images/minimal-image.bb
index e1635dcdf7..0acb5f1ad1 100644
--- a/recipes/images/minimal-image.bb
+++ b/recipes/images/minimal-image.bb
@@ -11,6 +11,7 @@ IMAGE_INSTALL = "task-boot \
${DISTRO_SSH_DAEMON} \
${ANGSTROM_EXTRA_INSTALL} \
angstrom-version \
+ ${SPLASH} \
"
export IMAGE_BASENAME = "minimalist-image"
diff --git a/recipes/images/sdr-image.bb b/recipes/images/sdr-image.bb
index 9e0f4e6a41..8338a57338 100644
--- a/recipes/images/sdr-image.bb
+++ b/recipes/images/sdr-image.bb
@@ -43,6 +43,7 @@ IMAGE_INSTALL = " task-base-extended \
uucp picocom \
angstrom-zeroconf-audio avahi-utils \
${ANGSTROM_EXTRA_INSTALL} \
+ ${SPLASH} \
"
inherit image
diff --git a/recipes/images/sugar-image.bb b/recipes/images/sugar-image.bb
index 4dbc1671af..2787f99e00 100644
--- a/recipes/images/sugar-image.bb
+++ b/recipes/images/sugar-image.bb
@@ -10,6 +10,7 @@ IMAGE_INSTALL = "\
angstrom-gpe-task-base \
angstrom-gpe-task-settings \
sugar-sucrose \
+ ${SPLASH} \
${ANGSTROM_EXTRA_INSTALL}"
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
diff --git a/recipes/images/udumpty-image.bb b/recipes/images/udumpty-image.bb
index c55381ed30..e581a8edab 100644
--- a/recipes/images/udumpty-image.bb
+++ b/recipes/images/udumpty-image.bb
@@ -43,6 +43,7 @@ IMAGE_INSTALL = "\
gnome-control-center \
gnome-settings-daemon \
gnome-session \
+ ${SPLASH} \
"
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
diff --git a/recipes/images/x11-gpe-image.bb b/recipes/images/x11-gpe-image.bb
index 7b272f60a1..03c9761663 100644
--- a/recipes/images/x11-gpe-image.bb
+++ b/recipes/images/x11-gpe-image.bb
@@ -16,6 +16,7 @@ IMAGE_INSTALL = "\
kernel-modules \
hal \
angstrom-gpe-task-pim \
+ ${SPLASH} \
${ANGSTROM_EXTRA_INSTALL}"
diff --git a/recipes/images/x11-gpe-java-image.bb b/recipes/images/x11-gpe-java-image.bb
index fcc022c7a0..b8904e303c 100644
--- a/recipes/images/x11-gpe-java-image.bb
+++ b/recipes/images/x11-gpe-java-image.bb
@@ -18,6 +18,7 @@ IMAGE_INSTALL = "\
kernel-modules \
hal \
angstrom-gpe-task-pim \
+ ${SPLASH} \
${ANGSTROM_EXTRA_INSTALL}"
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
diff --git a/recipes/images/x11-image.bb b/recipes/images/x11-image.bb
index 093e0c5b6d..7c632e3a96 100644
--- a/recipes/images/x11-image.bb
+++ b/recipes/images/x11-image.bb
@@ -12,6 +12,7 @@ IMAGE_INSTALL = "\
angstrom-x11-base-depends \
angstrom-gpe-task-base \
angstrom-gpe-task-settings \
+ ${SPLASH} \
${ANGSTROM_EXTRA_INSTALL}"
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
diff --git a/recipes/images/x11-office-image.bb b/recipes/images/x11-office-image.bb
index 48799d8998..66cc762d93 100644
--- a/recipes/images/x11-office-image.bb
+++ b/recipes/images/x11-office-image.bb
@@ -21,6 +21,7 @@ IMAGE_INSTALL = "\
claws-mail claws-mail claws-plugin-mailmbox claws-plugin-rssyl \
midori minimo \
gphoto2 \
+ ${SPLASH} \
${ANGSTROM_EXTRA_INSTALL}"
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
diff --git a/recipes/images/x11-pimlico-image.bb b/recipes/images/x11-pimlico-image.bb
index 79dcacce6e..e16eb51043 100644
--- a/recipes/images/x11-pimlico-image.bb
+++ b/recipes/images/x11-pimlico-image.bb
@@ -16,6 +16,7 @@ IMAGE_INSTALL = "\
kernel-modules \
hal \
angstrom-ohand-task-pim \
+ ${SPLASH} \
${ANGSTROM_EXTRA_INSTALL}"
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
diff --git a/recipes/initrdscripts/files/00-psplash.sh b/recipes/initrdscripts/files/00-psplash.sh
index db8aabedd7..bd1ed04452 100644
--- a/recipes/initrdscripts/files/00-psplash.sh
+++ b/recipes/initrdscripts/files/00-psplash.sh
@@ -1,6 +1,6 @@
if ! grep -Eq '\s?psplash=false\s?' /proc/cmdline; then
- mkdir -p /mnt/.psplash
- mount tmpfs -t tmpfs /mnt/.psplash -o,size=40k
+ mkdir -p /mnt/.splash
+ mount tmpfs -t tmpfs /mnt/.splash -o,size=40k
psplash &
fi
diff --git a/recipes/initrdscripts/files/99-psplash.sh b/recipes/initrdscripts/files/99-psplash.sh
index 3d5f1d60d1..ae8495c39b 100644
--- a/recipes/initrdscripts/files/99-psplash.sh
+++ b/recipes/initrdscripts/files/99-psplash.sh
@@ -1,4 +1,4 @@
if ! grep -Eq '\s?psplash=false\s?' /proc/cmdline; then
- mkdir -p /mnt/mnt/.psplash
- mount -n -o move /mnt/.psplash /mnt/mnt/.psplash
+ mkdir -p /mnt/mnt/.s0plash
+ mount -n -o move /mnt/.splash /mnt/mnt/.splash
fi
diff --git a/recipes/initrdscripts/initramfs-module-psplash_1.0.bb b/recipes/initrdscripts/initramfs-module-psplash_1.0.bb
index 44781fb6bf..8d61257220 100644
--- a/recipes/initrdscripts/initramfs-module-psplash_1.0.bb
+++ b/recipes/initrdscripts/initramfs-module-psplash_1.0.bb
@@ -1,5 +1,5 @@
SRC_URI = "file://00-psplash.sh file://99-psplash.sh"
-PR = "r3"
+PR = "r4"
RDEPENDS = "initramfs-uniboot virtual/psplash"
DESCRIPTION = "An initramfs module to enable psplash."
diff --git a/recipes/opie-init/opie-init/opie b/recipes/opie-init/opie-init/opie
index d7e06e5ce2..6bebec7955 100755
--- a/recipes/opie-init/opie-init/opie
+++ b/recipes/opie-init/opie-init/opie
@@ -43,8 +43,8 @@ fi
case $1 in
'start')
# Turn off psplash if any - sleep is required for anti-race
- if [ -e /mnt/.psplash ]; then
- TMPDIR=/mnt/.psplash psplash-write "QUIT" || true
+ if [ -e /mnt/.splash ]; then
+ TMPDIR=/mnt/.splash splash-write "QUIT" || true
sleep 1
fi
diff --git a/recipes/opie-init/opie-init_1.2.2.bb b/recipes/opie-init/opie-init_1.2.2.bb
index b52e162e50..0a03abbc56 100644
--- a/recipes/opie-init/opie-init_1.2.2.bb
+++ b/recipes/opie-init/opie-init_1.2.2.bb
@@ -1,5 +1,5 @@
require ${PN}.inc
-PR = "r8"
+PR = "r9"
SRC_URI = "file://opie-reorgfiles \
file://opie \
diff --git a/recipes/opkg/files/configure b/recipes/opkg/files/configure
new file mode 100644
index 0000000000..1a8c3149b5
--- /dev/null
+++ b/recipes/opkg/files/configure
@@ -0,0 +1,18 @@
+#!/bin/sh
+# get splash funcs
+if [ -f /etc/default/splashfuncs ]; then
+ . /etc/default/splashfuncs
+fi
+## tell boot status to "pulsate" really long busy cycle here
+status_pulse || true
+# run configure in bg
+opkg-cl configure &
+PID=$!
+# while configure still running loop
+while test -d /proc/$PID; do
+# tick to splash so it doesn't time out
+ status_tick || true
+ sleep 1
+done
+# delete myself
+rm -f /etc/rcS.d/S98configure
diff --git a/recipes/opkg/opkg-nogpg_svn.bb b/recipes/opkg/opkg-nogpg_svn.bb
index a9297d7645..641c7be451 100644
--- a/recipes/opkg/opkg-nogpg_svn.bb
+++ b/recipes/opkg/opkg-nogpg_svn.bb
@@ -3,7 +3,7 @@ require opkg_svn.bb
DEPENDS = "curl"
PROVIDES += "opkg"
-PR = "r3"
+PR = "r11"
SRCREV = "${SRCREV_pn-opkg}"
diff --git a/recipes/opkg/opkg_svn.bb b/recipes/opkg/opkg_svn.bb
index a4728970ce..bc9af61dce 100644
--- a/recipes/opkg/opkg_svn.bb
+++ b/recipes/opkg/opkg_svn.bb
@@ -1,6 +1,6 @@
require opkg.inc
-PR = "r2"
+PR = "r11"
PACKAGES =+ "libopkg-dev libopkg"
@@ -12,23 +12,17 @@ FILES_libopkg = "${libdir}/*.so.*"
OPKG_INIT_POSITION = "98"
OPKG_INIT_POSITION_slugos = "41"
+SRC_URI += "file://configure"
+
+do_install_prepend() {
+ install -d ${D}${sysconfdir}/rcS.d
+ install -m 0755 ${WORKDIR}/configure ${D}${sysconfdir}/rcS.d/S98configure
+}
+
pkg_postinst_${PN} () {
-#!/bin/sh
-if [ "x$D" != "x" ]; then
- install -d $D${sysconfdir}/rcS.d
- # this happens at S98 where our good 'ole packages script used to run
- echo "#!/bin/sh
-opkg-cl configure
-rm -f ${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
-" > $D${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
- chmod 0755 $D${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
-fi
-
-update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
+ update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
}
pkg_postrm_${PN} () {
-#!/bin/sh
-update-alternatives --remove opkg ${bindir}/opkg-cl
+ update-alternatives --remove opkg ${bindir}/opkg-cl
}
-
diff --git a/recipes/psplash/files/psplash-init b/recipes/psplash/files/psplash-init
index a4fb1dc7d1..0409240232 100644
--- a/recipes/psplash/files/psplash-init
+++ b/recipes/psplash/files/psplash-init
@@ -15,7 +15,7 @@ case `machine_id` in
PARAMS='-a 270' ;;
esac
-export TMPDIR=/mnt/.psplash
+export TMPDIR=/mnt/.splash
mount tmpfs -t tmpfs $TMPDIR -o,size=40k
/usr/bin/psplash $PARAMS &
diff --git a/recipes/psplash/files/splashfuncs b/recipes/psplash/files/splashfuncs
new file mode 100644
index 0000000000..ada2a96dd4
--- /dev/null
+++ b/recipes/psplash/files/splashfuncs
@@ -0,0 +1,29 @@
+status() {
+ if type splash-write >/dev/null 2>&1; then
+ (TMPDIR="/mnt/.splash" EXQUISITE_IPC="$TMPDIR/exquisite" splash-write "$1" || true) &
+ fi
+}
+
+status_position() {
+ status "PROGRESS $1"
+}
+
+status_title() {
+ status "TITLE $1"
+}
+
+status_text() {
+ if test -n "$1"; then
+ status "MSG $1"
+ else
+ status "CLEAR"
+ fi
+}
+
+status_pulse() {
+ status "PULSATE"
+}
+
+status_tick() {
+ status "TICK"
+}
diff --git a/recipes/psplash/files/zzapsplash-init b/recipes/psplash/files/zzapsplash-init
index 5a713e5701..19e18960b6 100644
--- a/recipes/psplash/files/zzapsplash-init
+++ b/recipes/psplash/files/zzapsplash-init
@@ -1,4 +1,4 @@
#!/bin/sh
-TMPDIR=/mnt/.psplash psplash-write "QUIT" || true
+TMPDIR=/mnt/.splash psplash-write "QUIT" || true
sleep 1
-umount /mnt/.psplash >/dev/null 2>/dev/null
+umount /mnt/.splash >/dev/null 2>/dev/null
diff --git a/recipes/psplash/psplash-angstrom_svn.bb b/recipes/psplash/psplash-angstrom_svn.bb
index 401afdfda9..f65fb81429 100644
--- a/recipes/psplash/psplash-angstrom_svn.bb
+++ b/recipes/psplash/psplash-angstrom_svn.bb
@@ -14,6 +14,7 @@ SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
file://psplash-hand-img.h \
file://psplash-bar-img.h \
file://psplash-default \
+ file://splashfuncs \
file://psplash-init"
S = "${WORKDIR}/psplash"
diff --git a/recipes/psplash/psplash.inc b/recipes/psplash/psplash.inc
index 89464694bc..a038f63f1c 100644
--- a/recipes/psplash/psplash.inc
+++ b/recipes/psplash/psplash.inc
@@ -5,9 +5,10 @@ LICENSE = "GPL"
RDEPENDS = "initscripts"
PROVIDES = "virtual/psplash"
RPROVIDES_${PN} = "virtual/psplash"
+RCONFLICTS_${PN} = "exquisite"
PV = "0.0+svnr${SRCREV}"
-PR = "r2"
+PR = "r20"
# You can create your own pslash-hand-img.h by doing
# ./make-image-header.sh <file>.png HAND
@@ -27,11 +28,15 @@ do_configure_append() {
}
do_install_prepend() {
- install -d ${D}/mnt/.psplash/
+ install -d ${D}/mnt/.splash/
install -d ${D}${sysconfdir}/default/
install -m 0644 ${WORKDIR}/psplash-default ${D}${sysconfdir}/default/psplash
install -d ${D}${sysconfdir}/init.d/
install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash
+ install -d ${D}${bindir}
+ ln -s psplash-write ${D}${bindir}/splash-write
+ install -d ${D}${sysconfdir}/default
+ install -m 0755 ${WORKDIR}/splashfuncs ${D}${sysconfdir}/default/splashfuncs
}
INITSCRIPT_NAME = "psplash"
@@ -40,4 +45,4 @@ INITSCRIPT_PARAMS = "start 01 S . stop 20 0 1 6 ."
PACKAGES =+ "psplash-support"
RDEPENDS_${PN} += "psplash-support"
-FILES_psplash-support += "/mnt/.psplash ${sysconfdir} ${bindir}/psplash-write"
+FILES_psplash-support += "/mnt/.splash ${sysconfdir} ${bindir}/psplash-write ${bindir}/splash-write"
diff --git a/recipes/psplash/psplash_svn.bb b/recipes/psplash/psplash_svn.bb
index cb370b7627..8119ccf1e7 100644
--- a/recipes/psplash/psplash_svn.bb
+++ b/recipes/psplash/psplash_svn.bb
@@ -3,12 +3,13 @@ require psplash-ua.inc
ALTERNATIVE_PRIORITY = "10"
-PR = "r19"
+PR = "r20"
SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
file://psplash-hand-img.h \
file://psplash-bar-img.h \
file://psplash-default \
+ file://splashfuncs \
file://psplash-init"
S = "${WORKDIR}/psplash"
diff --git a/recipes/sysvinit/sysvinit/angstrom/rc b/recipes/sysvinit/sysvinit/angstrom/rc
index 30b69ad516..6c5f4ca2ec 100755
--- a/recipes/sysvinit/sysvinit/angstrom/rc
+++ b/recipes/sysvinit/sysvinit/angstrom/rc
@@ -16,6 +16,9 @@
#
. /etc/default/rcS
+if [ -f /etc/default/splashfuncs ]; then
+ . /etc/default/splashfuncs
+fi
export VERBOSE
startup_progress() {
@@ -26,9 +29,7 @@ startup_progress() {
progress=$progress_size
fi
#echo "PROGRESS is $progress $runlevel $first_step + ($step of $num_steps) $step_change $progress_size"
- if type psplash-write >/dev/null 2>&1; then
- TMPDIR=/mnt/.psplash psplash-write "PROGRESS $progress" || true
- fi
+ status_position $progress || true
}
@@ -169,8 +170,8 @@ startup() {
#Uncomment to cause psplash to exit manually, otherwise it exits when it sees a VC switch
#if [ "x$runlevel" != "xS" ]; then
-# if type psplash-write >/dev/null 2>&1; then
-# TMPDIR=/mnt/.psplash psplash-write "QUIT" || true
-# umount /mnt/.psplash
+# if type splash-write >/dev/null 2>&1; then
+# TMPDIR=/mnt/.splash splash-write "QUIT" || true
+# umount /mnt/.splash
# fi
#fi
diff --git a/recipes/sysvinit/sysvinit_2.86.bb b/recipes/sysvinit/sysvinit_2.86.bb
index 6e6f98c6ed..d3a151703f 100644
--- a/recipes/sysvinit/sysvinit_2.86.bb
+++ b/recipes/sysvinit/sysvinit_2.86.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "System-V like init."
SECTION = "base"
LICENSE = "GPL"
HOMEPAGE = "http://freshmeat.net/projects/sysvinit/"
-PR = "r46"
+PR = "r52"
# USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf.
# Set PACKAGE_ARCH appropriately.
diff --git a/recipes/tasks/task-base.bb b/recipes/tasks/task-base.bb
index 4003359dd1..2269662ebe 100644
--- a/recipes/tasks/task-base.bb
+++ b/recipes/tasks/task-base.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Merge machine and distro options to create a basic machine task/package"
-PR = "r80"
+PR = "r82"
inherit task