summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorIhar Hrachyshka <ihar.hrachyshka@gmail.com>2009-03-25 05:47:34 +0000
committerCliff Brake <cbrake@bec-systems.com>2009-03-27 11:49:23 -0400
commit413872c423b266f598e08736556fd129526f8dac (patch)
tree9e291283def2610c86485c7044f5ef3d78b756db
parentf3fdd55a8f525ff59c793c0cbe8f43463021e96f (diff)
downloadopenembedded-413872c423b266f598e08736556fd129526f8dac.tar.gz
libzip: new recipe
This is a C library for reading, creating, and modifying zip archives. Package is created for libzip-0.9
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/libzip/libzip_0.9.bb13
2 files changed, 17 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 43d68f92cb..b74d8f75e9 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -14402,6 +14402,10 @@ sha256=ccefd4ceb29bb729dcaa9a9d4a86654a9134adfd29bdd72be1a9d3726efb54e0
md5=d6a9a020a76a3db17848d769d6c9c8a9
sha256=4e1f39ee16596fd2a83d28d6c3b065f742254f3336f93ce8ed1cae48ecbe49da
+[http://www.nih.at/libzip/libzip-0.9.tar.bz2]
+md5=56b9f11c1eee5eed189a20183d7e06b0
+sha256=23a8c3624122a3777bb4ac3be4a867fd0bed7f3aacb8f1d0b68fc459cfb035fc
+
[http://downloads.sourceforge.net/lightblue/lightblue-0.3.3.tar.gz]
md5=fb3761c8fff39a792035db4767847169
sha256=90b3271e5ce4de91d3651ba11b92e64fc7afb2a54ebe01826023e5bb2b53a3bc
diff --git a/recipes/libzip/libzip_0.9.bb b/recipes/libzip/libzip_0.9.bb
new file mode 100644
index 0000000000..914a0c1a38
--- /dev/null
+++ b/recipes/libzip/libzip_0.9.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "C library for reading, creating, and modifying zip archives"
+SECTION = "libs"
+HOMEPAGE = "http://www.nih.at/libzip"
+LICENSE = "BSD"
+DEPENDS = "zlib"
+
+SRC_URI = "http://www.nih.at/${PN}/${PN}-${PV}.tar.bz2"
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_all
+}