summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-04-21 13:42:52 +0200
committerKoen Kooi <koen@openembedded.org>2010-04-21 13:42:52 +0200
commit5e126716e0662ef9aaaa2132d9e98791254bce5e (patch)
tree454f5fcce1b3abce3b2d0da54f31655d275ae6ea
parent244c241f0439f822f4969e81681e540da56677f7 (diff)
downloadopenembedded-5e126716e0662ef9aaaa2132d9e98791254bce5e.tar.gz
linux-omap-psp 2.6.32: change 37xx OPP to latest definitions
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/0043-ARM-OMAP-Change-DSP-rate-table-for-36xx-37xx.patch54
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/beagleboard/defconfig4
-rw-r--r--recipes/linux/linux-omap-psp_2.6.32.bb1
3 files changed, 57 insertions, 2 deletions
diff --git a/recipes/linux/linux-omap-psp-2.6.32/0043-ARM-OMAP-Change-DSP-rate-table-for-36xx-37xx.patch b/recipes/linux/linux-omap-psp-2.6.32/0043-ARM-OMAP-Change-DSP-rate-table-for-36xx-37xx.patch
new file mode 100644
index 0000000000..b6aca645cc
--- /dev/null
+++ b/recipes/linux/linux-omap-psp-2.6.32/0043-ARM-OMAP-Change-DSP-rate-table-for-36xx-37xx.patch
@@ -0,0 +1,54 @@
+From 82d4a1e8295fec4869eb85c597074c124e1f493d Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Wed, 10 Mar 2010 17:42:54 +0100
+Subject: [PATCH 43/43] ARM: OMAP: Change DSP rate table for 36xx/37xx:
+
+The frequencies are now:
+
+ARM: DSP:
+300 300
+600 600
+800 800
+1000 430
+---
+ arch/arm/mach-omap2/omap3-opp.h | 1 +
+ arch/arm/mach-omap2/pm34xx.c | 8 ++++----
+ 2 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/arch/arm/mach-omap2/omap3-opp.h b/arch/arm/mach-omap2/omap3-opp.h
+index 7cc11df..2e546d9 100644
+--- a/arch/arm/mach-omap2/omap3-opp.h
++++ b/arch/arm/mach-omap2/omap3-opp.h
+@@ -4,6 +4,7 @@
+ #include <plat/omap-pm.h>
+
+ /* MPU speeds */
++#define S1200M 1200000000
+ #define S1000M 1000000000
+ #define S800M 800000000
+ #define S720M 720000000
+diff --git a/arch/arm/mach-omap2/pm34xx.c b/arch/arm/mach-omap2/pm34xx.c
+index 6bd7918..e0d517a 100644
+--- a/arch/arm/mach-omap2/pm34xx.c
++++ b/arch/arm/mach-omap2/pm34xx.c
+@@ -177,13 +177,13 @@ struct omap_opp omap37x_mpu_rate_table[] = {
+ struct omap_opp omap37x_dsp_rate_table[] = {
+ {0, 0, 0},
+ /*OPP1 (OPP50) */
+- {S260M, VDD1_OPP1, 0x1B},
++ {S300M, VDD1_OPP1, 0x1B},
+ /*OPP2 (OPP100) */
+- {S520M, VDD1_OPP2, 0x28},
++ {S600M, VDD1_OPP2, 0x28},
+ /*OPP3 (OPP120) */
+- {S660M, VDD1_OPP3, 0x35},
++ {S800M, VDD1_OPP3, 0x35},
+ /*OPP4 (OPPTM) */
+- {S875M, VDD1_OPP4, 0x39},
++ {S430M, VDD1_OPP4, 0x39},
+ };
+
+ struct omap_opp omap37x_l3_rate_table[] = {
+--
+1.6.6.1
+
diff --git a/recipes/linux/linux-omap-psp-2.6.32/beagleboard/defconfig b/recipes/linux/linux-omap-psp-2.6.32/beagleboard/defconfig
index ca0ca42f66..0551ac63fe 100644
--- a/recipes/linux/linux-omap-psp-2.6.32/beagleboard/defconfig
+++ b/recipes/linux/linux-omap-psp-2.6.32/beagleboard/defconfig
@@ -381,9 +381,9 @@ CONFIG_CPU_FREQ_TABLE=y
CONFIG_CPU_FREQ_DEBUG=y
CONFIG_CPU_FREQ_STAT=y
CONFIG_CPU_FREQ_STAT_DETAILS=y
-# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
+CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_POWERSAVE is not set
-CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE=y
+# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
diff --git a/recipes/linux/linux-omap-psp_2.6.32.bb b/recipes/linux/linux-omap-psp_2.6.32.bb
index d157399e48..e9a699b0c2 100644
--- a/recipes/linux/linux-omap-psp_2.6.32.bb
+++ b/recipes/linux/linux-omap-psp_2.6.32.bb
@@ -54,6 +54,7 @@ SRC_URI = "git://arago-project.org/git/people/sriram/ti-psp-omap.git;protocol=gi
file://0040-ARM-Add-option-to-allow-userspace-access-to-performa.patch;patch=1 \
file://0041-ARM-Expose-some-PMON-registers-through-sysfs.patch;patch=1 \
file://0042-musb-allow-host-io-without-gadget-module.patch;patch=1 \
+ file://0043-ARM-OMAP-Change-DSP-rate-table-for-36xx-37xx.patch;patch=1 \
file://defconfig"
SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \