aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-10-14 14:25:07 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-10-14 14:25:07 -0400
commit806811bf2d72827d3031bfcd5dbab1e82324d34e (patch)
treebef24882ac9b79fa3854de08889baf2e5afd8669
parentd74ca99871974a6efe3e024bfb6297e37c6291e3 (diff)
downloadopenembedded-806811bf2d72827d3031bfcd5dbab1e82324d34e.tar.gz
openembedded-806811bf2d72827d3031bfcd5dbab1e82324d34e.tar.bz2
openembedded-806811bf2d72827d3031bfcd5dbab1e82324d34e.zip
angstrom: clean ups of the external toolchain support
-rw-r--r--conf/distro/angstrom-2008.1.conf1
-rw-r--r--conf/distro/include/angstrom-glibc.inc2
-rw-r--r--conf/distro/include/glibc.inc20
-rw-r--r--recipes/meta/external-toolchain-generic.bb8
4 files changed, 4 insertions, 27 deletions
diff --git a/conf/distro/angstrom-2008.1.conf b/conf/distro/angstrom-2008.1.conf
index 07c62a091c..4b601b2409 100644
--- a/conf/distro/angstrom-2008.1.conf
+++ b/conf/distro/angstrom-2008.1.conf
@@ -146,7 +146,6 @@ PREFERRED_PROVIDER_virtual/libsdl ?= "libsdl-x11"
PREFERRED_PROVIDER_virtual/libx11 ?= "libx11"
# Others:
-PREFERRED_PROVIDER_linux-libc-headers = "linux-libc-headers"
PREFERRED_PROVIDER_dbus-glib = "dbus-glib"
PREFERRED_PROVIDER_esound ?= "pulseaudio"
PREFERRED_PROVIDER_gconf ?= "gconf"
diff --git a/conf/distro/include/angstrom-glibc.inc b/conf/distro/include/angstrom-glibc.inc
index fe78f48ea8..4488becd92 100644
--- a/conf/distro/include/angstrom-glibc.inc
+++ b/conf/distro/include/angstrom-glibc.inc
@@ -1,6 +1,4 @@
# glibc:
-require conf/distro/include/glibc.inc
-
require conf/distro/include/glibc-${TOOLCHAIN_TYPE}.inc
TARGET_OS = "linux"
diff --git a/conf/distro/include/glibc.inc b/conf/distro/include/glibc.inc
deleted file mode 100644
index 2cb6502322..0000000000
--- a/conf/distro/include/glibc.inc
+++ /dev/null
@@ -1,20 +0,0 @@
-# Add glibc to the overrides.
-OVERRIDES .= ":libc-glibc"
-
-# The things glibc can provide. We default to wanting glibc to provide them.
-PREFERRED_PROVIDER_virtual/libiconv ?= "glibc"
-PREFERRED_PROVIDER_virtual/libintl ?= "glibc"
-PREFERRED_PROVIDER_virtual/libc = "glibc"
-PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}libc-initial = "glibc-initial"
-PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}libc-for-gcc = "glibc"
-
-# glibc is configured for OLDEST_KERNEL kernel version, so we set minimal
-# sane versions there
-
-OLDEST_KERNEL ?= "2.4.0"
-
-# ARM OABI is fine with 2.4.0, EABI is not, so we override on "-gnueabi"
-# TARGET_OS here, not on architecture which is 'arm' in both cases
-OLDEST_KERNEL_linux-gnueabi ?= "2.6.14"
-OLDEST_KERNEL_sparc64 ?= "2.4.21"
-OLDEST_KERNEL_ppc64 ?= "2.4.21"
diff --git a/recipes/meta/external-toolchain-generic.bb b/recipes/meta/external-toolchain-generic.bb
index 6e87e88954..73f823f192 100644
--- a/recipes/meta/external-toolchain-generic.bb
+++ b/recipes/meta/external-toolchain-generic.bb
@@ -43,8 +43,8 @@ do_stage() {
cp -pPRr ${prefix}/deb/* ${DEPLOY_DIR_DEB}/
fi
-# if [ -d ${prefix}/pstage -a "x${DEPLOY_DIR_PSTAGE}" != "x" ]; then
-# install -d ${DEPLOY_DIR_PSTAGE}/
-# cp -pPRr ${prefix}/pstage/* ${DEPLOY_DIR_PSTAGE}/
-# fi
+ if [ -d ${prefix}/pstage -a "x${DEPLOY_DIR_PSTAGE}" != "x" ]; then
+ install -d ${DEPLOY_DIR_PSTAGE}/
+ cp -pPRr ${prefix}/pstage/* ${DEPLOY_DIR_PSTAGE}/
+ fi
}