summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-01-05 14:00:41 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-01-05 15:35:17 +0100
commit86735426ecc1dfca73e8bfa64f2b2a019f8f97e0 (patch)
treef16f8b98bc0be12342bf3cbfb94c7d090250fd13
parenteb935b9ae4da3dc07f2479e80bbd548eb4bbbc14 (diff)
downloadopenembedded-86735426ecc1dfca73e8bfa64f2b2a019f8f97e0.tar.gz
qi: bump revision for sane-toolchain compatibility
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--conf/distro/include/sane-srcrevs.inc2
-rw-r--r--recipes/qi/files/sanitize-makefile.patch2
-rw-r--r--recipes/qi/qi.inc4
3 files changed, 4 insertions, 4 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index d79c7581a1..1e33306d28 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -278,7 +278,7 @@ QEMUSRCREV ?= "4242"
SRCREV_pn-qemu ?= "${QEMUSRCREV}"
SRCREV_pn-qemu-native ?= "${QEMUSRCREV}"
SRCREV_pn-qemu-sdk ?= "${QEMUSRCREV}"
-SRCREV_pn-qi ?= "3b8513d8b3d9615ebda605de4bda18371aa3f359"
+SRCREV_pn-qi ?= "c38b062a609f1442e6a9e13005cfbdfd59a5ac0d"
SRCREV_pn-remoko ?= "148"
SRCREV_pn-remoko-server ?= "148"
SRCREV_pn-s3c24xx-gpio ?= "4949"
diff --git a/recipes/qi/files/sanitize-makefile.patch b/recipes/qi/files/sanitize-makefile.patch
index cd1abf3f58..69f34f8cfb 100644
--- a/recipes/qi/files/sanitize-makefile.patch
+++ b/recipes/qi/files/sanitize-makefile.patch
@@ -6,7 +6,7 @@ Index: git/Makefile
include config.mk
--BUILD_DATE := $(shell date)
+-BUILD_DATE := $(shell date --iso-8601=seconds)
-BUILD_HOST := $(shell hostname)
-BUILD_BRANCH := $(shell git branch | grep ^\* | cut -d' ' -f2)
-BUILD_HEAD := $(shell git show --pretty=oneline | head -n1 | cut -d' ' -f1 | cut -b1-16)
diff --git a/recipes/qi/qi.inc b/recipes/qi/qi.inc
index 949a011463..f944390345 100644
--- a/recipes/qi/qi.inc
+++ b/recipes/qi/qi.inc
@@ -16,7 +16,7 @@ do_configure() {
BUILD_HOST=\$(shell hostname)
BUILD_VERSION=${PV}
-BUILD_DATE=\$(shell date)
+BUILD_DATE=\$(shell date --iso-8601=seconds)
# NOTE: The following depends on the fact that only one version of the cross-compiler
# has been built. If it bails out with something like: "| arm-linux-ld: 4.3.3: No such file or directory"
@@ -51,6 +51,6 @@ do_deploy () {
PACKAGE_ARCH = "${MACHINE_ARCH}"
do_deploy[dirs] = "${S}"
-addtask deploy before do_package after do_install
+addtask deploy before do_build after do_package
addtask quilt before do_patch after do_unpack
addtask svnrev before do_patch after do_quilt