summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Mueller <schnitzeltony@gmx.de>2010-09-02 14:48:46 +0000
committerKoen Kooi <koen@openembedded.org>2010-09-07 10:08:41 +0200
commit970c9cfb838a489f681844cb02189a1a956ecd8b (patch)
treeb81fa9fd5d623fab68478ea142b165bc98d0386f
parent8d9d249f128b14f6e0d9d8ed97265a4eb9bfdc8a (diff)
downloadopenembedded-970c9cfb838a489f681844cb02189a1a956ecd8b.tar.gz
clutter (+box2d +gtk): Bump to latest (stable) versions
* clutter has a known problem with fonts feor more details and workaround see http://lists.clutter-project.org/pipermail/clutter-devel-list/2010-September/000070.html * clutter-box2d_0.10.0_git has the introspection bug fixed upstream and a funny (patience) new demo in blockbox Signed-off-by: Andreas Mueller <schnitzeltony@gmx.de> Acked-by: Koen Kooi <k-kooi@ti.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/clutter/clutter-box2d_0.10.0_git.bb12
-rw-r--r--recipes/clutter/clutter-gtk_0.10.6.bb10
-rw-r--r--recipes/clutter/clutter_1.2.12.bb36
3 files changed, 58 insertions, 0 deletions
diff --git a/recipes/clutter/clutter-box2d_0.10.0_git.bb b/recipes/clutter/clutter-box2d_0.10.0_git.bb
new file mode 100644
index 0000000000..4696a01c79
--- /dev/null
+++ b/recipes/clutter/clutter-box2d_0.10.0_git.bb
@@ -0,0 +1,12 @@
+require clutter-box2d.inc
+
+SRCREV = "4e72b9c135a9439b82d801c62422531db611f98b"
+
+PR = "${INC_PR}.0"
+PR_append = "+git${SRCREV}"
+
+SRC_URI = "git://git.clutter-project.org/clutter-box2d.git;protocol=git \
+ file://example-data-location.patch \
+ "
+
+S = "${WORKDIR}/git"
diff --git a/recipes/clutter/clutter-gtk_0.10.6.bb b/recipes/clutter/clutter-gtk_0.10.6.bb
new file mode 100644
index 0000000000..ab66c7765d
--- /dev/null
+++ b/recipes/clutter/clutter-gtk_0.10.6.bb
@@ -0,0 +1,10 @@
+require clutter-gtk.inc
+
+PR = "${INC_PR}.1"
+
+SRC_URI = "http://source.clutter-project.org/sources/clutter-gtk/0.10/clutter-gtk-${PV}.tar.bz2 \
+ "
+
+SRC_URI[md5sum] = "e7407392b14d6cddd9d4f86feaa9bd3f"
+SRC_URI[sha256sum] = "c65ec1e6b2932ed23b3db145357a96ae5ec7cb0666139468eba781d6c56a5371"
+
diff --git a/recipes/clutter/clutter_1.2.12.bb b/recipes/clutter/clutter_1.2.12.bb
new file mode 100644
index 0000000000..a454544c67
--- /dev/null
+++ b/recipes/clutter/clutter_1.2.12.bb
@@ -0,0 +1,36 @@
+require clutter.inc
+
+PR = "${INC_PR}.1"
+
+SRC_URI = "http://source.clutter-project.org/sources/clutter/1.2/clutter-${PV}.tar.bz2 \
+ ${INC_SRC_URI} \
+ "
+
+# recommended for --clutter-debug / --cogl-debug params
+BASE_CONF += " --enable-debug"
+
+do_configure_prepend() {
+ # align the test data location *.c (V1.2 uses macro ASSETS_DIR for path in *.c)
+ for i in $(find ${S}/tests -name Makefile.am) ; do
+ sed -i -e 's:$(top_srcdir)/tests/data:${datadir}/${PN}-tests:g' $i
+ done
+}
+
+do_compile_prepend() {
+ rebuild_shader_sources ${S}/clutter/cogl/cogl/driver/gles
+ # align test data location *.json
+ for full_name in $(find ${S}/tests/data -name *.png -o -name *.json) ; do
+ data_name=${full_name##*/}
+ for i in $(find ${S}/tests -name *.json) ; do
+ sed -i -e s:${data_name}:${datadir}/${PN}-tests/${data_name}:g $i
+ done
+ done
+}
+
+do_install() {
+ autotools_do_install
+ install_tests
+}
+
+SRC_URI[md5sum] = "76f70e765adcf7146be1ceb50bafa14f"
+SRC_URI[sha256sum] = "4582e6579897374d1f8ce51daa330311ebb90033fad95d5f076c1e9392b4ae68"