summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-06-08 14:22:42 -0700
committerKhem Raj <raj.khem@gmail.com>2010-06-08 14:24:27 -0700
commit9d886cd149d1ed68dfb82ca0a4a01112a187ea05 (patch)
tree40a8eceb66c4666ce43756aa1084dc9520398bc3
parent65af999427ce1bd3f2aa8f30bc69720f63c574f0 (diff)
downloadopenembedded-9d886cd149d1ed68dfb82ca0a4a01112a187ea05.tar.gz
libpam_1.1.0.bb: Add patch to fix running with DB5
* Imported from gentoo bug #319831 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/pam/libpam-1.1.0/define-HAVE_DBM.patch12
-rw-r--r--recipes/pam/libpam_1.1.0.bb3
2 files changed, 14 insertions, 1 deletions
diff --git a/recipes/pam/libpam-1.1.0/define-HAVE_DBM.patch b/recipes/pam/libpam-1.1.0/define-HAVE_DBM.patch
new file mode 100644
index 0000000000..eceb67dc3b
--- /dev/null
+++ b/recipes/pam/libpam-1.1.0/define-HAVE_DBM.patch
@@ -0,0 +1,12 @@
+Index: Linux-PAM-1.1.0/modules/pam_userdb/pam_userdb.c
+===================================================================
+--- Linux-PAM-1.1.0.orig/modules/pam_userdb/pam_userdb.c 2010-06-08 14:19:25.147555285 -0700
++++ Linux-PAM-1.1.0/modules/pam_userdb/pam_userdb.c 2010-06-08 14:20:50.707692049 -0700
+@@ -30,6 +30,7 @@
+ #else
+ # ifdef HAVE_DB_H
+ # define DB_DBM_HSEARCH 1 /* use the dbm interface */
++# define HAVE_DBM /* for BerkDB 5.0 and later */
+ # include <db.h>
+ # else
+ # error "failed to find a libdb or equivalent"
diff --git a/recipes/pam/libpam_1.1.0.bb b/recipes/pam/libpam_1.1.0.bb
index 3e8837649b..b54e81a3f9 100644
--- a/recipes/pam/libpam_1.1.0.bb
+++ b/recipes/pam/libpam_1.1.0.bb
@@ -15,7 +15,7 @@ DEPENDS = "flex flex-native"
# PAM is not a lot of use without configuration files and the plugins
RRECOMMENDS_${PN} = "libpam-meta libpam-base-files"
-PR = "r1"
+PR = "r2"
# The project is actually called Linux-PAM but that gives
# a bad OE package name because of the upper case characters
@@ -26,6 +26,7 @@ S = "${WORKDIR}/${p}"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/libs/pam/library/${p}.tar.bz2 \
file://pam-nodocs.patch \
file://fix_disabled_nls.patch \
+ file://define-HAVE_DBM.patch \
"
UCLIBC_PATCHES = " file://pam-disable-nis-on-uclibc.patch \