summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-11-11 14:11:12 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-11-11 14:11:12 +0000
commitb043fd916d4e8ab4a823b0ebd4eb5ab336ff2baf (patch)
treed5a17c1b511361ebc574607e71e4eee5200edd37
parent24f65d8096e185714b50b1e0bef084ea8cc8392d (diff)
downloadopenembedded-b043fd916d4e8ab4a823b0ebd4eb5ab336ff2baf.tar.gz
recipes: Fix recipes using do_stage_append or do_stage_prepend directly against base.bbclass
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
-rw-r--r--recipes/blackbox/blackbox_0.70.1.bb3
-rw-r--r--recipes/freesmartphone/fso-term_git.bb4
-rw-r--r--recipes/gcc/mingw-gcc-build.inc2
-rw-r--r--recipes/gob2/gob2_2.0.14.bb2
-rw-r--r--recipes/perl/libhtml-mason-perl_1.35.bb4
-rw-r--r--recipes/perl/liblog-dispatch-perl_2.13.bb4
-rw-r--r--recipes/perl/libmodule-build-perl_0.2805.bb4
-rw-r--r--recipes/pkgconfig/pkgconfig.inc2
8 files changed, 21 insertions, 4 deletions
diff --git a/recipes/blackbox/blackbox_0.70.1.bb b/recipes/blackbox/blackbox_0.70.1.bb
index 05010f97bb..0376f99980 100644
--- a/recipes/blackbox/blackbox_0.70.1.bb
+++ b/recipes/blackbox/blackbox_0.70.1.bb
@@ -16,6 +16,7 @@ EXTRA_OECONF = "--disable-i18n --without-imlib --with-xpm --with-gnome-menus"
do_install_append() {
sed -i s#${STAGING_LIBDIR}#${libdir}#g ${D}/${libdir}/pkgconfig/libbt.pc
}
-do_stage_append () {
+
+do_stage () {
sed -i s#${STAGING_LIBDIR}#${libdir}#g ${STAGING_LIBDIR}/pkgconfig/libbt.pc
}
diff --git a/recipes/freesmartphone/fso-term_git.bb b/recipes/freesmartphone/fso-term_git.bb
index e3f674d7cb..acb20cdb05 100644
--- a/recipes/freesmartphone/fso-term_git.bb
+++ b/recipes/freesmartphone/fso-term_git.bb
@@ -12,6 +12,10 @@ SRC_URI = "\
"
S = "${WORKDIR}/git"
+do_stage() {
+ :
+}
+
inherit autotools vala
FILES_${PN} += "${datadir}"
diff --git a/recipes/gcc/mingw-gcc-build.inc b/recipes/gcc/mingw-gcc-build.inc
index 4d7440f6d5..b79aab4a6a 100644
--- a/recipes/gcc/mingw-gcc-build.inc
+++ b/recipes/gcc/mingw-gcc-build.inc
@@ -34,7 +34,7 @@ do_configure () {
oe_runconf
}
-do_stage_append () {
+do_stage () {
# Fixup various .la files
sed -i -e "s|installed=yes|installed=no|" -e "s|dependency_libs\s*=\s*.*|dependency_libs='-L${STAGING_DIR_HOST}${layout_libdir} ${LIBGCCS_VAR} -lc -lm '|" ${STAGING_DIR_HOST}${layout_libdir}/libsupc++.la || true
sed -i -e "s|installed=yes|installed=no|" -e "s|dependency_libs\s*=\s*.*|dependency_libs='-L${STAGING_DIR_HOST}${layout_libdir} ${LIBGCCS_VAR} -lc -lm '|" ${STAGING_DIR_HOST}${layout_libdir}/libstdc++.la || true
diff --git a/recipes/gob2/gob2_2.0.14.bb b/recipes/gob2/gob2_2.0.14.bb
index eca8d13795..86f2f0979e 100644
--- a/recipes/gob2/gob2_2.0.14.bb
+++ b/recipes/gob2/gob2_2.0.14.bb
@@ -12,6 +12,6 @@ do_compile_prepend() {
find ${S} -name Makefile | xargs sed -i 's~-I$(includedir)~-I${STAGING_INCDIR}~g'
}
-do_stage_append() {
+do_stage() {
install -m 0644 ${S}/gob2.m4 ${STAGING_DATADIR}/aclocal
}
diff --git a/recipes/perl/libhtml-mason-perl_1.35.bb b/recipes/perl/libhtml-mason-perl_1.35.bb
index 71e96005e8..dfc6f3cc87 100644
--- a/recipes/perl/libhtml-mason-perl_1.35.bb
+++ b/recipes/perl/libhtml-mason-perl_1.35.bb
@@ -16,6 +16,10 @@ SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/HTML-Mason-${PV}.
S = "${WORKDIR}/HTML-Mason-${PV}"
+do_stage() {
+ :
+}
+
inherit cpan_build
do_install_append () {
diff --git a/recipes/perl/liblog-dispatch-perl_2.13.bb b/recipes/perl/liblog-dispatch-perl_2.13.bb
index ee4a2198c1..643deda664 100644
--- a/recipes/perl/liblog-dispatch-perl_2.13.bb
+++ b/recipes/perl/liblog-dispatch-perl_2.13.bb
@@ -7,4 +7,8 @@ SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Log-Dispatch-${PV
S = "${WORKDIR}/Log-Dispatch-${PV}"
+do_stage() {
+ :
+}
+
inherit cpan_build
diff --git a/recipes/perl/libmodule-build-perl_0.2805.bb b/recipes/perl/libmodule-build-perl_0.2805.bb
index 8a7ce9fa04..b7819fdebc 100644
--- a/recipes/perl/libmodule-build-perl_0.2805.bb
+++ b/recipes/perl/libmodule-build-perl_0.2805.bb
@@ -12,4 +12,8 @@ PR = "r5"
S = "${WORKDIR}/Module-Build-${PV}"
+do_stage() {
+ :
+}
+
inherit cpan_build
diff --git a/recipes/pkgconfig/pkgconfig.inc b/recipes/pkgconfig/pkgconfig.inc
index 495403eaf5..cb6bd0256e 100644
--- a/recipes/pkgconfig/pkgconfig.inc
+++ b/recipes/pkgconfig/pkgconfig.inc
@@ -21,6 +21,6 @@ do_configure_prepend () {
install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h glib-1.2.*/
}
-do_stage_prepend() {
+do_stage() {
install -d -m 0755 ${STAGING_LIBDIR}/pkgconfig
}