summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-09-09 12:47:15 -0700
committerTom Rini <tom_rini@mentor.com>2010-09-13 09:00:43 -0700
commitcadfaba4b534331bf3fbb03ab0a1685e595c12b9 (patch)
tree4942008c96edfef5bd626a7a738f77a1885ba611
parentb25356083ae610c859c7b21d967af65dd57ada1a (diff)
downloadopenembedded-cadfaba4b534331bf3fbb03ab0a1685e595c12b9.tar.gz
xfsdump: Switch to getting libtool from PATH
Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/xfsprogs/xfsdump_3.0.4.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes/xfsprogs/xfsdump_3.0.4.bb b/recipes/xfsprogs/xfsdump_3.0.4.bb
index 46a3d74116..f728aef096 100644
--- a/recipes/xfsprogs/xfsdump_3.0.4.bb
+++ b/recipes/xfsprogs/xfsdump_3.0.4.bb
@@ -3,6 +3,7 @@ HOMEPAGE = "http://oss.sgi.com/projects/xfs"
LICENSE = "GPL"
SECTION = "base"
DEPENDS = "xfsprogs"
+PR = "r1"
SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz"
SRC_URI[md5sum] = "af6932cfcd95ce64dc583128a190ffd7"
@@ -13,9 +14,10 @@ inherit autotools
EXTRA_OECONF = "--enable-gettext=no"
TARGET_CC_ARCH += "${LDFLAGS}"
+LIBTOOL = "${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
do_configure () {
- export LIBTOOL="${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool"
export DEBUG="-DNDEBUG"
oe_runconf
}