summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Dietze <di@fh-wedel.de>2009-05-20 00:36:25 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-20 10:16:06 +0200
commitcb70efeb71b3a1e5e8786d3488e4ec3a1580d45a (patch)
tree107d51ea437c6dea9543b984cdec70f3b6f34245
parent24db351c88feaa1b7ef23dd20a95d2ce78fb5bd4 (diff)
downloadopenembedded-cb70efeb71b3a1e5e8786d3488e4ec3a1580d45a.tar.gz
various nylon stuff: Updates to nylon-only code, needed to work with the current OE.
-rw-r--r--conf/distro/include/sane-srcdates.inc2
-rw-r--r--recipes/images/nylon-image-base.bb27
-rw-r--r--recipes/images/nylon-image-extended.bb1
-rw-r--r--recipes/images/nylon-image-standard.bb12
-rw-r--r--recipes/nylon/files/firewall-bash.diff8
-rw-r--r--recipes/nylon/files/simple-firewall-bash.diff8
-rw-r--r--recipes/nylon/nylon-config.bb41
-rw-r--r--recipes/nylon/nylon-scripts_cvs.bb6
-rw-r--r--recipes/nylon/nylon-statistics.bb5
-rw-r--r--recipes/nylon/simple-firewall.bb18
-rw-r--r--recipes/nylon/yamonenv.bb5
11 files changed, 114 insertions, 19 deletions
diff --git a/conf/distro/include/sane-srcdates.inc b/conf/distro/include/sane-srcdates.inc
index 114eaa3aea..15a8c00127 100644
--- a/conf/distro/include/sane-srcdates.inc
+++ b/conf/distro/include/sane-srcdates.inc
@@ -46,7 +46,7 @@ SRCDATE_waimea ?= "20060814"
SRCDATE_xcompmgr ?= "20060814"
SRCDATE_xirssi ?= "20060814"
SRCDATE_xsvg ?= "20060814"
-SRCDATE_yamonenv ?= "20060814"
+SRCDATE_yamonenv ?= "20051022"
SRCDATE_zaurusd ?= "20090501"
# Freedesktop.org
diff --git a/recipes/images/nylon-image-base.bb b/recipes/images/nylon-image-base.bb
index 27dc165800..416be1fae5 100644
--- a/recipes/images/nylon-image-base.bb
+++ b/recipes/images/nylon-image-base.bb
@@ -1,25 +1,36 @@
inherit image
inherit nylon-image
+IMAGE_FSTYPES = "jffs2 tar.gz"
+
export IMAGE_BASENAME = "nylon-base"
NYLON_BASE = "base-files base-passwd bash busybox \
ipkg initscripts less \
+ madwifi-modules \
mtd-utils \
+ nylon-scripts \
nano ncurses netbase \
- openssh sysvinit \
- tzdata tinylogin udev"
+ openssh \
+ pciutils \
+ sysvinit \
+ tinylogin \
+ tzdata \
+ wireless-tools wlan-ng-utils"
DEPENDS += "virtual/kernel less nano"
-IMAGE_INSTALL = "kernel less nano elvis-tiny \
- ${NYLON_BASE} ${BOOTSTRAP_EXTRA_RDEPENDS}"
## kernel 2.4 ##
-RDEPENDS_append_mtx-1 = " modutils modutils-initscripts modutils-depmod modutils-modinfo"
-RDEPENDS_append_mtx-2 = " modutils modutils-initscripts modutils-depmod modutils-modinfo"
+NYLON_IMAGE_RDEPENDS_mtx-1 = " modutils modutils-initscripts modutils-depmod modutils-modinfo"
+NYLON_IMAGE_RDEPENDS_mtx-2 = " modutils modutils-initscripts modutils-depmod modutils-modinfo"
## kernel 2.6 ##
-RDEPENDS_append_mtx-3 = " module-init-tools udev"
-RDEPENDS_append_mtx-3a = " module-init-tools"
+NYLON_IMAGE_RDEPENDS_mtx-3 = " module-init-tools udev"
+NYLON_IMAGE_RDEPENDS_mtx-3a = " module-init-tools"
+
+RDEPENDS_append = ${NYLON_IMAGE_RDEPENDS}
+
+IMAGE_INSTALL = "kernel less nano elvis-tiny \
+ ${NYLON_BASE} ${BOOTSTRAP_EXTRA_RDEPENDS} ${NYLON_IMAGE_RDEPENDS}"
IMAGE_LINGUAS = ""
diff --git a/recipes/images/nylon-image-extended.bb b/recipes/images/nylon-image-extended.bb
index 7a4e5b6c88..4fb324d52f 100644
--- a/recipes/images/nylon-image-extended.bb
+++ b/recipes/images/nylon-image-extended.bb
@@ -61,7 +61,6 @@ KERNEL_MODULES = " \
kernel-module-ds \
kernel-module-fat \
kernel-module-mii \
- kernel-module-pcmcia-core \
kernel-module-scsi-mod \
kernel-module-sd-mod \
kernel-module-usb-storage \
diff --git a/recipes/images/nylon-image-standard.bb b/recipes/images/nylon-image-standard.bb
index 5f79402c99..9238b0f8b2 100644
--- a/recipes/images/nylon-image-standard.bb
+++ b/recipes/images/nylon-image-standard.bb
@@ -3,15 +3,21 @@ require nylon-image-base.bb
export IMAGE_BASENAME = "nylon-standard"
NYLON_STANDARD = "\
- hostap-utils \
+ dash \
+ dnsmasq \
+ hostap-daemon hostap-utils \
linux-hotplug \
ifplugd \
+ iproute2 \
+ madwifi-modules \
+ nylon-config \
olsrd \
ppp \
rp-pppoe \
- shorewall \
+ simple-firewall \
tcpdump \
- wpa-supplicant"
+ wpa-supplicant \
+ yamonenv"
DEPENDS += "hostap-modules ntp \
${NYLON_STANDARD}"
diff --git a/recipes/nylon/files/firewall-bash.diff b/recipes/nylon/files/firewall-bash.diff
new file mode 100644
index 0000000000..044f8d813c
--- /dev/null
+++ b/recipes/nylon/files/firewall-bash.diff
@@ -0,0 +1,8 @@
+--- nylon-scripts/etc/init.d/firewall-orig 2009-04-25 13:46:25.000000000 +0200
++++ nylon-scripts/etc/init.d/firewall 2009-04-25 13:46:28.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/bin/bash
+
+ # this is a meta firewall start script:
+ # it either starts a local firewall script or shorewall
diff --git a/recipes/nylon/files/simple-firewall-bash.diff b/recipes/nylon/files/simple-firewall-bash.diff
new file mode 100644
index 0000000000..dc6cf0dd87
--- /dev/null
+++ b/recipes/nylon/files/simple-firewall-bash.diff
@@ -0,0 +1,8 @@
+--- simple-firewall/etc/init.d/simple-firewall-orig 2009-04-25 13:42:10.000000000 +0200
++++ simple-firewall/etc/init.d/simple-firewall 2009-04-25 13:42:16.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/bin/bash
+ #$HeadURL: http://gruen.4g/svn/branches/stable-1.0/application/simple-firewall/etc/init.d/simple-firewall $ $Rev: 2593 $
+
+ if [ -f /etc/firewall/firewall.conf ]; then
diff --git a/recipes/nylon/nylon-config.bb b/recipes/nylon/nylon-config.bb
new file mode 100644
index 0000000000..76f78a97f7
--- /dev/null
+++ b/recipes/nylon/nylon-config.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "nylon preliminary web configuration interface"
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
+LICENSE = "closed"
+DEPENDS = "perl virtual/kernel hostap-daemon busybox"
+RDEPENDS = "perl perl-module-exporter perl-module-posix perl-module-autoloader perl-module-strict perl-module-xsloader perl-module-data-dumper perl-module-carp perl-module-bytes perl-module-overload perl-module-warnings-register perl-module-warnings kernel-module-aes madwifi-modules hostap-daemon simple-firewall wlan-ng-utils busybox-httpd"
+CVSDATE = "20051026"
+PV = "cvs${CVSDATE}"
+
+SRC_URI = "http://br1.einfach.org/nylon/stable/sources/nylon-config_gruen.4g__20051026.tar.gz"
+S = "${WORKDIR}/${PN}"
+
+do_install() {
+ (cd ${S}; tar -c --exclude .svn -f - . ) | tar -C ${D} -xpf -
+ # chmod 600 ${D}/etc/certs/stunnel.key
+ chmod a+x ${D}/srv/www/cgi-bin/*
+}
+
+pkg_postinst() {
+#!/bin/sh
+if test "x$D" != "x"; then
+ exit 1
+fi
+
+# Create resolv.conf-link to ppp-file
+rm /etc/resolv.conf
+ln -s /etc/ppp/resolv.conf /etc/resolv.conf
+
+# enable factorydefaults
+update-rc.d factorydefaults start 90 2 .
+
+# "fix" /etc/network/interfaces
+perl -I /srv/www/cgi-bin -MConfig::IFace -e '$w=new Config::IFace(); $v = $w->read(); $v->{auto} = {0=>"lo",1=>eth0,2=>"wlan0",3=>"wlan1",4=>"ath0",5=>"ath1"}; $w->write($v)'
+
+update-rc.d busybox-httpd start 40 2 3 4 5 .
+/etc/init.d/busybox-httpd restart
+}
+
+FILES_${PN} += "/srv"
+
diff --git a/recipes/nylon/nylon-scripts_cvs.bb b/recipes/nylon/nylon-scripts_cvs.bb
index 650bd1a8e8..d87e2c11e1 100644
--- a/recipes/nylon/nylon-scripts_cvs.bb
+++ b/recipes/nylon/nylon-scripts_cvs.bb
@@ -4,12 +4,14 @@ DEPENDS = "hostap-utils"
SECTION = "base"
PRIORITY = "optional"
LICENSE = "GPLv2"
-SRCDATE = "20060923"
+#SRCDATE = "20060923"
+SRCDATE = "20051022"
PV = "1.0.0+cvs${SRCDATE}"
PR = "r2"
RDEPENDS = "bash"
-SRC_URI = "http://meshcube.org/download/${PN}_${SRCDATE}.tgz"
+SRC_URI = "http://download.berlin.freifunk.net/meshcube.org/nylon/stable/sources/${PN}_gruen.4g__${SRCDATE}.tar.gz \
+ file://firewall-bash.diff;patch=1"
S = "${WORKDIR}/${PN}"
INHIBIT_PACKAGE_STRIP = "1"
diff --git a/recipes/nylon/nylon-statistics.bb b/recipes/nylon/nylon-statistics.bb
index ef79bc6d31..c9b790cda0 100644
--- a/recipes/nylon/nylon-statistics.bb
+++ b/recipes/nylon/nylon-statistics.bb
@@ -3,11 +3,12 @@ RDEPENDS = "rrdtool"
SECTION = "base"
PRIORITY = "optional"
LICENSE = "GPLv2"
-SRCDATE = "20050909"
+#SRCDATE = "20050909"
+SRCDATE = "20051022"
PV = "1.0.0+cvs${SRCDATE}"
PR = "r1"
-SRC_URI = "http://meshcube.org/download/${PN}_${SRCDATE}.tgz"
+SRC_URI = "http://download.berlin.freifunk.net/meshcube.org/nylon/stable/sources/${PN}_gruen.4g__${SRCDATE}.tar.gz"
S = "${WORKDIR}/${PN}"
INHIBIT_PACKAGE_STRIP = "1"
diff --git a/recipes/nylon/simple-firewall.bb b/recipes/nylon/simple-firewall.bb
new file mode 100644
index 0000000000..d9e6974480
--- /dev/null
+++ b/recipes/nylon/simple-firewall.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "simple firewall configuratiopn script"
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "Bruno Randolf <br1@einfach.org>"
+LICENSE = "GPL"
+DEPENDS = "virtual/kernel"
+# these kernel modules are needed if the functionality is not hard-built into the kernel:
+# kernel-module-ip-tables kernel-module-iptable-filter kernel-module-iptable-nat kernel-module-ipt-state kernel-module-ipt-reject kernel-module-ipt-masquerade
+RDEPENDS = "kernel-module-ipt-limit kernel-module-ipt-tcpmss"
+PV = "cvs20051022"
+
+SRC_URI = "http://br1.einfach.org/nylon/stable/sources/simple-firewall_gruen.4g__20051022.tar.gz \
+ file://simple-firewall-bash.diff;patch=1"
+S = "${WORKDIR}/${PN}"
+
+do_install() {
+ (cd ${S}; tar -c --exclude .svn -f - . ) | tar -C ${D} -xpf -
+}
diff --git a/recipes/nylon/yamonenv.bb b/recipes/nylon/yamonenv.bb
index e963d913ee..1db737f042 100644
--- a/recipes/nylon/yamonenv.bb
+++ b/recipes/nylon/yamonenv.bb
@@ -2,10 +2,11 @@ DESCRIPTION = "Reads YAMON environment-variables"
SECTION = "base"
PRIORITY = "optional"
LICENSE = "GPL"
-SRCDATE = "20050909"
+#SRCDATE = "20050909"
+SRCDATE = "20051022"
PV = "1.0.0+cvs${SRCDATE}"
-SRC_URI = "http://meshcube.org/download/${PN}_${SRCDATE}.tgz"
+SRC_URI = "http://download.berlin.freifunk.net/meshcube.org/nylon/stable/sources/${PN}_gruen.4g__${SRCDATE}.tar.gz"
S = "${WORKDIR}/${PN}"
do_install() {