summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2010-09-07 13:07:25 +0200
committerStefan Schmidt <stefan@datenfreihafen.org>2010-09-07 13:09:24 +0200
commitd70dc036b73dd71332e5ff662280bbd8f3401c3b (patch)
treec12898ffa889f8f2864513b15a32a7581bcc2f44
parent970c9cfb838a489f681844cb02189a1a956ecd8b (diff)
downloadopenembedded-d70dc036b73dd71332e5ff662280bbd8f3401c3b.tar.gz
netbase: Add interface file for imote2 and bump PR
We need to set 'auto usb0' here to avoid some random kernel oops when trying to to gadget_ethernet.
-rw-r--r--recipes/netbase/netbase/imote2/interfaces84
-rw-r--r--recipes/netbase/netbase_4.21.bb2
2 files changed, 85 insertions, 1 deletions
diff --git a/recipes/netbase/netbase/imote2/interfaces b/recipes/netbase/netbase/imote2/interfaces
new file mode 100644
index 0000000000..74de5016bc
--- /dev/null
+++ b/recipes/netbase/netbase/imote2/interfaces
@@ -0,0 +1,84 @@
+# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
+
+# The loopback interface
+auto lo
+iface lo inet loopback
+
+
+# Wireless interfaces
+#
+# Example of an unencrypted (no WEP or WPA) wireless connection
+# that connects to any available access point:
+#
+iface wlan0 inet dhcp
+ wireless_mode managed
+ wireless_essid any
+#
+#
+# Same as above but locked to a specific access point:
+#
+#iface wlan0 inet dhcp
+# wireless_mode managed
+# wireless-essid some-essid
+#
+# A WEP encrypted connection locked to a specific access point:
+#
+#iface wlan0 inet dhcp
+# wireless-essid some-essid
+# wireless-key s:My-PlainText-Password
+# wireless-mode managed
+#
+# A WPA1 or WPA2 encrypted connection locked to a specific access point.
+# This is the best option for non-roaming, single-network usage.
+# Note that your card may require a firmware update to use WPA.
+# Some distributions install a temporary volatile firmware update on ifup.
+#
+#iface wlan0 inet dhcp
+# wpa-essid some-essid
+# wpa-psk My-PlainText-Password
+#
+# A WPA1 or WPA2 encrypted connection using an external configuration file
+# for wpa-supplicant. This is the way to go if you need to configure multiple
+# networks with different keys and / or WPA settings and roaming support.
+#
+# iface wlan0 inet dhcp
+# wpa-conf /etc/wpa_supplicant.conf
+# wpa-driver hostap
+
+
+
+iface atml0 inet dhcp
+
+# Wired or wireless interfaces
+auto eth0
+iface eth0 inet dhcp
+iface eth1 inet dhcp
+
+# Ethernet/RNDIS gadget (g_ether)
+# ... or on host side, usbnet and random hwaddr
+auto usb0
+iface usb0 inet static
+ address 192.168.0.202
+ netmask 255.255.255.0
+ network 192.168.0.0
+ gateway 192.168.0.200
+
+
+# Zaurus 2.4 Lineo net_fd; obsolete
+iface usbd0 inet static
+ address 192.168.129.201
+ netmask 255.255.255.0
+ network 192.168.129.0
+ gateway 192.168.129.200
+
+# iPAQ 2.4 mach-sa1100/usb-eth
+# (192.168.0.202 is the iPAQ's IP, 192.168.0.200 is the host's IP)
+iface usbf inet static
+ address 192.168.0.202
+ netmask 255.255.255.0
+ network 192.168.0.0
+ gateway 192.168.0.200
+
+# Bluetooth networking
+iface bnep0 inet dhcp
+
diff --git a/recipes/netbase/netbase_4.21.bb b/recipes/netbase/netbase_4.21.bb
index 9938d6e5e9..311f8c744f 100644
--- a/recipes/netbase/netbase_4.21.bb
+++ b/recipes/netbase/netbase_4.21.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "This package provides the necessary \
infrastructure for basic TCP/IP based networking."
SECTION = "base"
LICENSE = "GPLv2"
-PR = "r44"
+PR = "r45"
inherit update-rc.d