aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-11-01 16:38:21 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-11-01 16:38:21 +0100
commit2d365ab53b5497bafeb5893912746fdb15cdf88b (patch)
treeab89585ad0fcee355b2b9c1770525f70c64912ed
parent9393ac7170efdc97c6dc03f54a5f074c6005b1eb (diff)
downloadopenembedded-2d365ab53b5497bafeb5893912746fdb15cdf88b.tar.gz
mythtv: updated staging, fixed configure; renamed recipe
-rw-r--r--recipes/mythtv/mythtv-0.21+0.22rc1/configure.patch61
-rw-r--r--recipes/mythtv/mythtv_0.21+0.22rc1.bb (renamed from recipes/mythtv/mythtv_0.22rc1.bb)7
2 files changed, 65 insertions, 3 deletions
diff --git a/recipes/mythtv/mythtv-0.21+0.22rc1/configure.patch b/recipes/mythtv/mythtv-0.21+0.22rc1/configure.patch
new file mode 100644
index 0000000000..748c88d9fc
--- /dev/null
+++ b/recipes/mythtv/mythtv-0.21+0.22rc1/configure.patch
@@ -0,0 +1,61 @@
+Index: mythtv/configure
+===================================================================
+--- mythtv/configure (revision 22430)
++++ mythtv/configure (working copy)
+@@ -919,27 +919,27 @@
+ #deprecated, use check_lib or check_lib2 instead
+ has_library()
+ {
+- if test -f /etc/ld.so.conf ; then
+- LIBPATHS=`cat /etc/ld.so.conf | grep -v "#" | grep -v "include"`
+- else
+- LIBPATHS=''
+- fi
++ LIBPATHS=''
++ if test "x${sysroot}" = "x" ; then
++ if test -f /etc/ld.so.conf ; then
++ LIBPATHS=`cat /etc/ld.so.conf | grep -v "#" | grep -v "include"`
++ fi
++ LIBPATHS="$LIBPATHS `echo $LD_LIBRARY_PATH | sed s/':'/' '/g` "
++ # Mac OS X has a different variable for this:
++ LIBPATHS="$LIBPATHS `echo $DYLD_LIBRARY_PATH | sed s/':'/' '/g` "
+
+- LIBPATHS="$LIBPATHS `echo $LD_LIBRARY_PATH | sed s/':'/' '/g` "
+- # Mac OS X has a different variable for this:
+- LIBPATHS="$LIBPATHS `echo $DYLD_LIBRARY_PATH | sed s/':'/' '/g` "
+-
+- # recurse down just one level, should be enough in most cases
+- if test -f /etc/ld.so.conf ; then
+- INCL=`cat /etc/ld.so.conf | grep -v "#" | grep "^include"`
+- SRCH=`echo "$INCL" | sed '{ s/^include \//\//; s/^include /\/etc\//}'`
+- for x in $SRCH ; do
+- LP_APPEND=`cat $x | grep -v "#" | grep -v "^include"`
+- LIBPATHS="$LIBPATHS $LP_APPEND"
+- done
++ # recurse down just one level, should be enough in most cases
++ if test -f /etc/ld.so.conf ; then
++ INCL=`cat /etc/ld.so.conf | grep -v "#" | grep "^include"`
++ SRCH=`echo "$INCL" | sed '{ s/^include \//\//; s/^include /\/etc\//}'`
++ for x in $SRCH ; do
++ LP_APPEND=`cat $x | grep -v "#" | grep -v "^include"`
++ LIBPATHS="$LIBPATHS $LP_APPEND"
++ done
++ fi
+ fi
+
+- LIBPATHS="`echo $LIBPATHS /$libdir_name /usr/$libdir_name /usr/local/$libdir_name /usr/X11R6/$libdir_name | sed s/'\/ '/' '/g` "
++ LIBPATHS="`echo $LIBPATHS $sysroot/$libdir_name $sysroot/usr/$libdir_name $sysroot/usr/local/$libdir_name $sysroot/usr/X11R6/$libdir_name | sed s/'\/ '/' '/g` "
+
+ HAS_IT="no"
+ for LIBPATH in $LIBPATHS ; do
+@@ -4252,8 +4252,8 @@
+ # -L from early in the link line, to ignore any old installed libmyth*
+ # Note: Qt uses QMAKE_INCDIR_QT to build an absolute path for include
+ # directories, it cannot be modified.
+-QMAKE_LIBDIR_QT -= $libdir
+-LATE_LIBS += -L$libdir
++QMAKE_LIBDIR_QT -= ${sysroot}${libdir}
++LATE_LIBS += -L${sysroot}${libdir}
+ EOF
+
+ diff $TMPH $MYTH_CONFIG_H >/dev/null 2>&1
diff --git a/recipes/mythtv/mythtv_0.22rc1.bb b/recipes/mythtv/mythtv_0.21+0.22rc1.bb
index 8e95d0d99c..95f04e5132 100644
--- a/recipes/mythtv/mythtv_0.22rc1.bb
+++ b/recipes/mythtv/mythtv_0.21+0.22rc1.bb
@@ -5,10 +5,12 @@ inherit qmake2 qt4x11
DEFAULT_PREFERENCE = "-1"
PV = "0.21+0.22rc1"
-PR = "r3"
+PR = "r4"
REALPV = "0.22"
-SRC_URI = "ftp://ftp.osuosl.org/pub/mythtv/mythtv-0.22rc1.tar.bz2"
+SRC_URI = "ftp://ftp.osuosl.org/pub/mythtv/mythtv-0.22rc1.tar.bz2 \
+ file://configure.patch;patch=1 \
+ "
S = "${WORKDIR}/mythtv-0.22rc1"
@@ -115,7 +117,6 @@ do_stage() {
install -m 0644 ${D}/${includedir}/${PN}/libswscale/*.h ${STAGING_INCDIR}/${PN}/libswscale
install -m 0644 ${D}/${includedir}/${PN}/mpeg2dec/*.h ${STAGING_INCDIR}/${PN}/mpeg2dec
install -m 0644 ${D}/${includedir}/${PN}/upnp/*.h ${STAGING_INCDIR}/${PN}/upnp
- sed -i 's:LIBDIR=/usr/lib:LIBDIR=${STAGING_LIBDIR}:' ${STAGING_INCDIR}/${PN}/mythconfig.mak
# next part may need to be done better
cp -R ${D}/${libdir}/* ${STAGING_LIBDIR}
# ugly chmod ahead