aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrijesh Singh <bksingh@ti.com>2009-10-29 17:50:31 -0500
committerKoen Kooi <koen@openembedded.org>2009-11-02 13:40:10 +0100
commit5a9d128fc9c4ff5f731ede82502ad80b0ccb37ee (patch)
tree8b0640afe9ba2f790cff779e2b75517b31516f46
parent5eae1a8b24fb96f1e28ebdc348ea150058e1edda (diff)
downloadopenembedded-5a9d128fc9c4ff5f731ede82502ad80b0ccb37ee.tar.gz
task-gstreamer-ti: do not install gst-ti on am3517 platform
-rw-r--r--recipes/tasks/task-gstreamer-ti.bb30
1 files changed, 20 insertions, 10 deletions
diff --git a/recipes/tasks/task-gstreamer-ti.bb b/recipes/tasks/task-gstreamer-ti.bb
index cf05c7ce6b..e7e13e5635 100644
--- a/recipes/tasks/task-gstreamer-ti.bb
+++ b/recipes/tasks/task-gstreamer-ti.bb
@@ -1,18 +1,28 @@
-# Task for dsp accelerated gstreamer plugins
+# Task for installing gstreamer plugins on TI platforms
-PR = "r1"
+PR = "r2"
-DEPENDS = "gst-plugins-base gst-plugins-bad gst-plugins-good gst-plugins-ugly gst-ffmpeg gstreamer-ti gst-openmax"
+DEPENDS = "gst-plugins-base gst-plugins-bad gst-plugins-good gst-plugins-ugly"
+
+GST_CODEC_ELEMENT = " \
+ gstreamer-ti \
+ gstreamer-ti-demo-script \
+"
+
+GST_CODEC_ELEMENT_am3517-evm = "\
+ gst-ffmpeg \
+ gst-omapfb \
+"
RDEPENDS_${PN} = " \
-gst-plugins-base-meta \
-gst-plugins-good-meta \
-gst-plugins-bad-meta \
-gst-plugins-ugly-meta \
-gst-ffmpeg \
-gst-openmax \
-gstreamer-ti \
+ gst-plugins-base-meta \
+ gst-plugins-good-meta \
+ gst-plugins-bad-meta \
+ gst-plugins-ugly-meta \
+ ${GST_CODEC_ELEMENT} \
"
inherit task
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+