aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2011-09-08 09:57:14 +0000
committerAndreas Oberritter <obi@opendreambox.org>2011-09-08 10:02:48 +0000
commit4f4ed88bc7caa3d2b0b44ae2f51907aa9e68fc1b (patch)
treed0b9e9e6f590c2aa408b2d87df70118bd3b93ffc
parent85438f28491211c00b87a7c396efe569a9cb7ef1 (diff)
downloadopenembedded-4f4ed88bc7caa3d2b0b44ae2f51907aa9e68fc1b.tar.gz
libdca: fix sed failing on unpack
sed: can't read [...]/libdca/*.{ch}: No such file or directory Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--recipes/libdca/libdca_0.0.5-3.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes/libdca/libdca_0.0.5-3.bb b/recipes/libdca/libdca_0.0.5-3.bb
index 5bc023a5b4..67b311e6d4 100644
--- a/recipes/libdca/libdca_0.0.5-3.bb
+++ b/recipes/libdca/libdca_0.0.5-3.bb
@@ -1,6 +1,7 @@
DESCRIPTION = "decoding library for DTS Coherent Acoustics streams"
SECTION = "libs/multimedia"
LICENSE = "GPLv2+"
+PR = "r1"
SRC_URI = "git://git.debian.org/pkg-multimedia/${PN}.git;protocol=git"
@@ -12,7 +13,7 @@ inherit autotools lib_package pkgconfig
do_unpackpost() {
QUILT_PATCHES=debian/patches quilt push -a
# single precision is enough and speeds up libdca by about 10-15%
- sed -i -e 's/double/sample_t/g' ${S}/libdca/*.{ch}
+ sed -i -e 's/double/sample_t/g' ${S}/libdca/*.c ${S}/libdca/*.h
}
addtask unpackpost after do_unpack before do_patch