aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteffen Sledz <sledz@dresearch-fe.de>2011-09-15 18:53:22 +0000
committerSteffen Sledz <sledz@dresearch-fe.de>2011-09-19 09:33:26 +0200
commit508b49eedc2b051e92e89741040bb514eea70c1d (patch)
tree8b8a38a114fca950303b57385e267e68602dfd5a
parentb16d53e4800ac85e24f9388efb20c9fbd60beca3 (diff)
downloadopenembedded-508b49eedc2b051e92e89741040bb514eea70c1d.tar.gz
linux-2.6.28: allow building with GNU make >= 3.82
GNU make >= 3.82 does not allow mixed implicit and normal rules Signed-off-by: Steffen Sledz <sledz@dresearch-fe.de>
-rw-r--r--recipes/linux/linux-2.6.28/make-3.82.patch40
-rw-r--r--recipes/linux/linux_2.6.28.bb3
2 files changed, 42 insertions, 1 deletions
diff --git a/recipes/linux/linux-2.6.28/make-3.82.patch b/recipes/linux/linux-2.6.28/make-3.82.patch
new file mode 100644
index 0000000000..c22717e2da
--- /dev/null
+++ b/recipes/linux/linux-2.6.28/make-3.82.patch
@@ -0,0 +1,40 @@
+linux-2.6.28: allow building with GNU make >= 3.82
+
+GNU make >= 3.82 does not allow mixed implicit and normal rules
+
+Because linux-2.6.28 is superseded by newer versions it makes no sense
+to submit this patch upstream.
+
+Upstream-Status: Inappropriate [other]
+
+Signed-off-by: Steffen Sledz <sledz@dresearch-fe.de>
+
+diff -Nurd linux-2.6.28.orig//Makefile linux-2.6.28/Makefile
+--- linux-2.6.28.orig//Makefile 2011-09-14 16:15:53.782945380 +0200
++++ linux-2.6.28/Makefile 2011-09-14 16:16:50.887123688 +0200
+@@ -439,7 +439,11 @@
+ include $(srctree)/arch/$(SRCARCH)/Makefile
+ export KBUILD_DEFCONFIG KBUILD_KCONFIG
+
+-config %config: scripts_basic outputmakefile FORCE
++config: scripts_basic outputmakefile FORCE
++ $(Q)mkdir -p include/linux include/config
++ $(Q)$(MAKE) $(build)=scripts/kconfig $@
++
++%config: scripts_basic outputmakefile FORCE
+ $(Q)mkdir -p include/linux include/config
+ $(Q)$(MAKE) $(build)=scripts/kconfig $@
+
+@@ -1607,7 +1611,11 @@
+ $(Q)$(MAKE) $(build)=$(build-dir) $(target-dir)$(notdir $@)
+
+ # Modules
+-/ %/: prepare scripts FORCE
++/: prepare scripts FORCE
++ $(cmd_crmodverdir)
++ $(Q)$(MAKE) KBUILD_MODULES=$(if $(CONFIG_MODULES),1) \
++ $(build)=$(build-dir)
++%/: prepare scripts FORCE
+ $(cmd_crmodverdir)
+ $(Q)$(MAKE) KBUILD_MODULES=$(if $(CONFIG_MODULES),1) \
+ $(build)=$(build-dir)
diff --git a/recipes/linux/linux_2.6.28.bb b/recipes/linux/linux_2.6.28.bb
index 9cbb15e032..1356378ac8 100644
--- a/recipes/linux/linux_2.6.28.bb
+++ b/recipes/linux/linux_2.6.28.bb
@@ -1,6 +1,6 @@
require linux.inc
-PR = "r15"
+PR = "r16"
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
@@ -18,6 +18,7 @@ DEFAULT_PREFERENCE_mini6410 = "1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.28.tar.bz2;name=kernel \
${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.10.bz2;apply=yes;name=stablepatch \
+ file://make-3.82.patch \
file://defconfig"
SRC_URI_append_at91sam9263ek = " \