aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Cavallini <m.cavallini@koansoftware.com>2011-10-26 12:08:45 +0200
committerMarco Cavallini <m.cavallini@koansoftware.com>2011-10-26 12:08:45 +0200
commitb9103c3e4fc289093550b17b07ae6575fe05664d (patch)
treedd8cdfe06c94d871996a7a743cb5f4f8a443a148
parent57fbdd9741e0b8445fd3007efc8b18bcb5e0dbe4 (diff)
downloadopenembedded-b9103c3e4fc289093550b17b07ae6575fe05664d.zip
openembedded-b9103c3e4fc289093550b17b07ae6575fe05664d.tar.gz
openembedded-b9103c3e4fc289093550b17b07ae6575fe05664d.tar.bz2
kaeilos.conf: updated KaeilOS version
-rw-r--r--conf/distro/kaeilos.conf56
1 files changed, 27 insertions, 29 deletions
diff --git a/conf/distro/kaeilos.conf b/conf/distro/kaeilos.conf
index e7080be..ae2f4b1 100644
--- a/conf/distro/kaeilos.conf
+++ b/conf/distro/kaeilos.conf
@@ -4,20 +4,20 @@
#@DESCRIPTION: KaeilOS Linux Distribution for Kernel 2.6 based devices
# This version is strictly conformed to Angstrom
#@MAINTAINER: Marco Cavallini <m.cavallini@koansoftware.com>
-#@VERSION: 23-09-2011
+#@VERSION: 25-10-2011
#
# KaeilOS is a registered trade mark of KOAN - Bergamo - Italia
# Use this at your own risk, we welcome bugreports filed at
# Product website : http://www.KaeilOS.com
#@--------------------------------------------------------------------
-DISTRO_VERSION = "2011.3-${DATE}"
-DISTRO_REVISION = "3"
-DISTRO_PR = ".8"
+DISTRO_VERSION = "v${@time.strftime('%Y.%m',time.gmtime())}"
+DISTRO_REVISION = "4"
+DISTRO_PR = ".9"
OLDEST_KERNEL ?= "2.6.16"
-require conf/distro/include/kaeilos-2009-preferred-versions.inc
+require conf/distro/include/kaeilos-2011-preferred-versions.inc
require conf/distro/include/preferred-opie-versions-1.2.5.inc
# Java VM
@@ -47,14 +47,7 @@ IMAGE_LINGUAS = '${@base_less_or_equal("ROOT_FLASH_SIZE", "16", "", "en-us", d)}
EXTRA_IMAGECMD_ext2 = "-i 4096"
# set feed path variables
-FEED_BASEPATH = "feeds/unstable/${ANGSTROM_PKG_FORMAT}/${LIBC}/"
-
-
-#The angstrom-mirrors.bbclass should have everything, but we can use this as a fallback
-CVS_TARBALL_STASH ?= "\
- http://www.angstrom-distribution.org/unstable/sources/ \
- "
-
+FEED_BASEPATH = "feeds/next/${ANGSTROM_PKG_FORMAT}/${LIBC}/"
#Make sure we use 2.6 on machines with a 2.4/2.6 selector
KERNEL = "kernel26"
@@ -64,23 +57,18 @@ PCMCIA_MANAGER = "pcmciautils"
#Preferred version for the kernel on various machines
PREFERRED_VERSION_linux-handhelds-2.6 ?= "2.6.21-hh20"
-#Initramfs for kernels
-#KERNEL_INITRAMFS_DIR = "${TMPDIR}/deploy/uclibc/images/${MACHINE}/"
-#KERNEL_INITRAMFS_PATH = "${KERNEL_INITRAMFS_DIR}/$(readlink ${KERNEL_INITRAMFS_DIR}initramfs-bootmenu-image-${MACHINE}.cpio.gz)"
-
#This is unrelated to the kernel version, but userspace apps (e.g. HAL) require a recent version to build against
-LINUX_LIBC_HEADERS_VERSION ?= "2.6.31"
+LINUX_LIBC_HEADERS_VERSION ?= "2.6.37"
PREFERRED_VERSION_linux-libc-headers = "${LINUX_LIBC_HEADERS_VERSION}"
PREFERRED_VERSION_linux-libc-headers-native = "${LINUX_LIBC_HEADERS_VERSION}"
-# see into glibc-package.bbclass : added KaeilOS hack supporting glibc 2.9
#Prefer glibc 2.6 and uclibc 0.9.30, these have had the most testing.
-PREFERRED_VERSION_glibc ?= "2.9"
-PREFERRED_VERSION_glibc-initial ?= "2.9"
+PREFERRED_VERSION_glibc ?= "2.10.1"
+PREFERRED_VERSION_glibc-initial ?= "2.10.1"
PREFERRED_VERSION_uclibc ?= "0.9.30.2"
PREFERRED_VERSION_uclibc-initial ?= "0.9.30.2"
-PREFERRED_VERSION_eglibc ?= "2.9"
-PREFERRED_VERSION_eglibc-initial ?= "2.9"
+PREFERRED_VERSION_eglibc ?= "2.12"
+PREFERRED_VERSION_eglibc-initial ?= "2.12"
#powerpc needs additional patches to gcc
ANGSTROM_GCC_VERSION_ppc405 ?= "4.1.1"
@@ -102,11 +90,9 @@ ANGSTROM_GCC_VERSION_avr32 ?= "4.2.2"
ANGSTROM_GCC_VERSION_armv4 ?= "4.4.2"
#Everybody else can just use this:
-ANGSTROM_GCC_VERSION ?= "4.3.3"
+ANGSTROM_GCC_VERSION ?= "4.5"
-ANGSTROM_BINUTILS_VERSION ?= "2.18"
-ANGSTROM_BINUTILS_VERSION_armv4 ?= "2.20"
-ANGSTROM_BINUTILS_VERSION_armv7a ?= "2.18.50.0.7"
+ANGSTROM_BINUTILS_VERSION ?= "2.20.1"
PREFERRED_VERSION_binutils ?= "${ANGSTROM_BINUTILS_VERSION}"
PREFERRED_VERSION_binutils-cross ?= "${ANGSTROM_BINUTILS_VERSION}"
@@ -127,7 +113,7 @@ PREFERRED_PROVIDER_dbus-glib = "dbus-glib"
PREFERRED_PROVIDER_hotplug = "udev"
PREFERRED_PROVIDER_opkg ?= "opkg"
-# see recipes/bluez/bluez4*.bb for further dependencies of this setting
+# Remaining some Angstrom stuff
ANGSTROM_BLACKLIST_pn-bluez-libs = "bluez-libs 3.x has been replaced by bluez4"
ANGSTROM_BLACKLIST_pn-bluez-utils = "bluez-utils 3.x has been replaced by bluez4"
@@ -135,7 +121,16 @@ ANGSTROM_BLACKLIST_pn-fso-apm = "regular apmd is good enough"
ANGSTROM_BLACKLIST_pn-ipkg = "ipkg has been superseded by opkg"
-ANGSTROMLIBC ?= "glibc"
+ANGSTROM_BLACKLIST_pn-bash-noemu = "doesn't work on the target"
+
+ANGSTROM_BLACKLIST_pn-hotplug-ng = "hotplug functionality is provided by udev"
+ANGSTROM_BLACKLIST_pn-hotplug2 = "hotplug functionality is provided by udev"
+ANGSTROM_BLACKLIST_pn-linux-hotplug = "hotplug functionality is provided by udev"
+
+ANGSTROM_BLACKLIST_pn-xcursor-watchonly-theme = "xcursor-transparent-theme is good enough"
+
+PREFERRED_PROVIDER_ffmpeg = "libav"
+ANGSTROM_BLACKLIST_pn-ffmpeg = "libav is the preferred multimedia library"
require conf/distro/include/kaeilos.inc
@@ -143,6 +138,9 @@ require conf/distro/include/kaeilos.inc
require conf/distro/include/toolchain-${TOOLCHAIN_TYPE}.inc
require conf/distro/include/arm-thumb.inc
+# Set DISTRO_FEED_CONFIGS to our config var, assigned in the above .inc
+DISTRO_FEED_CONFIGS = "${ANGSTROM_FEED_CONFIGS}"
+
# If we're using an .ipk based rootfs, we want to have opkg installed so postinst script can run
# We also take this opportunity to inject angstrom-version and the feed configs into the rootfs
IPKG_VARIANT = "opkg angstrom-version ${ANGSTROM_FEED_CONFIGS}"