aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf_samuelsson@telia.com>2011-11-16 15:22:33 +0100
committerUlf Samuelsson <ulf_samuelsson@telia.com>2011-11-21 17:02:21 +0100
commitc4344f1949d1dbc3a5a823e41b25f56af1a13793 (patch)
treed7bcb488513bc63e561ee05bd60fe2dbcb9828be
parentf4e51537e8bb0f0f31d0c1d5e27bbbf6315954b2 (diff)
downloadopenembedded-c4344f1949d1dbc3a5a823e41b25f56af1a13793.tar.gz
at91sam9m10-vdec: Add new recipe to use SAM9M10 H/W decoder
Signed-off-by: Ulf Samuelsson <ulf.samuelsson@telia.com>
-rw-r--r--recipes/at91sam9m10-vdec/gst-plugin-on2-8170_1.0.bb43
-rw-r--r--recipes/at91sam9m10-vdec/on2-8170-libs_1.0.bb51
2 files changed, 94 insertions, 0 deletions
diff --git a/recipes/at91sam9m10-vdec/gst-plugin-on2-8170_1.0.bb b/recipes/at91sam9m10-vdec/gst-plugin-on2-8170_1.0.bb
new file mode 100644
index 0000000000..087b1e7f5c
--- /dev/null
+++ b/recipes/at91sam9m10-vdec/gst-plugin-on2-8170_1.0.bb
@@ -0,0 +1,43 @@
+# This is the support library for AT91SAM9M10 On2 8170 video decoder.
+DESCRIPTION = "Library for AT91SAM9M10 On2 8170 video decoder"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = ""
+
+COMPATIBLE_MACHINE = (at91sam9m10ekes|at91sam9m10g45ek|at91sam9m10g45|at91sam9x5ek)
+
+PR = "r1"
+
+DEPENDS = "glib-2.0 gstreamer on2-8170-libs"
+CFLAGS += "-I${STAGING_INCDIR}/glib-2.0 -I${STAGING_INCDIR}/gstreamer-0.10 -I${STAGING_INCDIR}/libxml2/ -I${STAGING_LIBDIR}/glib-2.0/include"
+GST_MAJORMINOR=0.10
+PROVIDES += "gstx170"
+
+SRC_URI = "ftp://ftp.linux4sam.org/pub/demo/linux4sam_1.9/codec/gst-plugin-x170-${PV}.tar.gz"
+SRC_URI[md5sum] = "bd8a8a1cc31dd37f18b1614f503226f4"
+SRC_URI[sha256sum] = "734ded3618246d946b53c2c8c7ab5a0961287485aaef5fb9bf874f93e3caa342"
+S = ${WORKDIR}/gst-plugin-x170-${PV}
+
+inherit autotools
+
+FILES_${PN} = " \
+ ${libdir}/gstreamer-${GST_MAJORMINOR}/*.so \
+ "
+
+FILES_${PN}-dev = " \
+ ${libdir}/gstreamer-${GST_MAJORMINOR}/*.so \
+ ${libdir}/gstreamer-${GST_MAJORMINOR}/*.a \
+ ${libdir}/gstreamer-${GST_MAJORMINOR}/*.la \
+ "
+
+do_stage() {
+ echo staging ...
+ oe_libinstall -s -a -C ${S}/src/.libs libgstx170 ${STAGING_LIBDIR}
+ install -m 0644 ${S}/src/gstx170.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+ echo install ...
+ install -d ${D}/${libdir}/gstreamer-${GST_MAJORMINOR}
+ oe_libinstall -s -C ${S}/src/.libs/ libgstx170 ${D}/${libdir}/gstreamer-${GST_MAJORMINOR}
+}
diff --git a/recipes/at91sam9m10-vdec/on2-8170-libs_1.0.bb b/recipes/at91sam9m10-vdec/on2-8170-libs_1.0.bb
new file mode 100644
index 0000000000..c011bc607d
--- /dev/null
+++ b/recipes/at91sam9m10-vdec/on2-8170-libs_1.0.bb
@@ -0,0 +1,51 @@
+# This is the support library for Hantro X170 video decoder.
+DESCRIPTION = "Library for Hantro X170 video decoder"
+SECTION = "libs"
+PRIORITY = "optional"
+
+COMPATIBLE_MACHINE = (at91sam9m10ekes|at91sam9m10g45ek|at91sam9m10g45|at91sam9x5ek)
+
+PR = "r1"
+PROVIDES += "hantro-libs"
+SRC_URI ="file://on2-8170-libs-1.0.tar.gz"
+SRC_URI[md5sum] = "6dbdf510d16f120df9072ca7a25b1804"
+SRC_URI[sha256sum] = "db7390a13e7c0426894a6f966ecde1f89e6566416088c50729750e800306a2de"
+
+inherit autotools
+S = ${WORKDIR}/on2-8170-libs-${PV}
+
+FILES_${PN} = " \
+ ${libdir}/*.so \
+ "
+
+FILES_${PN}-dev = " \
+ ${libdir}/*.so \
+ ${libdir}/*.a \
+ ${libdir}/*.la \
+ ${includedir}/*.h \
+ "
+
+#SRC_URI_append = ""
+
+do_stage() {
+ oe_libinstall -s -a -C ${S} libdwlx170 ${STAGING_LIBDIR}
+ oe_libinstall -s -a -C ${S} libdecx170h ${STAGING_LIBDIR}
+ oe_libinstall -s -a -C ${S} libx170j ${STAGING_LIBDIR}
+ oe_libinstall -s -a -C ${S} libdecx170m2 ${STAGING_LIBDIR}
+ oe_libinstall -s -a -C ${S} libdecx170m ${STAGING_LIBDIR}
+ oe_libinstall -s -a -C ${S} libdecx170p ${STAGING_LIBDIR}
+ oe_libinstall -s -a -C ${S} libdecx170v ${STAGING_LIBDIR}
+
+ install -m 0644 ${S}/*.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+ oe_libinstall -s -C ${S} libdwlx170 ${D}/${libdir}/
+ oe_libinstall -s -C ${S} libdecx170h ${D}/${libdir}/
+ oe_libinstall -s -C ${S} libx170j ${D}/${libdir}/
+ oe_libinstall -s -C ${S} libdecx170m2 ${D}/${libdir}/
+ oe_libinstall -s -C ${S} libdecx170m ${D}/${libdir}/
+ oe_libinstall -s -C ${S} libdecx170p ${D}/${libdir}/
+ oe_libinstall -s -C ${S} libdecx170v ${D}/${libdir}/
+}
+