aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTodd Kempel <todd.kempel@gmail.com>2011-11-14 09:17:42 -0600
committerPaul Menzel <paulepanter@users.sourceforge.net>2011-11-14 20:36:05 +0100
commitee6171aee5f69f079bf87dd143f80899bddd6755 (patch)
treea979b65b66833a7ede8bc1edf4478262c6ce7f8a
parent77edf34b704b3a8d5dc2e82de0614878f4467de3 (diff)
downloadopenembedded-ee6171aee5f69f079bf87dd143f80899bddd6755.tar.gz
batctl: Add version 2011.3.0 (initial recipe)
* batmand is included in the current OE repository but is not being actively maintained. The batman-adv kernel module is a replacement for batmand and requires batctl for operation. Recipe has been tested and binary found fully operational using Ȧngström on gumstix board. Signed-off-by: Todd Kempel <todd.kempel@gmail.com> Correct license from GPL to GPLv2+. From `bat-hosts.c`: /* * Copyright (C) 2007-2011 B.A.T.M.A.N. contributors: * * Andreas Langer <an.langer@gmx.de>, Marek Lindner <lindner_marek@yahoo.de> * * This program is free software; you can redistribute it and/or * modify it under the terms of version 2 of the GNU General Public * License as published by the Free Software Foundation. * * This program is distributed in the hope that it will be useful, but * WITHOUT ANY WARRANTY; without even the implied warranty of * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU * General Public License for more details. * * You should have received a copy of the GNU General Public License * along with this program; if not, write to the Free Software * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA * 02110-1301, USA * */ Build tested with `angstrom-2010.x` and `minimal{,uclibc}` for `MACHINE = "beagleboard"`. Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
-rw-r--r--recipes/batctl/batctl.inc20
-rw-r--r--recipes/batctl/batctl_2011.3.0.bb6
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes/batctl/batctl.inc b/recipes/batctl/batctl.inc
new file mode 100644
index 0000000000..cc13b4c2df
--- /dev/null
+++ b/recipes/batctl/batctl.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "Control application for B.A.T.M.A.N. routing protocol kernel module for multi-hop ad-hoc mesh networks."
+HOMEPAGE = "http://www.open-mesh.net/"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPLv2+"
+
+INC_PR = "r0"
+
+RDEPENDS_${PN} = "kernel-module-batman-adv"
+
+SRC_URI = "http://downloads.open-mesh.net/batman/stable/sources/batctl/batctl-${PV}.tar.gz"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 batctl ${D}${bindir}
+}
diff --git a/recipes/batctl/batctl_2011.3.0.bb b/recipes/batctl/batctl_2011.3.0.bb
new file mode 100644
index 0000000000..97d8e174ba
--- /dev/null
+++ b/recipes/batctl/batctl_2011.3.0.bb
@@ -0,0 +1,6 @@
+require batctl.inc
+PR = "${INC_PR}.0"
+
+
+SRC_URI[md5sum] = "8eb197896049bb04a6beef56015a16b6"
+SRC_URI[sha256sum] = "94922fd167d2bca5193cc7465bfc212c2c3595da70e653506493dfc65e4410fb"