aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-01-06 17:12:34 +0100
committerKoen Kooi <koen@openembedded.org>2011-01-06 17:13:55 +0100
commit0d63bd4a601342e25da0a3c8dc2cfeff2d9546e4 (patch)
tree3350ef86628935a1caf07feba675b93c3308b26a
parent8eb70199bbca34e74829514afb72e2cb1d430976 (diff)
downloadopenembedded-0d63bd4a601342e25da0a3c8dc2cfeff2d9546e4.tar.gz
ti-ocf-crypto-module: remove hardcodes from makefile
Signed-off-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/ti/ti-ocf-crypto-module_1.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes/ti/ti-ocf-crypto-module_1.0.bb b/recipes/ti/ti-ocf-crypto-module_1.0.bb
index 3f8f248d2e..92c6cb047c 100644
--- a/recipes/ti/ti-ocf-crypto-module_1.0.bb
+++ b/recipes/ti/ti-ocf-crypto-module_1.0.bb
@@ -17,6 +17,11 @@ inherit module
PR = "${MACHINE_KERNEL_PR}+svnr${SRCPV}"
+# Fix silly hardcodes, module.bbclass puts in the *correct* values
+do_compile_prepend() {
+ sed -i 's:ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi-::g' Makefile
+}
+
do_install () {
install -d ${D}/lib/modules/${KERNEL_VERSION}/crypto/ocf/
install -m 0755 ${S}/ocf_omap3_cryptok.ko ${D}/lib/modules/${KERNEL_VERSION}/crypto/ocf/