aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-01-05 15:06:41 +0100
committerKoen Kooi <koen@openembedded.org>2011-01-05 15:15:38 +0100
commit2bb663abd461b04663b0459f54a133dc844b4eb4 (patch)
tree0559a5dd6f05c178d60f663f8eb730ab0625474b
parent4aaf290289ff8b9e43793b7052a8f30ea631312f (diff)
downloadopenembedded-2bb663abd461b04663b0459f54a133dc844b4eb4.tar.gz
gstreamer-ti: fix build with recent toolchains
Signed-off-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/ti/gstreamer-ti.inc16
1 files changed, 15 insertions, 1 deletions
diff --git a/recipes/ti/gstreamer-ti.inc b/recipes/ti/gstreamer-ti.inc
index 905e192ee7..4da1bab81d 100644
--- a/recipes/ti/gstreamer-ti.inc
+++ b/recipes/ti/gstreamer-ti.inc
@@ -15,7 +15,7 @@ require ti-paths.inc
require ti-staging.inc
# Rebuild on kernel change since it links statically to ti-dmai, ti-codec-engine, etc
-PR = "r81+${MACHINE_KERNEL_PR}"
+PR = "r82+${MACHINE_KERNEL_PR}"
DEPENDS = "ti-dmai gstreamer gst-plugins-base"
@@ -79,6 +79,20 @@ do_configure_prepend() {
if ! [ -e ${STAGING_KERNEL_DIR}/include/linux/omapfb.h ] ; then
sed -i -e s:linux/omapfb:mach/omapfb:g ${S}/src/omapfb.h || true
fi
+
+ # Fix up linkerscripts, recent toolchains need -T to prepend the default script to the custom one
+ for makefile in $(find ${S} -name "Makefile.am") ; do
+ sed -i -e 's:-Wl,$(XDC_CONFIG_BASENAME)/linker.cmd:-Wl,-T,$(XDC_CONFIG_BASENAME)/linker.cmd:g' $makefile
+ done
+}
+
+do_compile() {
+ # Recent kernel headers warn against inclusion from userspace
+ for makefile in $(find ${S} -name "Makefile") ; do
+ sed -i -e s:-Werror::g $makefile
+ done
+
+ oe_runmake
}
do_install_prepend () {