aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2011-01-08 22:38:28 +0300
committerRoman I Khimov <khimov@altell.ru>2011-01-09 07:17:46 +0300
commit3d030ffa57af27275fbb42eaa0fcd611f4925348 (patch)
tree39315c040d8312ada128de4fd050886eed93955b
parent6a9b1f15df1b7481755e9c9607f47bac069d6873 (diff)
downloadopenembedded-3d030ffa57af27275fbb42eaa0fcd611f4925348.tar.gz
perl: blacklist perl-module-cpanplus-internals-source-sqlite for perl-modules
It has runtime dependencies on libdbd-sqlite-perl and libdbix-simple-perl which doesn't get built automatically if not required as build time dependency for something. It's not possible to add them as build time dependencies for perl itself since they're in turn depend on perl making a circular dependency (and they _really_ depend on perl because they build binaries, so no way to cheat by making this recipes not to depend on perl). It's also not correct to downgrade this runtime dependency to recommendation, since the module is really unusable without its dependencies. The most annoying thing about all this is that this dependency situation renders perl-modules package uninstallable by itself, failing with something like: Collected errors: * satisfy_dependencies_for: Cannot satisfy the following dependencies for task-sdk-native: * libdbd-sqlite-perl * libdbix-simple-perl * So the best way to solve it IMO is to just blacklist it from perl-modules since the value of this module is questionable. It's experimental CPANPLUS backend that's not used by default, you have to specifically configure your perl to use it. And if you _really_ want to use it - the module package itself will still contain proper dependencies, you just need to get them built and installed. The problem only exists in perl 5.10.1, but 5.8.8 doesn't have this module, so blacklisting in common .inc doesn't hurt. Signed-off-by: Roman I Khimov <khimov@altell.ru> Acked-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/perl/perl.inc2
-rw-r--r--recipes/perl/perl_5.10.1.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes/perl/perl.inc b/recipes/perl/perl.inc
index ddde0b8872..3d8b9bbcca 100644
--- a/recipes/perl/perl.inc
+++ b/recipes/perl/perl.inc
@@ -1,7 +1,7 @@
# helper functions for perl
def all_perl_packages(d):
depchains = (d.getVar("DEPCHAIN_POST", True) or "").split()
- blacklist = ["perl-modules", "perl-misc", "perl-pod", "perl-doc"]
+ blacklist = ["perl-modules", "perl-misc", "perl-pod", "perl-doc", "perl-module-cpanplus-internals-source-sqlite", "perl-module-cpanplus-internals-source-sqlite-tie"]
for pkg in d.getVar("PACKAGES", True).split():
if not pkg in blacklist and not any(pkg.endswith(post) for post in depchains):
yield pkg
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index 4e6bc331f5..33ddffef78 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPLv1+"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r19"
+PR = "r20"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"