aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-01-06 09:51:42 +0100
committerKoen Kooi <koen@openembedded.org>2011-01-06 10:08:26 +0100
commit3f3a8b2c700cd3127718d8be0ddbd21418c384a8 (patch)
tree729f9e86e577875e8807e942af52dc0f7bcaa33c
parent676cbb54d42c89a4832871064cfcb7ee2ad372ee (diff)
downloadopenembedded-3f3a8b2c700cd3127718d8be0ddbd21418c384a8.tar.gz
c6accel/dmai/gst-ti: only fix up linkerscript when using gcc >4.3.x
Signed-off-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/ti/gstreamer-ti.inc13
-rw-r--r--recipes/ti/ti-c6accel.inc7
-rw-r--r--recipes/ti/ti-c6accel_1.01.00.03.bb1
-rw-r--r--recipes/ti/ti-dmai.inc11
-rw-r--r--recipes/ti/ti-dmai_svn.bb2
5 files changed, 22 insertions, 12 deletions
diff --git a/recipes/ti/gstreamer-ti.inc b/recipes/ti/gstreamer-ti.inc
index 4da1bab81d..8d355e0e93 100644
--- a/recipes/ti/gstreamer-ti.inc
+++ b/recipes/ti/gstreamer-ti.inc
@@ -15,7 +15,7 @@ require ti-paths.inc
require ti-staging.inc
# Rebuild on kernel change since it links statically to ti-dmai, ti-codec-engine, etc
-PR = "r82+${MACHINE_KERNEL_PR}"
+PR = "r83+${MACHINE_KERNEL_PR}"
DEPENDS = "ti-dmai gstreamer gst-plugins-base"
@@ -80,10 +80,13 @@ do_configure_prepend() {
sed -i -e s:linux/omapfb:mach/omapfb:g ${S}/src/omapfb.h || true
fi
- # Fix up linkerscripts, recent toolchains need -T to prepend the default script to the custom one
- for makefile in $(find ${S} -name "Makefile.am") ; do
- sed -i -e 's:-Wl,$(XDC_CONFIG_BASENAME)/linker.cmd:-Wl,-T,$(XDC_CONFIG_BASENAME)/linker.cmd:g' $makefile
- done
+ # Angstrom 2008 breaks with -Wl,-T, while angstrom 2010 needs it
+ if [ $(${TARGET_PREFIX}gcc -dumpversion | awk -F. '{print $2}') -gt 3 ] ; then
+ # Fix up linkerscripts, recent toolchains need -T to prepend the default script to the custom one
+ for makefile in $(find ${S} -name "Makefile.am") ; do
+ sed -i -e 's:-Wl,$(XDC_CONFIG_BASENAME)/linker.cmd:-Wl,-T,$(XDC_CONFIG_BASENAME)/linker.cmd:g' $makefile
+ done
+ fi
}
do_compile() {
diff --git a/recipes/ti/ti-c6accel.inc b/recipes/ti/ti-c6accel.inc
index 777ece246e..7d09783726 100644
--- a/recipes/ti/ti-c6accel.inc
+++ b/recipes/ti/ti-c6accel.inc
@@ -18,7 +18,7 @@ PROVIDES += "ti-c6accel-apps"
# This recipe links statically against kernel dependant stuff, use kernel PR as base and append a local version
PR = "${MACHINE_KERNEL_PR}"
-PR_append = "b"
+PR_append = "c"
S = "${WORKDIR}/c6accel_${PV}"
@@ -57,6 +57,11 @@ do_configure() {
unset VERBOSE
make ${TIARGS} clean
sed -i -e 's:-L$(LINUXLIBS_INSTALL_DIR)/lib:-L$(LINUXLIBS_INSTALL_DIR)/lib -L$(LINUXLIBS_INSTALL_DIR)/usr/lib ${LDFLAGS}:' ${S}/soc/app/Makefile
+
+ # Angstrom 2008 breaks with -Wl,-T, while angstrom 2010 needs it
+ if [ $(${TARGET_PREFIX}gcc -dumpversion | awk -F. '{print $2}') -gt 3 ] ; then
+ sed -i -e 's: $(XDC_CFG)/linker.cmd: -Wl,-T,$(XDC_CFG)/linker.cmd:g' ${S}/soc/app/Makefile
+ fi
}
do_compile() {
diff --git a/recipes/ti/ti-c6accel_1.01.00.03.bb b/recipes/ti/ti-c6accel_1.01.00.03.bb
index 15e2d058a3..bf5f1cf35b 100644
--- a/recipes/ti/ti-c6accel_1.01.00.03.bb
+++ b/recipes/ti/ti-c6accel_1.01.00.03.bb
@@ -5,7 +5,6 @@ SRC_URI[c6accelbin.sha256sum] = "453399a84bf117bd7a91393242c7c005e2829692db5ede1
SRC_URI_append = "file://fix-loadmodule.patch \
file://0001-soc-honour-buildsystem-CFLAGS-and-LDFLAGS-when-set.patch \
- file://0001-soc-app-fix-makefile-to-pass-Wl-T-before-the-linkers.patch \
"
PV = "1_01_00_03"
diff --git a/recipes/ti/ti-dmai.inc b/recipes/ti/ti-dmai.inc
index dff11caef1..c3a0f710d1 100644
--- a/recipes/ti/ti-dmai.inc
+++ b/recipes/ti/ti-dmai.inc
@@ -86,10 +86,13 @@ do_compile () {
sed -i -e s:-Werror::g $makefile
done
- # Fix up linkerscripts, recent toolchains need -T to prepend the default script to the custom one
- for appmakefile in $(find ${S} -name "Makefile.app") ; do
- sed -i -e 's: $(XDC_CFG)/linker.cmd: -Wl,-T,$(XDC_CFG)/linker.cmd:g' $appmakefile
- done
+ # Angstrom 2008 breaks with -Wl,-T, while angstrom 2010 needs it
+ if [ $(${TARGET_PREFIX}gcc -dumpversion | awk -F. '{print $2}') -gt 3 ] ; then
+ # Fix up linkerscripts, recent toolchains need -T to prepend the default script to the custom one
+ for appmakefile in $(find ${S} -name "Makefile.app") ; do
+ sed -i -e 's: $(XDC_CFG)/linker.cmd: -Wl,-T,$(XDC_CFG)/linker.cmd:g' $appmakefile
+ done
+ fi
# TODO :: Why do we do this?
unset DMAI_INSTALL_DIR
diff --git a/recipes/ti/ti-dmai_svn.bb b/recipes/ti/ti-dmai_svn.bb
index f7a5496fe3..374acce792 100644
--- a/recipes/ti/ti-dmai_svn.bb
+++ b/recipes/ti/ti-dmai_svn.bb
@@ -9,7 +9,7 @@ PV = "2_10_00_01+svnr${SRCPV}"
# This package has high dependence on kernel, use kernel PR as base and append a local version
PR = "${MACHINE_KERNEL_PR}"
-PR_append = "m"
+PR_append = "n"
DMAIBRANCH_dm6446 = "trunk"
DMAIBRANCH_dm6467 = "branches/GITPSP_INT_101009"