aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-01-05 16:17:31 -0700
committerTom Rini <tom_rini@mentor.com>2011-01-05 17:15:09 -0700
commit676cbb54d42c89a4832871064cfcb7ee2ad372ee (patch)
tree10da2ef87a3d419385e8130d88729538d0c72e70
parentc48983a2ef2e79508fe8545258ff9a09a4ddd6a8 (diff)
downloadopenembedded-676cbb54d42c89a4832871064cfcb7ee2ad372ee.tar.gz
klcc-cross: Add patch to use /usr/bin/env perl
Certain configurations (such as autobuilders) may build in very deep paths (that are longer than the #! mechanism allows) which makes it unsafe to use the direct path for perl. In our case we know that /usr/bin/env perl will always return ours (if it has been built). Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/klibc/klcc-cross_1.5.20.bb5
-rw-r--r--recipes/klibc/klibc-1.5.20/use-env-for-perl.patch17
2 files changed, 21 insertions, 1 deletions
diff --git a/recipes/klibc/klcc-cross_1.5.20.bb b/recipes/klibc/klcc-cross_1.5.20.bb
index 6b6d74d3b2..ef0144905c 100644
--- a/recipes/klibc/klcc-cross_1.5.20.bb
+++ b/recipes/klibc/klcc-cross_1.5.20.bb
@@ -1,7 +1,10 @@
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
require klibc.inc
require klibc-checksums_${PV}.inc
+
+SRC_URI += "file://use-env-for-perl.patch"
+
DEPENDS = "klibc"
FILESPATHPKG =. "klibc-${PV}:"
diff --git a/recipes/klibc/klibc-1.5.20/use-env-for-perl.patch b/recipes/klibc/klibc-1.5.20/use-env-for-perl.patch
new file mode 100644
index 0000000000..8609864251
--- /dev/null
+++ b/recipes/klibc/klibc-1.5.20/use-env-for-perl.patch
@@ -0,0 +1,17 @@
+---
+ klcc/makeklcc.pl | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: klibc-1.5.20/klcc/makeklcc.pl
+===================================================================
+--- klibc-1.5.20.orig/klcc/makeklcc.pl
++++ klibc-1.5.20/klcc/makeklcc.pl
+@@ -26,7 +26,7 @@ sub pathsearch($) {
+ return undef;
+ }
+
+-print "#!${perlpath}\n";
++print "#!/usr/bin/env perl\n";
+
+ open(KLIBCCONF, "< $klibcconf\0")
+ or die "$0: cannot open $klibcconf: $!\n";