aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-01-05 13:34:49 +0100
committerKoen Kooi <koen@openembedded.org>2011-01-05 13:53:36 +0100
commitff1cf74a1d8ea22035405eeab3b0422dd12da26e (patch)
treee60738fd6986818a10c30b228a298b0c223ce4c8
parent130843b39a7550239d6378f51e4e3e410b8ea3a3 (diff)
downloadopenembedded-ff1cf74a1d8ea22035405eeab3b0422dd12da26e.tar.gz
ti-dmai: fix build with recent kernel headers and recent toolchains
Signed-off-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/ti/ti-dmai.inc10
-rw-r--r--recipes/ti/ti-dmai_svn.bb2
2 files changed, 11 insertions, 1 deletions
diff --git a/recipes/ti/ti-dmai.inc b/recipes/ti/ti-dmai.inc
index 1bdaee15f8..dff11caef1 100644
--- a/recipes/ti/ti-dmai.inc
+++ b/recipes/ti/ti-dmai.inc
@@ -81,6 +81,16 @@ do_prepsources() {
addtask prepsources after do_unpack before do_patch
do_compile () {
+ # Recent kernel headers warn against inclusion from userspace
+ for makefile in $(find ${S} -name "Makefile") ; do
+ sed -i -e s:-Werror::g $makefile
+ done
+
+ # Fix up linkerscripts, recent toolchains need -T to prepend the default script to the custom one
+ for appmakefile in $(find ${S} -name "Makefile.app") ; do
+ sed -i -e 's: $(XDC_CFG)/linker.cmd: -Wl,-T,$(XDC_CFG)/linker.cmd:g' $appmakefile
+ done
+
# TODO :: Why do we do this?
unset DMAI_INSTALL_DIR
cd ${S}
diff --git a/recipes/ti/ti-dmai_svn.bb b/recipes/ti/ti-dmai_svn.bb
index de86b18832..f7a5496fe3 100644
--- a/recipes/ti/ti-dmai_svn.bb
+++ b/recipes/ti/ti-dmai_svn.bb
@@ -9,7 +9,7 @@ PV = "2_10_00_01+svnr${SRCPV}"
# This package has high dependence on kernel, use kernel PR as base and append a local version
PR = "${MACHINE_KERNEL_PR}"
-PR_append = "l"
+PR_append = "m"
DMAIBRANCH_dm6446 = "trunk"
DMAIBRANCH_dm6467 = "branches/GITPSP_INT_101009"