aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-03-05 16:30:30 +0100
committerKoen Kooi <koen@openembedded.org>2009-03-05 16:30:30 +0100
commit0af35468217f549c4cc78dddcbdd92d20313c985 (patch)
treec5ae326fe4f51f8d99d68ea7bfe1e0fc1a98decf
parent222487a1a7129c043cad30f8d628928fee22cebe (diff)
downloadopenembedded-0af35468217f549c4cc78dddcbdd92d20313c985.tar.gz
linux-omap, -pm: add patch to reset MUSB phy
-rw-r--r--packages/linux/linux-omap-pm/usbttyfix.patch29
-rw-r--r--packages/linux/linux-omap-pm_git.bb3
-rw-r--r--packages/linux/linux-omap/usbttyfix.patch29
-rw-r--r--packages/linux/linux-omap_2.6.28.bb3
4 files changed, 62 insertions, 2 deletions
diff --git a/packages/linux/linux-omap-pm/usbttyfix.patch b/packages/linux/linux-omap-pm/usbttyfix.patch
new file mode 100644
index 0000000000..997705a31b
--- /dev/null
+++ b/packages/linux/linux-omap-pm/usbttyfix.patch
@@ -0,0 +1,29 @@
+To get USB HOST mode working on USB OTG Port with USB TTY enabled U-boot
+
+Signed-off-by: Syed Mohammed Khasim <khasim@ti.com>
+---
+--- linux-2.6.git/drivers/usb/musb/omap2430.c 2009-01-19 22:42:18.000000000 +0530
++++ linux-2.6.git/drivers/usb/musb/omap2430.c 2009-02-19 12:45:22.000000000 +0530
+@@ -33,6 +33,7 @@
+ #include <linux/list.h>
+ #include <linux/clk.h>
+ #include <linux/io.h>
++#include <linux/i2c/twl4030.h>
+
+ #include <asm/mach-types.h>
+ #include <mach/hardware.h>
+@@ -233,6 +234,14 @@ int __init musb_platform_init(struct mus
+ omap_cfg_reg(AE5_2430_USB0HS_STP);
+ #endif
+
++ /* Reset MUSB Controller */
++ omap_writel(SOFTRST,OTG_SYSCONFIG);
++
++#if defined(CONFIG_TWL4030_USB)
++ /* Reset the TWL USB PHY */
++ twl4030_i2c_write_u8(TWL4030_MODULE_USB, 0x60, 0x4);
++#endif
++
+ musb->xceiv = *x;
+ musb_platform_resume(musb);
+
diff --git a/packages/linux/linux-omap-pm_git.bb b/packages/linux/linux-omap-pm_git.bb
index 6ee2109f5f..0da2b894b2 100644
--- a/packages/linux/linux-omap-pm_git.bb
+++ b/packages/linux/linux-omap-pm_git.bb
@@ -10,7 +10,7 @@ DEFAULT_PREFERENCE = "-1"
SRCREV = "65d02c2c7fe676369b7162459feec60268c7f4ba"
PV = "2.6.28-pm2+gitr${SRCREV}"
-PR = "r3"
+PR = "r4"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-omap-pm.git;protocol=git;branch=pm \
file://defconfig"
@@ -47,6 +47,7 @@ SRC_URI_append = " \
file://dss2.diff;patch=1 \
file://register-all-OPPs.diff;patch=1 \
file://add-cpufreq-for-omap3evm.diff;patch=1 \
+ file://usbttyfix.patch;patch=1 \
"
diff --git a/packages/linux/linux-omap/usbttyfix.patch b/packages/linux/linux-omap/usbttyfix.patch
new file mode 100644
index 0000000000..997705a31b
--- /dev/null
+++ b/packages/linux/linux-omap/usbttyfix.patch
@@ -0,0 +1,29 @@
+To get USB HOST mode working on USB OTG Port with USB TTY enabled U-boot
+
+Signed-off-by: Syed Mohammed Khasim <khasim@ti.com>
+---
+--- linux-2.6.git/drivers/usb/musb/omap2430.c 2009-01-19 22:42:18.000000000 +0530
++++ linux-2.6.git/drivers/usb/musb/omap2430.c 2009-02-19 12:45:22.000000000 +0530
+@@ -33,6 +33,7 @@
+ #include <linux/list.h>
+ #include <linux/clk.h>
+ #include <linux/io.h>
++#include <linux/i2c/twl4030.h>
+
+ #include <asm/mach-types.h>
+ #include <mach/hardware.h>
+@@ -233,6 +234,14 @@ int __init musb_platform_init(struct mus
+ omap_cfg_reg(AE5_2430_USB0HS_STP);
+ #endif
+
++ /* Reset MUSB Controller */
++ omap_writel(SOFTRST,OTG_SYSCONFIG);
++
++#if defined(CONFIG_TWL4030_USB)
++ /* Reset the TWL USB PHY */
++ twl4030_i2c_write_u8(TWL4030_MODULE_USB, 0x60, 0x4);
++#endif
++
+ musb->xceiv = *x;
+ musb_platform_resume(musb);
+
diff --git a/packages/linux/linux-omap_2.6.28.bb b/packages/linux/linux-omap_2.6.28.bb
index ff1c5d2521..9824d7e667 100644
--- a/packages/linux/linux-omap_2.6.28.bb
+++ b/packages/linux/linux-omap_2.6.28.bb
@@ -12,7 +12,7 @@ DEFAULT_PREFERENCE_overo = "1"
SRCREV = "79d042a081d3e467c735bb0d9569ed6296f85a3c"
PV = "2.6.28"
-PR = "r13"
+PR = "r14"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;branch=omap-2.6.28;protocol=git \
file://defconfig"
@@ -50,6 +50,7 @@ SRC_URI_append = " \
file://0001-ASoC-Add-support-for-OMAP3-EVM.patch;patch=1 \
file://0001-board-omap3beagle-set-i2c-3-to-100kHz.patch;patch=1 \
file://add-resizer-driver.patch;patch=1 \
+ file://usbttyfix.patch;patch=1 \
"